Yeastar S20 Please Help!

Here you can post your own working configurations of hardware or software to share with other users who may be using the same device!
Fongo recommends Fongo Home Phone for a fully supported Home Phone system for only $4.95/mo
Forum rules
DISCLAIMER
This forum is for those users who have already purchased a configuration file with the SIP settings needed to configure any SIP compatible device.

1. Please use this forum only as a means to share your configuration advice and guides for ATA devices and SIP clients that you are using with our service.
2. For any questions relating to device configuration, please use the other forum sections or post your question directly in the device topic that your question is meant for.
3. Please title your topics with only the name and model of your device so users can easily find the information they need.
4. Preferable format for posting here is compressing your screenshots of your successfully configured device into a .zip file, and post a brief description of the configuration.

Please stay on topic

Yeastar S20 Please Help!

Postby kjmj » 02/22/2017

Hi there,

I'm a longtime FPL user and have been running Asterisk virtualized for several years without issue. I wanted to add some redundancy so i decided to ditch virtualized Asterisk for a Yeastar S20 with a built in Cellular module to act as a failover for when the internet goes down.

The trunk and sip settings for the S20 seem a little different than any of the other PBXs' or ATAs i've I've configured in the past but I managed to get the device connected back to FPL.

Two problems: First,is inbound calls are drop approximately 32 seconds after the call is answered. Second, I don't hear the ringback tone when I make an outside call.

Please see screenshots of my current config from my S20 below.

Thank you in advance.

S20 ScreenShots.zip
(515.2 KiB) Downloaded 60 times

1.jpg
1.jpg (225.77 KiB) Viewed 747 times

2.jpg
2.jpg (115.44 KiB) Viewed 747 times


4.png
4.png (193.94 KiB) Viewed 747 times

5.PNG
5.PNG (82.08 KiB) Viewed 747 times
kjmj
Just Passing Thru
 
Posts: 21
Joined: 11/04/2012
SIP Device Name: PAP2T
ISP Name: Telus's
Computer OS: Win 7 Pro
Router: Linksys RV042

Re: Yeastar S20 Please Help!

Postby Liptonbrisk » 02/23/2017

I don't have the device you're using, but I would guess the problem is the ACK response isn't being received after the 200 OK status.

Have you tried using voip4.freephoneline.ca:6060 instead, which is intended to circumvent faulty SIP ALG functions in routers?

And/or have you tried disabling SIP ALG in whatever router(s) you're using?
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 882
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin


Return to Device Configuration Sharing

Who is online

Users browsing this forum: No registered users and 1 guest