obi202, recently cannot receive incoming call

Have a question or problem with your Fongo application? This forum is the place to get help from both staff and fellow community members.

obi202, recently cannot receive incoming call

Postby flybluesky » 01/10/2018

obi202, use it for years, but recently cannot receive incoming call, call side no ring tone and then goes voicemail. out call ok. anyone has the same problem ?
flybluesky
Just Passing Thru
 
Posts: 5
Joined: 01/10/2018
SIP Device Name: obi202
Firmware Version: 3.2.1.5775

Share On:

Re: obi202, recently cannot receive incoming call

Postby Fongo Support » 01/10/2018

flybluesky wrote:obi202, use it for years, but recently cannot receive incoming call, call side no ring tone and then goes voicemail. out call ok. anyone has the same problem ?

Hi,

Perhaps Do not disturb was enabled on your OBI?

Please login into the OBI and check this:

Voice Services -> SPx Service -> DoNotDisturbEnable: should be un checked

Please try and let us know.

Regards,
User avatar
Fongo Support
Site Moderator
 
Posts: 1663
Joined: 01/01/2013

Re: obi202, recently cannot receive incoming call

Postby Liptonbrisk » 01/10/2018

Please do what Fongo Support wrote.

Additionally, refer to pages 42 to 44 in the PDF guide located at viewtopic.php?f=15&t=18805#p73839
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 661
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2(Build: 5859EX)
ISP Name: Rogers Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: obi202, recently cannot receive incoming call

Postby flybluesky » 01/13/2018

thanks, check "DoNotDisturbEnable:", it is un checked, but still can not receive the incoming call
flybluesky
Just Passing Thru
 
Posts: 5
Joined: 01/10/2018
SIP Device Name: obi202
Firmware Version: 3.2.1.5775

Re: obi202, recently cannot receive incoming call

Postby Liptonbrisk » 01/13/2018

flybluesky wrote:thanks, check "DoNotDisturbEnable:", it is un checked, but still can not receive the incoming call


Follow the steps, slowly and carefully, listed on pages 42 to 44 of the PDF guide, and also use the guide to set up FPL's service properly.
You can also visit https://forums.redflagdeals.com/newegg- ... #p28531312 (follow the steps in the order listed, especially steps 1 to 15 at the bottom of the post)

A number of Obitalk.com default settings need to be changed for FPL. Some of the settings are wrong, as indicated on pages 5 and 6 of the PDF guide.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 661
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2(Build: 5859EX)
ISP Name: Rogers Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: obi202, recently cannot receive incoming call

Postby flybluesky » 01/13/2018

thanks

. use it for years, everything was good,.ISP & Router are same,

just recently, out call is good, but can not receive incoming call. try more times resetting as you said, out call is good. each time after setting retest, both side have ring tone when try incoming call, but receive side hear nothing.
and one more problem : after a few minters , try incoming call again , both side no ring tone and after a minuter goes to voicemail.
Attachments
214.jpg
214.jpg (84.3 KiB) Viewed 1066 times
213.jpg
213.jpg (96.95 KiB) Viewed 1066 times
212.jpg
212.jpg (97.64 KiB) Viewed 1066 times
211.jpg
211.jpg (77.66 KiB) Viewed 1066 times
flybluesky
Just Passing Thru
 
Posts: 5
Joined: 01/10/2018
SIP Device Name: obi202
Firmware Version: 3.2.1.5775

Re: obi202, recently cannot receive incoming call

Postby flybluesky » 01/13/2018

follow pictures
Attachments
217.jpg
217.jpg (160.52 KiB) Viewed 1066 times
216.jpg
216.jpg (120.72 KiB) Viewed 1066 times
215.jpg
215.jpg (129.03 KiB) Viewed 1066 times
flybluesky
Just Passing Thru
 
Posts: 5
Joined: 01/10/2018
SIP Device Name: obi202
Firmware Version: 3.2.1.5775

Re: obi202, recently cannot receive incoming call

Postby Liptonbrisk » 01/14/2018

flybluesky wrote:thanks

. use it for years, everything was good,.ISP & Router are same


Unfortunately, it doesn't really matter if everything worked well for you for years. NAT associations in routers can become corrupt without you doing anything.

Thanks to Mango, many of us now understand that in order for ATAs to remain registered and working properly
with a VoIP SIP provider like Freephoneline, in particular after power failures, the following conditions must be met:

UDP Unreplied Timeout (in your router) < NAT Keep-alive Interval (in your ATA; for Obihai ATAs this is X_KeepAliveExpires) < UDP Assured Timeout (in your router) < SIP Registration Failure Retry Wait Time (or RegisterRetryInterval in Obihai ATAs)

“<“ means less than.

A problem can occur when the Keep-Alive interval is greater than UDP Assured Timeout (often 180 by default in
consumer routers): the NAT hole will close due to the ATA not communicating frequently enough with the SIP server.
In turn, incoming calls may, intermittently, not reach the ATA. Again, X_Keepalives expires is supposed to be 20 with
FPL.

Getting access to both UDP Unreplied Timeout and UDP Assured Timeout settings in consumer routers may be
difficult, if not impossible. Asuswrt-Merlin, third party firmware for Asus routers, does offer easy access to these two
settings, which are found under General–>Tools-->Other settings. In part, for this reason, I tend to use Asus routers
that work with Asuswrt-Merlin. However, my understanding is that third party Tomato firmware has these two settings
as well. So if your router supports Tomato firmware, that may be another option.
The keep alive interval for FPL is 20. The SIP Registration Failure Retry Wait Time is 120. I use 10 for UDP
Unreplied Timeout and 117 for UDP Assured Timeout.

Typically, it's best to have your own router for VoIP.



out call is good. each time after setting retest, both side have ring tone when try incoming call, but receive side hear nothing. and one more problem : after a few minters , try incoming call again , both side no ring tone


This sounds like a corrupted NAT association/UPnP issue or SIP ALG related problem to me.

Test by using a regular landline or cellphone service (not VoIP) when making calls to or receiving calls from someone else.
If the other side is using a VoIP service, the problem could be on that user's end.


try more times resetting as you said



1) What does the registration status in your ATA indicate for Freephoneline?
Navigate to Status-->System Status-->SP(FPL) Service Status-->Status

What does the registration status state?

Registration isn't required for outgoing calls. It is required for incoming calls.

It's important to note that only one registration per FPL account is allowed at any given time.
If multiple devices are registered (or attempting registrations) with the same FPL account, only the most recently registered device will ring for incoming calls.
The others will not. Obviously, if your FPL SIP credentials are being used on another device or by someone else (even by a hacker) that can present problems.

With respect to registration being required to receive incoming calls, more than 5 registration attempts within 5 minutes can result in a temporary IP ban from the FPL proxy server being used.

From https://community.freepbx.org/t/trunk-s ... ca/22479/8
"As May 2013, our servers will rate limit REGISTER requests to a maximum of 10 requests per 5 minutes. Each authentication round usually consumes 2 requests (digest auth), so it is a fair number given our guidelines. Also, it does not affect INVITES (which are also authenticated)...

This rate limit is applied per IP address as our service is tailored to residential Canadian users (ADSL/Cable)."


2) Your X_keepalive related settings are wrong.
X_KeepAliveExpires should be 20
X_KeepAliveMsgType should be notify

3) In your Obihai ATA or at Obitalk.com, Navigate to Voice Services-->SP(FPL) Service-->X_UserAgentPort
Pick a new random number between 30000 and 60000, and don't post it this time

4) Try voip4.freephoneline.ca:6060 for the proxyserver just to see if there's some bug in your router despite SIP ALG being disabled in it.

I strongly suggest you configure FPL again from scratch (if you're using Obitalk.com, I would delete your FPL profile) using the PDF guide: viewtopic.php?f=15&t=18805#p73839
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 661
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2(Build: 5859EX)
ISP Name: Rogers Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: obi202, recently cannot receive incoming call

Postby flybluesky » 01/18/2018

thanks.
try everything, still the same problem, it makes my crazy,,, ,,,
flybluesky
Just Passing Thru
 
Posts: 5
Joined: 01/10/2018
SIP Device Name: obi202
Firmware Version: 3.2.1.5775

Re: obi202, recently cannot receive incoming call

Postby Liptonbrisk » 01/18/2018

flybluesky wrote:thanks.
try everything, still the same problem, it makes my crazy,,, ,,,



1) What does the registration status in your ATA indicate for Freephoneline?
Dial ***1. Enter the IP address you hear into a web browser
Navigate to Status-->System Status-->SP(FPL) Service Status-->Status

What does the registration status state when you're having problems? Please answer this question.

2) Are you testing with a regular landline or cellular phone (Telus, Rogers, Bell or one of their subsidiaries) for incoming calls to your FPL number? Please answer this question. The point is don't use VoIP to test incoming calls.
Who is the carrier? Check with https://www.twilio.com/lookup

Use for example Bell (outgoing)---->FPL (incoming call to you)

3) Try a different phone (check cables, etc.)

4) You can try port forwarding your RTP (UDP) port range 16660-16798 from your router to your ATA. For reference, that range can be found under ITSP Profile (FPL)-->RTP. Then look at LocalPortMin and LocalPortMax. RTP packets need to reach your ATA in order for you get incoming audio. Quite often, when the one way audio issue occurs, this is the problem. RTP packets are not reaching your ATA. Ideally, one should not have to port forward in order to achieve proper two-way audio, since port forwarding does create security issues. Port forwarding should only be done when everything else fails.

Refer to the port forwarding section of your router manual to learn how to port forward to your ATA. If a router was given to you by your ISP, call your ISP for port forwarding assistance.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 661
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2(Build: 5859EX)
ISP Name: Rogers Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: obi202, recently cannot receive incoming call

Postby longwinter » 01/24/2018

sorry, lose my password and get one new.

1) What does the registration status in your ATA indicate for Freephoneline?
Dial ***1. Enter the IP address you hear into a web browser
Navigate to Status-->System Status-->SP(FPL) Service Status-->Status

What does the registration status state when you're having problems? Please answer this question.




2) use cellphone (fido) for incoming call.

3) try different phones

4) You can try port forwarding your RTP (UDP) port range 16660-16798 from your router to your ATA. For reference, that range can be found under ITSP Profile (FPL)-->RTP. Then look at LocalPortMin and LocalPortMax. RTP packets need to reach your ATA in order for you get incoming audio. Quite often, when the one way audio issue occurs, this is the problem. RTP packets are not reaching your ATA. Ideally, one should not have to port forward in order to achieve proper two-way audio, since port forwarding does create security issues. Port forwarding should only be done when everything else fails.


3215.jpg
3215.jpg (80.48 KiB) Viewed 783 times

3214.jpg
3214.jpg (57.75 KiB) Viewed 783 times
longwinter
Just Passing Thru
 
Posts: 3
Joined: 01/24/2018

Re: obi202, recently cannot receive incoming call

Postby longwinter » 01/24/2018

sorry. lose the password, get one new.


1) What does the registration status in your ATA indicate for Freephoneline?
Dial ***1. Enter the IP address you hear into a web browser
Navigate to Status-->System Status-->SP(FPL) Service Status-->Status
3213.jpg
3213.jpg (49.9 KiB) Viewed 782 times


2) cellphone for incoming call (fido)


3) Try a different phone (check cables, etc.)

tried different phones , samething

4) You can try port forwarding your RTP (UDP) port range 16660-16798 from your router to your ATA. For reference, that range can be found under ITSP Profile (FPL)-->RTP. Then look at LocalPortMin and LocalPortMax. RTP packets need to reach your ATA in order for you get incoming audio. Quite often, when the one way audio issue occurs, this is the problem. RTP packets are not reaching your ATA. Ideally, one should not have to port forward in order to achieve proper two-way audio, since port forwarding does create security issues. Port forwarding should only be done when everything else fails

3214.jpg
3214.jpg (57.75 KiB) Viewed 782 times

3215.jpg
3215.jpg (80.48 KiB) Viewed 782 times
longwinter
Just Passing Thru
 
Posts: 3
Joined: 01/24/2018

Re: obi202, recently cannot receive incoming call

Postby longwinter » 01/24/2018

thanks. sorry, lose password, get one new.

follow the 1).2). 3). 4). same problem, when got incoming call , incoming call side is ok . receive side is silent.
longwinter
Just Passing Thru
 
Posts: 3
Joined: 01/24/2018

Re: obi202, recently cannot receive incoming call

Postby Liptonbrisk » 01/24/2018

Okay, I'm seeing that you've lost your forum account password. I'm new as a moderator, and I don't know what the rules are here for creating multiple forum accounts. So I'm going to wait for Fongo Support or another mod to make a decision with respect to your new account and the posts that are waiting for approval.

In the meantime, to recover your password for your original forum account, click ucp.php?mode=sendpassword


208.65.240.44 is voip.freephonline.ca

I would prefer that you were using voip4.freephonline.ca:6060 for the Proxy Server while you're having this problem.

You state that when you get an incoming call to your FPL number, the incoming side rings fine and you can hear (FPL) what the other person says, but the outgoing side from you can't hear you, correct? That's an issue involving outgoing audio (upload direction).
Possible causes include your ISP being at fault (upload issue) or some defect involving the router or the ethernet cord running to the ATA; your devices (computers, smartphones, smart tv, etc.) hogging bandwidth while making calls; your handset being muted or a bad phone cord; RX gain setting in the ATA being too high (audio clipping) or too low; or the ATA just suddenly developing some defect that I've never encountered with my OBi202 that I've had since 2012.

The only ports being used are all UDP (not TCP) with Freephoneline.
They are
a) 5060 or 6060 (if you're using voip4.freephoneline.ca, it's 6060),
b) RTP port range,
and
c) X_Useragentport

The RTP port range is for the actual audio stream, so it would be odd if port forwarding either of the other two UDP ports (a and c) resolves this issue for you, given that you're registered and can receive calls. Port forwarding 5060 and X_Useragentport are huge security risks, in my opinion, and should be avoided. But for 3 minutes, if you test with all ports forwarded, and if the problem persists, then stop forwarding anything. Disable all port forwarding. You can just port forward to test for 3 minutes or so to see if there's some NAT firewall issue (I doubt this is the problem though at this point). If the problem continues, then disable all port forwarding, since I doubt that's the issue.


Instead of port forwarding, I would take a look at these four posts:

a) https://forums.redflagdeals.com/newegg- ... #p27510756
b) https://forums.redflagdeals.com/newegg- ... #p27510825
c) https://forums.redflagdeals.com/newegg- ... #p27510848
d) https://forums.redflagdeals.com/newegg- ... #p27510881

Besides following the instructions for the four posts above, I am mostly out of further advice. It may be worth trying your ATA at a friend's place to see if you can reproduce the issue.
And if you'd like, you can perform a factory reset: https://www.obitalk.com/info/faq/Troubl ... tory-Reset
Then you'd need to reconfigure your ATA again: viewtopic.php?f=15&t=18805#p73839.

Should you determine that your ATA is defective, in the future, I would suggest using a UPS, if you're not already, and keeping it in a well-ventilated area so that it can't overheat.


I also suggest visiting http://thetestcall.blogspot.ca/. This is a very good, free service. You can call either the 416 or 250 numbers for free. During the call, dial #. And then choose one of the options from 1 to 9. There’s a free echo test, DTMF test (check to make sure all your touchtone keys are recognized), Caller ID readback, etc.

If you just want an echo test, Freephoneline does provide one at (226)244-4444.

You can also get some very general ideas from visiting https://www.obitalk.com/info/support/troubleshooting.
However, I would ignore anything that site says about enabling DMZ.


If the problem only occurs with Fido, then you may want to contact them and let them know they have a carrier issue involving incoming calls from your Fibernetics number.
I am out of further advice.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 661
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2(Build: 5859EX)
ISP Name: Rogers Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin


Return to Customer Support

Who is online

Users browsing this forum: No registered users and 3 guests