Calls are mute after 15 minutes

Have a question or problem with your Fongo application? This forum is the place to get help from both staff and fellow community members.
Fongo recommends Fongo Home Phone for a fully supported Home Phone system for only $4.95/mo

Calls are mute after 15 minutes

Postby extremehub » 02/26/2020

I don't usually have long calls but recently I noticed my calls are mute after 15 minutes (roughly). I could see from the phone display the call is still connected but could't hear anything. Could someone please help advising how I can fix it ? Thanks
extremehub
Just Passing Thru
 
Posts: 5
Joined: 02/26/2020

Re: Calls are mute after 15 minutes

Postby Liptonbrisk » 02/27/2020

1) What brand and model modem are you using?

a) If you were issued a modem/router gateway or hub by your ISP ensure that it's in bridge mode if you're also using your own router.

b) Reboot it. Wait for it to be fully up and running.

2) What brand and model router are you using?

a) Is SIP ALG disabled in it?

b) After rebooting your modem (above), reboot your router. Wait for SSIDs to populate.

3) What brand and model ATA or IP Phone are you using?

a) After rebooting your router, reboot your ATA.

b) If the problem persists, chance local SIP port to a new random number between 30000 and 60000. With Obihai ATAs, navigate to Voice Services-->SP(FPL) Service-->X_UserAgentPort. X_UserAgentPort is local SIP port.

c) Try using proxyserver voip4.freephoneline.ca:6060 to cirvcumvent faulty SIP ALG features in routers.

Proper device reboot order is always modem-->router (wait for it to be fully up and running first)-->ATA.

Doublecheck your Keep-Alive settings in your ATA.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 1123
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Calls are mute after 15 minutes

Postby extremehub » 02/27/2020

Thanks for the detailed reply. Below are my answers to your questions:

1. Modem is Hitron CGN3

2. Router is Netgear WPN824 v3 Note: I have a bit complicated setup. Since this router is connected with modem which located at a far corner of the house in the basement, there is another spare router Netgear WNR2000 v2 which is setup as a access point in the middle of the house and it is connected through the ethernet cable there (it is hard wired directly to one of the hub on the router.

a) Should I go into the setting of Netgear WPN824 and check if the SIP ALG is disabled ?

3) The ATA is Obi200

Honestly, I am not techy at all. Thus, didn't touch this setup for a long time. About a year ago, I notice my FPL would not ring occassionally and went straight voicemail but it works again after I rebooted it. Someone in another forum suggested me to do some testing and make some changes in the ATA setting (that I don't quite understand), So I didn't do it as I don't call that much and for some reasons, the ringing issue seems to be gone. However, like I mentioned, the new issue recently is that I notice calls are mute after certain minutes, and I notice it is roughly 15 minutes.

I had reboot everything yesterday but the mute call issue is still there........
extremehub
Just Passing Thru
 
Posts: 5
Joined: 02/26/2020

Re: Calls are mute after 15 minutes

Postby Liptonbrisk » 02/27/2020

extremehub wrote:
1. Modem is Hitron CGN3


Okay, so that should be put into bridge mode: https://www.rogers.com/customer/support ... emode-cgn3. Instructions should be somewhat similar.


2. Router is Netgear WPN824 v3 Note: I have a bit complicated setup. Since this router is connected with modem which located at a far corner of the house in the basement, there is another spare router Netgear WNR2000 v2 which is setup as a access point in the middle of the house and it is connected through the ethernet cable there (it is hard wired directly to one of the hub on the router.


I'm a little confused.

Does your setup look like this?

1) CGN3--->WPN824-->WNR2000-->OBI200 ?

Or does it look like
2) CGN3-->WPN824-->OBI200 ?

If it looks like #1, WNR2000 should be setup as a repeater so that you're not double NATting (running traffic through two router firewalls). If you need help doing that, it would probably be best to ask at https://community.netgear.com/t5/English/ct-p/English or contact Netgear: https://www.netgear.com. I don't have your routers, so I'm not familiar with them.

#1 makes the problem harder to troubleshoot because the issue could involve either of the routers.


a) Should I go into the setting of Netgear WPN824 and check if the SIP ALG is disabled ?


Yes
I can't find information on SIP ALG for that router. That model router seems to be over 15 years old.
According to https://kb.intermedia.net/article/3167
SIP ALG can only be disabled on newer firmware.

Visit https://kb.netgear.com/30796/How-do-I-d ... -interface

Your latest router firmware is found at https://www.netgear.com/support/product ... ica%20only)

Your only option might be to use voip4.freephoneline.ca:6060 for the proxy server to circumvent SIP ALG (SIP ALG listens for traffic on UDP port 5060 and mangles SIP headers; using UDP 6060 bypasses SIP ALG). Follow the PDF guide at viewtopic.php?f=15&t=18805#p73839 fully.
On page 14 and the top of page 15, the underlined section applies to you. Just use use
voip4.freephoneline.ca={voip4.freephoneline.ca:6060,1} in step 6c, and the pic you, later on, need to refer to is at the top of page 21.



Someone in another forum suggested me to do some testing and make some changes in the ATA setting


If you have questions, ask, and I'll try to answer when I have time.

I had reboot everything yesterday but the mute call issue is still there........


It's really important to reboot the ATA after the routers have been rebooted and are fully up and running first.

You really should be doing steps 4, 5, 9, and 11 on page 43 of the PDF guide: viewtopic.php?f=15&t=18805#p73839.
If you don't understand how or become stuck, just ask.

These steps are important:

4) In your Obihai ATA or at Obitalk.com, (whichever method you originally used; don't use both methods), navigate to Voice Services-->SP(FPL) Service-->X_UserAgentPort
X_UserAgentPort should be a random port number between 30000 and 60000. Just pick a port number in that range.
By using a high random port you help to thwart SIP scanners and may also circumvent a faulty SIP ALG feature in your
router.

5) Navigate to Service Providers-->ITSP Profile (FPL)-->SIP
i) ensure X_DiscoverPublicAddress is enabled (it is by default)
ii) enable X_UsePublicAddressInVia (it's not by default)



Anyway, I think the issue is SIP session timer/NAT firewall related. I would go through the PDF guide fully.

If you follow the PDF guide for your ATA, you'll also see the following:

Navigate to Voice Services-->SP(FPL)
X_KeepAliveEnable: Checked
X_KeepAliveExpires: 20
X_KeepAliveMsgType: notify


That step is also important. The Keep Alive packets help to keep NAT associations from dropping prematurely, so that routers know a port is still in use and don't close or drop the connection too soon.
That might be the cause of a 15 minute dropped call.

If you become stuck, just ask.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 1123
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Calls are mute after 15 minutes

Postby extremehub » 02/27/2020

Thanks again, I will read all your detail and try to digest to make necessary changes, Hope I can handle it........

By the way, to my understanding, Hitron CGN3 is a modem and router. But I am using a bridge mode to by pass it my Netgear router.

Here is my setup: CGN3--->WPN824-->WNR2000-->OBI200
extremehub
Just Passing Thru
 
Posts: 5
Joined: 02/26/2020

Re: Calls are mute after 15 minutes

Postby Liptonbrisk » 02/27/2020

extremehub wrote:
By the way, to my understanding, Hitron CGN3 is a modem and router.


Wow, sorry, you're right. I'll edit my post to avoid confusion. I was thinking of another device.
Visit https://www.rogers.com/customer/support ... emode-cgn3 for bridge mode instructions (instructions should be similar for your device).


Here is my setup: CGN3--->WPN824-->WNR2000-->OBI200


Well, the double NAT firewall makes this setup difficult to troubleshoot. I would try to get the WNR2000 setup as a repeater, or I would try to drop all router functions in it, especially the firewall (use DMZ) and SIP ALG.
If you configure the ATA to use voip4.freephoneline.ca:6060, disabling SIP ALG in both routers isn't paramount.

I came across https://community.netgear.com/t5/WiFi-A ... d-p/415499 for the WNR2000. It seems SIP ALG is stuck on in that router and causes a lot of problems. You may need to update or use different firmware in it. Again, it would probably make sense to switch to voip4.freephoneline.ca:6060 in your ATA so that you can bypass buggy SIP ALGs.

I'm probably not going to be able to help very much with your routers since I'm not familiar with them (possibly someone else can). I provided what information I was able to find.
But I can help you with OBi200 ATA settings, so feel free to ask if you become stuck with ATA settings.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 1123
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Calls are mute after 15 minutes

Postby extremehub » 02/27/2020

By the way, I wonder if it will make things easier to change a new router, or use the Netgear WNR2000 as the router instead. However, I am hesitate to make any change since I am not techy. I could make things worse, and everything (my Wifi network with all wireless printer, cameras, TV boxes, wifi thermostat and garage door, etc seem working ok now, don't want to mess up stuff just because of the ocassionally use of FPL........
extremehub
Just Passing Thru
 
Posts: 5
Joined: 02/26/2020

Re: Calls are mute after 15 minutes

Postby extremehub » 02/27/2020

Sorry, I haven't touched Obi200 for years since I bought it......

How do I switch to voip4.freephoneline.ca:6060 as you suggested ? I assume I need to log into the Obi200 to do so ?
extremehub
Just Passing Thru
 
Posts: 5
Joined: 02/26/2020

Re: Calls are mute after 15 minutes

Postby Liptonbrisk » 02/27/2020

extremehub wrote:By the way, I wonder if it will make things easier to change a new router, or use the Netgear WNR2000 as the router instead. However, I am hesitate to make any change since I am not techy. I could make things worse, and everything (my Wifi network with all wireless printer, cameras, TV boxes, wifi thermostat and garage door, etc seem working ok now, don't want to mess up stuff just because of the ocassionally use of FPL........


I would prefer not making you run out and buy something that you may not need. I would prefer troubleshooting the issue instead with the equipment you already own.

But if you do eventually get one, take a look below first.



Typically, for VoIP SIP services, especially for freephoneline, you want

A) a router that does not have a full cone NAT,

Visit https://www.think-like-a-computer.com/2 ... es-of-nat/.
Mango from the Obitalk.com forums writes,
“Use a restricted cone NAT router, and do not use port forwarding or DMZ. Restricted cone NAT will only permit
inbound traffic from the service provider you're registered to. If you have a full cone NAT router, it will allow traffic
from any source. This is probably not what you intend.
If you have a Windows computer, you can test your router using the utility here:
http://www.dslreports.com/forum/remark,22292023. To run it, use stun stun.ekiga.net from a command prompt.”
Essentially, you download the stun-test.zip file; extract the stun.exe file from within the zip file to an easily
accessible location; use an elevated command prompt (visit
http://www.thewindowsclub.com/how-to-ru ... inistrator); change directory (cd) to the
directory or location where you extracted stun.exe (visit
http://www.digitalcitizen.life/command- ... c-commands); and type “stun stun.ekiga.net” without
the quotation marks followed by the enter/return button on your keyboard.
Asus routers, at the time of this writing, produce port restricted cone NAT routers, for example and are fine,
provided you’re using one with Asuswrt-Merlin, third party firmware installed.

B) a router that lets you disable SIP ALG if it's buggy,

To understand why SIP ALG often causes horrible problems, please visit
https://www.voip-info.org/routers-sip-alg/ (scroll down to the section on SIP ALG problems).

If you're dealing with a modem/router combo issued by an ISP or a router with SIP ALG forced on, you may have
to use voip4.freephoneline.ca:6060 for the Proxy Server. The purpose of voip4.freephoneline.ca:6060 is to circumvent
faulty SIP ALG features in routers.

C) a router that allows you to set QoS or assign highest priority to your ATA or IP Phone over all other devices on your LAN (local area network),

For a very general description of what QoS can do for you, visit https://www.voipmechanic.com/qos-for-voip.htm.
The basic idea is if you're torrenting or have a bunch of other computers, smartphones, tablets, etc. downloading and uploading (hogging all your available bandwidth), you don't want
your ATA not to have access to enough bandwidth to make or receive calls properly. So QoS or a Bandwidth Monitor feature (which is just another form of QoS) is a really good idea for VoIP users.

I often get an occasional relative complaining to me, "Hey my calls sound choppy." And then when I go visit, some kids are playing MMOs on a computer, while another person is downloading a huge file,
and another person is backing up files to a cloud service all at the same time someone else is trying to talk on the phone. All those devices, without QoS enabled, are fighting over available bandwidth along with the ATA.

and D) A router that lets you adjust both Unreplied and Assured UDP timeouts.

Thanks to Mango, many of us now understand that in order for ATAs to remain registered and working properly with a VoIP SIP provider like Freephoneline, in particular after power failures, the following conditions must be met:

UDP Unreplied Timeout (in your router) < SIP OPTIONS Keep Alive Interval (in your ATA; for Obihai ATAs this is X_KeepAliveExpires) < UDP Assured Timeout (in your router) < SIP Registration Failure Retry Wait Time:(or RegisterRetryInterval in Obihai ATAs)

“<“ means less than.

When a modem leases a new IP address, a problem can arise where prior associations using the old IP address are maintained in the router. When the ATA attempts to communicate using the old IP address, the response is unreplied, and then if the UDP Unreplied timeout is greater than the Keep Alive Interval (and UDP Unreplied timeout is often set to 30 by default in consumer routers) a problem arises where the corrupted connection persists. If UDP Unreplied timeout is, for example, 17, and the NAT Keep Alive Interval is 20, then the corrupted connection will timeout or close. A new connection will be created, and everything will work fine.

Another problem can occur when the Keep-Alive interval is greater than UDP Assured Timeout (often 180 by default in consumer routers): the NAT hole will close due to the ATA not communicating frequently enough with the SIP server. In turn, incoming calls may, intermittently, not reach the ATA. Again, X_Keepalives expires is supposed to be 20 with FPL.

(the above settings are making reference to those in Obihai ATAs)

Getting access to both UDP Unreplied Timeout and UDP Assured Timeout settings in consumer routers may be difficult, if not impossible. Asuswrt-Merlin (I would avoid any model below/less powerful than an RT-AC68U), third party firmware for Asus routers, does offer easy access to these two settings, which are found under General–>Tools-->Other settings. My understanding is that third party Tomato firmware has these two settings as well. So if your router supports Tomato firmware, that may be another option. Note that I will not be held accountable any damage resulting from failed firmware updates. Apparently, Mikrotik routers also allow users to change both Assured and Unreplied UDP timeout settings as well: https://forums.redflagdeals.com/recomme ... 2115672/2/

The keep alive interval for FPL is 20. The SIP Registration Failure Retry Wait Time is 120. I use 17 for UDP Unreplied Timeout and 117 for UDP Assured Timeout.



ISPs do not issue customers routers that can do all four things I just listed. Typically it's far better to have your own router with strong QoS functions and a restricted cone NAT firewall,
disable whatever SIP ALG feature is enabled in the router, and stick whatever modem/router combo your ISP gives you into bridge mode. For Bell Hubs, visit http://forums.redflagdeals.com/please-s ... r-1993629/. For Rogers, visit https://www.rogers.com/customer/support ... ridgemodem.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 1123
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Calls are mute after 15 minutes

Postby Liptonbrisk » 02/27/2020

extremehub wrote:Sorry, I have touched Obi200 for years since I bought it......

How do I switch to voip4.freephoneline.ca:6060 as you suggested ? I assume I need to log into the Obi200 to do so ?


If you used the Obitalk web portal (http://www.obitalk.com) to configure your ATA, keep in mind that you must
continue using it to configure your ATA unless you disable Obitalk Provisioning first. Otherwise whatever
settings you change will eventually be overwritten (they will be transferred from your Obitalk.com account
to your ATA) by what you previously entered at obitalk.com anyway. If you wish to disable this behaviour,
dial ***1. Login to your ATA. Enter the IP address you hear into a web browser. Navigate to System Management-->OBiTalk
Provisioning-->select Disabled for the method. Save. Reboot ATA. Afterwards, obitalk.com won't overwrite
whatever changes you make via the device's interface (via IP address).

Pick one method (obitalk.com) or the other (IP address of device) for changing device settings. But do not
use both methods.

If you've never used obitalk.com to configure your ATA, dial ***1 on a phone connected to your ATA, and enter the IP address you're told into a web
browser. Login.


Download the PDF guide at download/file.php?id=2065

To start, jump to page 9 if you're using Obitalk.com. Otherwise, jump to page 11.

On page 14 and the top of page 15, the underlined section applies to you. Just use ("under Value, for Line 1, enter the following")
voip4.freephoneline.ca={voip4.freephoneline.ca:6060,1} in step 6c, and the pic you, later on, need to refer to is at the top of page 21 (step 8c).

For Proxyserver (page 21, step 8c), enter voip4.freephoneline.ca
ProxyServerPort needs to be set to 6060.

The picture on page 20 does not apply to you. The picture on page 21 does.

I would go through the PDF guide completely starting at page 11 until page 40. The guide explains what sections you can skip if you're not interested in setting up certain features, and it will tell you where to jump ahead if need be.




These steps are also important:

1) In your Obihai ATA or at Obitalk.com, (whichever method you originally used; don't use both methods), navigate to Voice Services-->SP(FPL) Service-->X_UserAgentPort
X_UserAgentPort should be a random port number between 30000 and 60000. Just pick a port number in that range.
By using a high random port you help to thwart SIP scanners and may also circumvent a faulty SIP ALG feature in your
router.

2) Navigate to Service Providers-->ITSP Profile (FPL)-->SIP
i) ensure X_DiscoverPublicAddress is enabled (it is by default)
ii) enable X_UsePublicAddressInVia (it's not by default)



Anyway, I think the issue is SIP session timer/NAT firewall related. I would go through the PDF guide fully.

If you follow the PDF guide for your ATA, you'll also see the following:

3) Navigate to Voice Services-->SP(FPL)
X_KeepAliveEnable: Checked
X_KeepAliveExpires: 20
X_KeepAliveMsgType: notify


That step is also important. The Keep Alive packets help to keep NAT associations from dropping prematurely, so that routers know a port is still in use and don't close or drop the connection too soon.
That might be the cause of a 15 minute dropped call.

If you become stuck, just ask.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 1123
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Calls are mute after 15 minutes

Postby JOHN-SBK » 02/27/2020

I don't think the problem comes from a bad setting in the router or the ATA. It's most likely a problem with the FPL server.

I have been using FPL since July 2011 with the exact same router and ATA (did not change any settings since the beginning). Had a couple small problems over the years, usually going away after a week, or a month... Various FPL problems that came a gone without having anything to do with my settings.

I've been making long calls all the time (Trying to help my mother with her computer problems over the phone can sometimes be long :shock: )

The 15 minutes mute thing appeared a couple weeks ago. There are probably many people affected, they just don't talk long enough to know it :D

There was also a problem with voicemail that appeared at around the same time. I just did what was sugggested in this thread and it appears to work. I can call myself and hear the voicemail. But have not attempted to leave a message yet to see if it really works.http://forum.fongo.com/viewtopic.php?f=8&t=19733

I know they migrated the servers recently, so I think the problem is on FPL side. There is probably a wrong setting on the new server that is causing the line to go mute after 15 minutes.
JOHN-SBK
Just Passing Thru
 
Posts: 4
Joined: 02/27/2020
SIP Device Name: Linksys PAP2-NA
Firmware Version: 3.1.22(LS)
ISP Name: Videotron cable
Router: Netgear WNR3500L

Re: Calls are mute after 15 minutes

Postby Liptonbrisk » 02/27/2020

JOHN-SBK wrote:I don't think the problem comes from a bad setting in the router or the ATA. It's most likely a problem with the FPL server.


I just had a call that lasted over an hour. I can't reproduce the problem on any of my ATAs or SIP apps.


I have been using FPL since July 2011 with the exact same router and ATA (did not change any settings since the beginning)


I've been a paid customer with FPL since 2010 and rarely encounter issues.

Had a couple small problems over the years, usually going away after a week, or a month... Various FPL problems that came a gone without having anything to do with my settings.


Most people don't realize that NAT issues develop on their own between routers and ATAs that are corrected temporarily, in some cases, by rebooting, changing the local SIP port in ATAs, or by adjusting UDP timeouts in routers. There's tons of cases that I've fixed for other users. SIP session timer and NAT corruption issues are well-known by people who work in the industry.

The 15 minutes mute thing appeared a couple weeks ago.


I haven't experienced it yet.


There are probably many people affected, they just don't talk long enough to know it


I had a 70+ minute call on the 24th.

I had a 25+ minute call on the 26th.
I had another 30+ minute call.

I had over an hour long call just a little while ago today.


There was also a problem with voicemail that appeared at around the same time.


The voicemail issue is unrelated, and the lack of notifications is still on-going.

I know they migrated the servers recently, so I think the problem is on FPL side. There is probably a wrong setting on the new server that is causing the line to go mute after 15 minutes.


While it could be possible there's an issue after migration, typically 15 minute call drops are related to SIP session timers or NAT corruption. That's how SIP works with residential routers and ATAs.

NAT Keep-Alive helps to prevent a router's NAT association from dropping. Associated issues involve calls dropping after 15 minutes or at other intervals. Sometimes calls will go directly to voicemail.
Another way to help keep NAT associations from dropping is to reduce registration intervals to say, 60 seconds, if the service provider will allow it, which Freephoneline doesn't. The registration timer with FPL is 3600 seconds. So FPL relies on Keep-Alive packets at 20 second intervals instead. Another way of dealing with this problem is to adjust UDP timeouts in routers. Disabling SIP ALG in routers can also help because they're often buggy messes.

Yes, it's possible the problem is with FPL, but I haven't run into it yet. Based on the long calls I've had, I would have expected to encounter the issue by now.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 1123
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Calls are mute after 15 minutes

Postby Liptonbrisk » 02/27/2020

I just made another call over 25 minutes. No problems. I’m having trouble trying to reproduce this issue.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 1123
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Calls are mute after 15 minutes

Postby JOHN-SBK » 02/27/2020

Ok thanks for your help!

It look like disabling SIP ALG may have fixed it. It's late and I can't call anyone to test it, but I called my cell phone and made it to 16 minutes. Will test longer calls in the next few days.

The weird thing is that it worked well since 2011 with SIP ALG enabled. In fact, I don't even know if there was a way to disable it. I just updated the firmware today (it was up to date back then when I set it up) to the latest version. There is now a way to disable SIP ALG.

There is probably something a little different in the way the new FPL hardware and/or configuration works that does not play nice with my router's SIP ALG, but the older hardware/configuration was OK before the migration.

For reference, my ATA is a Linksys PAP2-NA with firmware 3.1.22(LS), and my router is a Netgear WNR3500L with the latest firmware 1.2.2.48.
JOHN-SBK
Just Passing Thru
 
Posts: 4
Joined: 02/27/2020
SIP Device Name: Linksys PAP2-NA
Firmware Version: 3.1.22(LS)
ISP Name: Videotron cable
Router: Netgear WNR3500L

Re: Calls are mute after 15 minutes

Postby Liptonbrisk » 02/27/2020

JOHN-SBK wrote:
It look like disabling SIP ALG may have fixed it.


To understand why SIP ALG often causes horrible problems, please visit
https://www.voip-info.org/routers-sip-alg/ (scroll down to the section on SIP ALG problems).

If you're dealing with a modem/router combo issued by an ISP or a router with SIP ALG forced on, people may have
to use voip4.freephoneline.ca:6060 for the Proxy Server. The purpose of voip4.freephoneline.ca:6060 is to circumvent
faulty SIP ALG features in routers.



It's late and I can't call anyone to test it


Visit http://thetestcall.blogspot.com/

Dial the 416 or 250 number, and then press #. Then press 4 for music on hold. After one song finishes, press the # again to play the next song.


but I called my cell phone and made it to 16 minutes. Will test longer calls in the next few days.


I'm trying to figure out if the problem involves a specific server, but because I can't reproduce the issue it's hard for me to test.

I tried a smartphone SIP app called Acrobits Groundwire using cellular data a little while ago, which completely bypasses my router. And I tried voip.freephoneline.ca on Groundwire because I figured most people are using voip.freephoneline.ca. I was able to call a Telus mobile number for 17 minutes without any problems. So, I hung up.

The 60+ minute call today was using voip2.freephoneline.ca on an OBi202 ATA. My router firmware uses Asuswrt-Merlin. The SIP ALG feature in Asus routers is called SIP Passthrough. In Merlin firmware, my SIP Passthrough setting is set to "Enabled + NAT helper", which works fine with Freephoneline.

I'd need to look at SIP traces (logs) where someone is having the problem and also check that person's firewall logs. That's a lot of work for me that I just don't have time for.


There is probably something a little different in the way the new FPL hardware and/or configuration works


I suspect something has changed, but the change doesn't appear to be affecting me at the moment.


For reference, my ATA is a Linksys PAP2-NA with firmware 3.1.22(LS), and my router is a Netgear WNR3500L with the latest firmware 1.2.2.48.


What brand and model modem are you using? If it's a modem/router combo or gateway, ensure that it's in bridge mode.

Do the following steps, slowly and carefully, step by step:

1. Before beginning the steps below make sure whatever modem/router combo your ISP gave you is in bridge mode if you are using your own router. Call/contact your ISP if you have to. For Bell Hubs, visit
http://forums.redflagdeals.com/please-s ... r-1993629/

2. Disable DMZ and all port forwarding in your router. Port forwarding is a security risk.

3. In your PAP2T, Navigate to Line 1 (or whatever you're using for FPL)-->SIP settings, and change SIP Port to a random number between 30000 and 60000. Do this for security reasons. Also, this step may help to temporarily address a corrupted NAT association that's developed between a router and ATA.

4. In your PAP2T, Navigate to the SIP tab-->NAT Support Parameters, and make sure that the following settings are enabled:

a)Handle VIA received-->yes
b)Handle VIA rport-->yes
c)Substitute VIA Addr-->yes

This helps to ensure RTP (the streaming audio packets sent by FPL's server) packets are sent to your public WAN IP address as opposed to your LAN IP address (nowhere/outer space) .

d) NAT Keep Alive Intvl should be 20

(discussed earlier)

5. Navigate to Line (whatever you use for FPL)-->NAT settings
a) NAT Mapping enabled --> yes
b) NAT Keep alive enabled --> yes

6. Navigate to Voice-->SIP-->SIP Timer Values (sec)
a. Reg Retry Intvl should be 120 seconds
https://support.freephoneline.ca/hc/en- ... redentials
This step is not related to your problem, but old guides didn't include this setting.


You may not be able to do this step:

7. Thanks to Mango, many of us now understand that in order for ATAs to remain registered and working properly
with a VoIP SIP provider like Freephoneline, in particular after power failures, the following conditions must be met:

UDP Unreplied Timeout (in your router) < NAT Keep-alive Interval < UDP Assured Timeout (in your router) < SIP Registration Failure Retry Wait Time (Reg Retry Intvl)

“<“ means less than.

When a modem leases a new IP address, a problem can arise where prior associations using the old IP address are maintained in the router. When the ATA attempts to communicate using the old IP address, the response is unreplied, and then if the UDP Unreplied timeout is greater than the Keep Alive Interval (and UDP Unreplied timeout is often set to 30 by default in consumer routers) a problem arises where the corrupted connection persists. If UDP Unreplied timeout is, for example, 17, and the NAT Keep Alive Interval is 20, then the corrupted connection will timeout or close. A new connection will be created, and everything will work fine.

Another problem can occur when the Keep-Alive interval is greater than UDP Assured Timeout (often 180 by default in consumer routers): the NAT hole will close due to the ATA not communicating frequently enough with the SIP server. In turn, incoming calls may, intermittently, not reach the ATA. Again, NAT Keep-alive Interval is supposed to be 20 with FPL.

Getting access to both UDP Unreplied Timeout and UDP Assured Timeout settings in consumer routers may be
difficult, if not impossible. Asuswrt-Merlin, third party firmware for Asus routers, does offer easy access to these two
settings, which are found under General–>Tools-->Other settings. In part, for this reason, I tend to use Asus routers
that work with Asuswrt-Merlin. However, my understanding is that third party Tomato firmware has these two settings
as well. So if your router supports Tomato firmware, that may be another option. I will not be held responsible for failed firmware updates.
Apparently, Mikrotik routers also allow users to change both Assured and Unreplied UDP timeout settings: https://forums.redflagdeals.com/recomme ... 2115672/2/.
The keep alive interval for FPL is 20. The SIP Registration Failure Retry Wait Time is 120. I use 17 for UDP
Unreplied Timeout and 117 for UDP Assured Timeout.

8. After changing and savings settings, reboot your devices. Proper device reboot order is always modem (wait for it to be fully up and running)-->router (wait for Wi-Fi SSIDs to populate and broadcast first)-->ATA
in that order.

Then test another call.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 1123
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Calls are mute after 15 minutes

Postby JOHN-SBK » 02/28/2020

Thanks for the informations!

Unfortunately, I'm too tired to make all these modifications for today. I had a bad headache all day, and had to deal with all that snow from the snow storm :x . I also have a few important calls to make (that will last much more than 15 minutes) that I postponed because of this issue that I will have to deal with before modifying my current settings. But I will definitely make the changes you suggested probably next week, I'm sure they are better than my current settings. I will try your suggestions and read a bit to get back up to speed on the subject. I did not touch this since 2011 after I got it working properly. There is no doubt room for improvement in my settings.

For now, a little more info on my setup:

Videotron cable ISP --> Thomson DCM475 modem --> Netgear WNR3500L router --> Linksys PAP2-NA ATA --> Panasonic KX-TG1062C Dect 6.0 Corded phone base + 2 cordless handsets

The good news is that since I disabled the SIP ALG in my router, I made 3 successful calls of more than 15 minutes. About 16, 20 and 25 minutes, both inbound and outbound (The 15 minutes limit applied to both inbound and outbound calls) Will test longer calls soon, but I expect that it will be OK since the limit was always at 15 minutes, and not random times.

Maybe there is a timer on the new server that send a command to my ATA to verify I'm still active, and it can't get past my Netgear SIP ALG function and my ATA can't reply? Or maybe there was always a timer but the command sent by the old server was slightly different and could pass through my router? It look like SIP ALG could be implemented differently by various manufacturers.

Anyway, disabling SIP ALG did the trick for me. I see the OP also have a Netgear router (even 2) so there is a good chance that disabling SIP ALG will fix the problem also.

Thanks again!
JOHN-SBK
Just Passing Thru
 
Posts: 4
Joined: 02/27/2020
SIP Device Name: Linksys PAP2-NA
Firmware Version: 3.1.22(LS)
ISP Name: Videotron cable
Router: Netgear WNR3500L

Re: Calls are mute after 15 minutes

Postby JOHN-SBK » 02/28/2020

A quick update to say I just completed a 1h36min call without any problem. Great!
JOHN-SBK
Just Passing Thru
 
Posts: 4
Joined: 02/27/2020
SIP Device Name: Linksys PAP2-NA
Firmware Version: 3.1.22(LS)
ISP Name: Videotron cable
Router: Netgear WNR3500L

Re: Calls are mute after 15 minutes

Postby Liptonbrisk » 02/29/2020

JOHN-SBK wrote:
Thomson DCM475 modem


That is a regular modem without a router built into it, so you can ignore the part where I mention bridge mode. Also, you don't need to reboot your modem after making changes in your ATA or router.
So, when you do reboot devices just reboot your router (wait for it to be fully up and running first), followed by your ATA.

The good news is that since I disabled the SIP ALG in my router


SIP ALG monitors traffic on UDP port 5060 and modifies, often incorrectly, in many routers, information in SIP headers.


A quick update to say I just completed a 1h36min call without any problem


I'm glad your issue is resolved.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 1123
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Calls are mute after 15 minutes

Postby mkaye » 03/17/2020

i have been getting this all day
2 different calls - each lasted 15 minutes (called back each for another 15 min)

mark
mkaye
Just Passing Thru
 
Posts: 2
Joined: 05/28/2017
SIP Device Name: Freepbx
Firmware Version: v15
ISP Name: teksavvy
Computer OS: windows 10
Router: ubiquiti usg3

Re: Calls are mute after 15 minutes

Postby slvrsi » 03/26/2020

yes. i'm having the same problem.

running an asterisk box on my openwrt router which is in the dmz.

alg is not on and i also tried voip4. still 15ish minute limit...

incoming calls unlimited. outgoing calls 15 mins...
slvrsi
Just Passing Thru
 
Posts: 7
Joined: 08/27/2009

Re: Calls are mute after 15 minutes

Postby Liptonbrisk » 03/26/2020

slvrsi wrote:yes. i'm having the same problem.

running an asterisk box on my openwrt router which is in the dmz.


Using DMZ is a huge security risk. It's better to ensure, if you're using a modem/router combo or gateway issued by your ISP, that it’s in bridge mode. Afterwards disable DMZ in your own router.

I'm not using Freepbx nor Asterisk, so I won't be able to help troubleshoot. I can't reproduce your issue with any FPL server for outgoing or incoming calls.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 1123
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Calls are mute after 15 minutes

Postby mkaye » 03/28/2020

strange, i seemed to fix it on my Grandstream 702 ATA, but not my Grandstream 2-line voip phone (use voip.ms for business & it's OK, not freephoneline)
all settings are identical and it has to be the phone since the ATA works fine
i added session=timers=refuse on the trunk, but that didn't help

mark
mkaye
Just Passing Thru
 
Posts: 2
Joined: 05/28/2017
SIP Device Name: Freepbx
Firmware Version: v15
ISP Name: teksavvy
Computer OS: windows 10
Router: ubiquiti usg3


Return to Community Support

Who is online

Users browsing this forum: No registered users and 3 guests

cron