Registration keeps failing on voip.freephoneline.ca

Have a question or problem with your Fongo application? This forum is the place to get help from both staff and fellow community members.
Fongo recommends Fongo Home Phone for a fully supported Home Phone system for only $4.95/mo

Re: Registration keeps failing on voip.freephoneline.ca

Postby bridonca » 09/08/2016

Have you tried using your SIP settings with another SIP device, like an Android phone? It feels like your PAP2 is failing to work. Might be something as simple as a dying power supply, but to be honest, any excuse to get rid of a PAP2 to upgrade to something much better like an Obi ATA is a good one.
User avatar
bridonca
Technical Support
 
Posts: 1141
Joined: 11/16/2009
SIP Device Name: Netgear WGR615V
Firmware Version: latest
ISP Name: Eastlink
Computer OS: XP

Re: Registration keeps failing on voip.freephoneline.ca

Postby lobotiger » 09/10/2016

Well it made it to 7:00AM Saturday morning and then I find out from the wife this afternoon that the phone is not working. :( Power off and on and the device is registered again.

LoboTiger
lobotiger
Quiet One
 
Posts: 37
Joined: 03/06/2010

Re: Registration keeps failing on voip.freephoneline.ca

Postby lobotiger » 09/10/2016

bridonca wrote:Have you tried using your SIP settings with another SIP device, like an Android phone? It feels like your PAP2 is failing to work. Might be something as simple as a dying power supply, but to be honest, any excuse to get rid of a PAP2 to upgrade to something much better like an Obi ATA is a good one.


That might be an option (going with the Obi) but it's odd that quite a few of us started experiencing this similar problem. We can't all have suffered dying units. Plus, I'd hate to go and buy the Obi and then find out I'm still experiencing the same issues. That would royally peeve me off.

LoboTiger
lobotiger
Quiet One
 
Posts: 37
Joined: 03/06/2010

Re: Registration keeps failing on voip.freephoneline.ca

Postby bridonca » 09/10/2016

Might want to invest in a Obihai device. They do not have these problems. Yes, I have a hate on for Cisco ATA gear, but it is justified.
User avatar
bridonca
Technical Support
 
Posts: 1141
Joined: 11/16/2009
SIP Device Name: Netgear WGR615V
Firmware Version: latest
ISP Name: Eastlink
Computer OS: XP

Re: Registration keeps failing on voip.freephoneline.ca

Postby killerjay » 09/12/2016

have you tried switching to the voip4 sip address? that seems to have fixed my registration problems. something in voip1 was causing my registration to fail very often.
killerjay
Active Poster
 
Posts: 70
Joined: 06/14/2010
SIP Device Name: grandstream 286
ISP Name: cogeco
Computer OS: windows vista
Router: dir-655

Re: Registration keeps failing on voip.freephoneline.ca

Postby lobotiger » 09/12/2016

I've only use voip and voip2 for the sip address. I thought voip4 was for Rogers customers only?

LoboTiger
lobotiger
Quiet One
 
Posts: 37
Joined: 03/06/2010

Re: Registration keeps failing on voip.freephoneline.ca

Postby mjbad2 » 09/12/2016

Same problem yesterday and Today. But the swapped line1 and Line 2 and same phone worked on line 2. So was about to buy new ATA.
But did some search here. Then changed the port 6060. Worked fine. Then changed back to 5060 and it worked. Now I will restore Line1 to that number again and check.

By the way Do Freephoneline sell ATA adapter? What cost and brand. I could not find anything on main web site.
mjbad2
Active Poster
 
Posts: 120
Joined: 06/16/2009

Re: Registration keeps failing on voip.freephoneline.ca

Postby killerjay » 09/13/2016

lobotiger wrote:I've only use voip and voip2 for the sip address. I thought voip4 was for Rogers customers only?

LoboTiger


dont think that matters, i am on cogeco and its been running fine without losing registration like it was on voip1.
switch voip1.freephoneline.ca to voip4.freephoneline.ca:6060
killerjay
Active Poster
 
Posts: 70
Joined: 06/14/2010
SIP Device Name: grandstream 286
ISP Name: cogeco
Computer OS: windows vista
Router: dir-655

Re: Registration keeps failing on voip.freephoneline.ca

Postby Liptonbrisk » 09/16/2016

These are ust a few general points:

1. It doesn't matter if you never changed settings and suddenly have a failed registration state or are suddenly getting dead air. It doesn't matter if the service worked fine for years. Unless FPL servers are down, the problem is likely to be on your end. http://status.fongo.com/

The problem may be related to a user not properly changing registration timers: http://support.freephoneline.ca/hc/en-u ... redentials
Registration Interval: 3600 seconds (1 hour), Registration Expiry: 3600 seconds (1 hour), Failed Registration Re-Try Interval: 120 seconds
If your timers are wrong, you can end up with a temporary IP ban with the specific FPL SIP server you're attempting to register with.

The problem can also include a user not understanding that there may be a corrupted NAT connection that has developed in his or her router to the ATA that needs to be reset.
In some cases, changing local SIP port or X_UserAgentPort is the most effective way of, temporarily, fixing this.The problem can arise due to the router's UDP timeout being in excess of the ATA's Failure Retry timer.


2. If changing local SIP Port (in SPAxxx, PAP ATAs, etc.) or X_UserAgentPort in Obihai ATAs works, that means you are dealing with a corrupted NAT connection in your router. Typically, it's best to choose a random value between 30000 and 60000 to help thwart SIP scanners and circumvent faulty/buggy SIP ALG features in routers.

3. voip4.freephoneline.ca:6060 is used for dealing with SIP ALG issues. Rogers Hitron router and modem combos have SIP ALG enabled by default with no way for user to disable that feature without getting a Rogers tech to do it for you. Other modem/router combos that are issued by ISPs can also have SIP ALG stuck on. Typically, it's best to have your own router with SIP ALG/SPI disabled in it and stick the ISP's router/modem in bridge mode.

To better understand why SIP ALG is horrible visit http://www.voip-info.org/wiki/view/Routers+SIP+ALG and read. Although SIP ALG is not broken in all routers (for example, the SIP Passthrough function in Asus routers doesn't seem to affect FPL), it is broken in a lot of them.

4. Proper device reboot order is always modem-->router (wait for it and your modem to be fully up, running, and passing data before turning on your ATA)-->ATA
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 989
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Registration keeps failing on voip.freephoneline.ca

Postby mh1983 » 09/17/2016

Lipton, I have a DSL modem/router combo that doesn't have an obvious way of disabling SIP ALG permanently. I plan to replace it with a better option at some point; until then, is it acceptable for me to use voip4.freephonline.ca:6060? I always thought that was specific to cable/Rogers connections. TIA!
mh1983
Lightly Seasoned
 
Posts: 223
Joined: 01/14/2014
SIP Device Name: Grandstream HT-701
Firmware Version: 1.0.7.3
ISP Name: Teksavvy DSL
Computer OS: Windows 10 64 bit
Router: Asus RT-N600
Smartphone Model: BlackBerry Passport

Re: Registration keeps failing on voip.freephoneline.ca

Postby Liptonbrisk » 09/17/2016

mh1983 wrote:Lipton, I have a DSL modem/router combo that doesn't have an obvious way of disabling SIP ALG permanently. I plan to replace it with a better option at some point; until then, is it acceptable for me to use voip4.freephonline.ca:6060? I always thought that was specific to cable/Rogers connections. TIA!


Yeah, voip4.freephoneline.ca:6060 is not isolated for use with a specific ISP. It's real intended use is to help with modem/router combos that have SIP ALG enabled with no way for the customer to disable the faulty SIP ALG feature in the router. This SIP server (voip4.freephoneline.ca) has a lot less to do with an ISP than the equipment being used.

Even if SIP ALG is disabled in your router, it's not as though voip4 won't work with it either. voip4.freephoneline.ca:6060 will work regardless.

So, if you don't have a SIP ALG/SPI issue, choosing amongst voip.freephoneline.ca:5060, voip2.freephoneline.ca:5060, and voip4.freephoneline.ca:6060 really comes down to your jitter and ping between you and these individual SIP servers. The lower the jitter (variation between each ping) and ping, the better. Server load is also a factor; I would imagine there are a lot less FPL users are using voip4.freephoneline.ca:6060, for example.

Jitter affects calls sounding choppy or even dropping. Typically it's best to have a router with strong QoS functions and enable QoS properly for your ATA. ISP modem/router combos frequently lack proper QoS functions. Ping affects voice delay (typically, the closer you are located, physically, to a SIP server, the lower your ping will be). Pings above 200ms are not acceptable.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 989
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Registration keeps failing on voip.freephoneline.ca

Postby mh1983 » 09/17/2016

Liptonbrisk wrote:
mh1983 wrote:Lipton, I have a DSL modem/router combo that doesn't have an obvious way of disabling SIP ALG permanently. I plan to replace it with a better option at some point; until then, is it acceptable for me to use voip4.freephonline.ca:6060? I always thought that was specific to cable/Rogers connections. TIA!


Yeah, voip4.freephoneline.ca:6060 is not isolated for use with a specific ISP. It's real intended use is to help with modem/router combos that have SIP ALG enabled with no way for the customer to disable the faulty SIP ALG feature in the router. This SIP server (voip4.freephoneline.ca) has a lot less to do with an ISP than the equipment being used.

Even if SIP ALG is disabled in your router, it's not as though voip4 won't work with it either. voip4.freephoneline.ca:6060 will work regardless.

So, if you don't have a SIP ALG/SPI issue, choosing amongst voip.freephoneline.ca:5060, voip2.freephoneline.ca:5060, and voip4.freephoneline.ca:6060 really comes down to your jitter and ping between you and these individual SIP servers. The lower the jitter (variation between each ping) and ping, the better. Server load is also a factor; I would imagine there are a lot less FPL users are using voip4.freephoneline.ca:6060, for example.

Jitter affects calls sounding choppy or even dropping. Typically it's best to have a router with strong QoS functions and enable QoS properly for your ATA. ISP modem/router combos frequently lack proper QoS functions. Ping affects voice delay (typically, the closer you are located, physically, to a SIP server, the lower your ping will be). Pings above 200ms are not acceptable.


Great info, thanks!

However, I switched to voip4 and while my ATA (HT-701) seems to be registered, I get a "that password is not valid" when I dial out. I switched back to my original voip (primary) and voip2 (secondary) setup, and I still get the password error. :(
mh1983
Lightly Seasoned
 
Posts: 223
Joined: 01/14/2014
SIP Device Name: Grandstream HT-701
Firmware Version: 1.0.7.3
ISP Name: Teksavvy DSL
Computer OS: Windows 10 64 bit
Router: Asus RT-N600
Smartphone Model: BlackBerry Passport

Re: Registration keeps failing on voip.freephoneline.ca

Postby Liptonbrisk » 09/17/2016

mh1983 wrote:
However, I switched to voip4 and while my ATA (HT-701) seems to be registered, I get a "that password is not valid" when I dial out.


SIP username and password are found after logging into https://www.freephoneline.ca/showSipSettings
You likely have the wrong credentials entered.

Check your settings from the .pdf at viewtopic.php?f=15&t=16292

After making the appropriate changes, reboot your router. Wait for it to be fully up and running (and passing data), and then reboot your ATA.

If everything checks out (right SIP username and SIP password), but you still have problems, open a support ticket at https://support.fongo.com/anonymous_requests/new and ask to have your account checked.
If no responds to your support ticket, provide the ticket number in a private message to Fongo Support: ucp.php?i=pm&mode=compose&u=7852
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 989
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Registration keeps failing on voip.freephoneline.ca

Postby mh1983 » 09/17/2016

Thanks, Lipton.

Maddening, because I didn't change the PWD to begin with. :) In any case:
- Settings checked as per PDF
- Password reentered (directly out of the SIP settings page you cite above)

I must've reentered the password from the page 3 times; each time it didn't appear to work. I just did so again, and now my SIP status shows as connected. Go figure; possibly human error, but I feel as though I'm losing my mind! Thanks for the quick reply in any case.
mh1983
Lightly Seasoned
 
Posts: 223
Joined: 01/14/2014
SIP Device Name: Grandstream HT-701
Firmware Version: 1.0.7.3
ISP Name: Teksavvy DSL
Computer OS: Windows 10 64 bit
Router: Asus RT-N600
Smartphone Model: BlackBerry Passport

Re: Registration keeps failing on voip.freephoneline.ca

Postby Liptonbrisk » 09/17/2016

mh1983 wrote:Maddening, because I didn't change the PWD to begin with.


People often tell me this, but they forget their browsers have autofill form/password functions, and one wrong click messes everything up automatically.

If you get that error, you need to double check your SIP credentials (password).

. I just did so again, and now my SIP status shows as connected.


Good!
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 989
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Registration keeps failing on voip.freephoneline.ca

Postby mh1983 » 09/18/2016

Lipton, you're right -- it was the Chrome autosave function. Thanks for pointing that out and sorry for the oversight!

All seems well now. One thing: should there be any indication that I am registered to voip4? My SIP status still shows voip.free...My 701 status doesn't mention any server, but it says I'm registered/on hook. I guess I can infer that I'm on voip4 now, but it's nice to see an official status update.

Thanks again.
mh1983
Lightly Seasoned
 
Posts: 223
Joined: 01/14/2014
SIP Device Name: Grandstream HT-701
Firmware Version: 1.0.7.3
ISP Name: Teksavvy DSL
Computer OS: Windows 10 64 bit
Router: Asus RT-N600
Smartphone Model: BlackBerry Passport

Re: Registration keeps failing on voip.freephoneline.ca

Postby Liptonbrisk » 09/18/2016

mh1983 wrote:
All seems well now. One thing: should there be any indication that I am registered to voip4? My SIP status still shows voip.free...


SIP Status isn't SIP settings, by the way. All my SIP status indicates in FPL's portal is "connected." No server is mentioned.

I wouldn't trust any SIP registration status on Freephoneline's web account portal. It always lags behind what's really happening. Always refer to the registration status in the ATA instead.


My 701 status doesn't mention any server, but it says I'm registered/on hook. I guess I can infer that I'm on voip4 now, but it's nice to see an official status update.


If you have voip4.freephoneline.ca as your Primary Sip Server in your ATA, then that's what you're using.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 989
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Registration keeps failing on voip.freephoneline.ca

Postby lobotiger » 09/20/2016

So I made it to 10 days with no failed registrations but this morning it had stopped trying to register at about 1:30AM EDT. Coincidentally enough that's around the time that my PPPoE session reset as well.

I did try to change over to voip4 but it refuses to register for some reason. I've put it back to voip and changed the retry interval from 30sec to 120sec to see if it makes any difference.

LoboTiger
lobotiger
Quiet One
 
Posts: 37
Joined: 03/06/2010

Re: Registration keeps failing on voip.freephoneline.ca

Postby Liptonbrisk » 09/20/2016

lobotiger wrote: I've put it back to voip and changed the retry interval from 30sec to 120sec to see if it makes any difference.


If your ATA attempts more than 5 registrations within a 5 minute period, you'll end up with an automatic temporary I.P. ban with the FPL SIP server being used.

http://community.freepbx.org/t/trunk-se ... ca/22479/8
"As May 2013, our servers will rate limit REGISTER requests to a maximum of 10 requests per 5 minutes. Each authentication round usually consumes 2 requests (digest auth), so it is a fair number given our guidelines. Also, it does not affect INVITES (which are also authenticated)...

This rate limit is applied per IP address as our service is tailored to residential Canadian users (ADSL/Cable)."


Visit http://support.freephoneline.ca/hc/en-u ... redentials
If you're not using the proper timer values specified, you're doing something wrong and should expect problems.

Also, double check your settings against the .pdf: viewtopic.php?f=15&t=16294
and refer to Mango's post below in that thread as well.

I did try to change over to voip4 but it refuses to register for some reason



Proxy: voip4.freephoneline.ca:6060

The :6060 needs to be specified in your ATA. And your timers need to be right.
You may have been dealing with a temporary IP ban.

Unless you're getting one-way audio issues or otherwise have less jittter and lower pings to voip4.freephoneline.ca, I would stick with the FPL SIP server you're using.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 989
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Registration keeps failing on voip.freephoneline.ca

Postby lobotiger » 09/29/2016

So I've been up now for about 9 days straight with no login failures to the server. This is after making the change to 120 seconds for retries. I think that might have been what fixed it for me. Might be something to add to the documentation or how-to guides since it's something that's different from when people like us registered years ago.

Thank you everyone for all the feedback and suggestions.

LoboTiger
lobotiger
Quiet One
 
Posts: 37
Joined: 03/06/2010

Re: Registration keeps failing on voip.freephoneline.ca

Postby mtlv » 10/02/2016

obi-conf.png
obi-conf.png (167.3 KiB) Viewed 11216 times
Hi,
I also have registration keep failing for me for approx. last two weeks. I've read messages above and tried various combinations but still no luck.
My setup: obihai OBI100 ata, dlink router on teksavvy's cable.
The setup was good for approx 2 years, then maybe couple months back things started fail occasionally and I had to power-cycle OBI100 occasionally, but last couple weeks were particularly unstable and now for last 2 days it's just does not work.

I used proxy: voip.freephoneline.ca
I also tried voip2.freephoneline.ca
and voip4.freephoneline.ca:6060
RegistrationPeriod and RegisterExpires :3600 (was always like that)
RegisterRetryInterval 120 (also is/was always like that)
in my router: I have SIP ALG disabled (but I also tried to enable it , just in case)

The status message is :Retrying Register (server=162.213.111.22:5060)

When I gave up on trying various combinations and wrote this post, I have just finally been able to set it with voip4.freephoneline.ca:6060, (though it didn't work before). I'll monitor this if it'll last.
mtlv
Just Passing Thru
 
Posts: 6
Joined: 10/02/2016
SIP Device Name: obihai obi100
Firmware Version: 3.4
ISP Name: Teksavvy, cable
Computer OS: Windows
Router: dlink

Re: Registration keeps failing on voip.freephoneline.ca

Postby Liptonbrisk » 10/04/2016

mtlv wrote:in my router: I have SIP ALG disabled (but I also tried to enable it , just in case)


Keep SIP ALG disabled.
https://www.obitalk.com/forum/index.php?topic=33.0

Also ensure whatever modem/router combo your ISP gave you is in bridge mode.

The status message is :Retrying Register (server=162.213.111.22:5060).


Navigate to Voice Services-->SP1 Service-->X_UserAgentPort
Pick a random number between 49152 and 65535.
Save/reboot

If that works a corrupted NAT connection that has developed between your router and your ATA that needs to be reset.
In some cases, changing X_UserAgentPort is the most effective way of, temporarily, fixing this.The problem can arise due to the router's UDP timeout being in excess of the ATA's Failure Retry timer.

Using a high random port also helps to thwart SIP scanners and may circumvent faulty SIP ALGs in routers.

The proper order for rebooting devices is always modem-->router (ensure that it's fully up and transmitting data)-->ATA.


Lastly, click http://forums.redflagdeals.com/newegg-obihai-obi202-ata-79-99-1-50-ehf-5-99-shipping-tax-2036007/#p26724391, and follow the instructions for setting up server failover.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 989
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Registration keeps failing on voip.freephoneline.ca

Postby Liptonbrisk » 11/17/2016

Liptonbrisk wrote:Lastly, click http://forums.redflagdeals.com/newegg-obihai-obi202-ata-79-99-1-50-ehf-5-99-shipping-tax-2036007/#p26724391, and follow the instructions for setting up server failover.


Use this link instead: http://forums.redflagdeals.com/newegg-o ... #p26724391
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 989
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Previous

Return to Community Support

Who is online

Users browsing this forum: No registered users and 2 guests

cron