Page 1 of 1

One way audio - only recently

PostPosted: 02/12/2020
by jpstoppa
Been using FPL (paid for unlock key) for years. Never had issues running it on my Android phones and windows PCs.

I've been using different software, but find Zoiper for Android, and Zoiper classic for windows works best. Always been using the voip.freephoneline.ca server, sometimes voip2 when things go down.

Never had issues with one way audio until about 2 weeks ago. It's not app specific, or ISP or wether I'm on 3G, LTE or wifi, since it is happening on both my Android phone and my Windows machine. I get one way audio (they hear me, I can't hear them) when calling landlines or mobile phones.

However, when I call FPL/Fongo numbers, it's working fine.

Has there been a server change recently?

Is there anything I can do? I've tried different ports, using an outbound proxy, stun server, RTP signalling, basically everything I could think of, and the same result.

The issue started around January 28th, 2020 (plus minus a day). That's the day I first noticed the issue making a call to a mobile number, I could not hear them but they could hear me.

Anyone know how to fix this?

Thanks

Re: One way audio - only recently

PostPosted: 02/12/2020
by Liptonbrisk
My Freephoneline accounts work fine using Acrobits Groundwire (smartphone app) and the Freephoneline desktop app (Windows 10).

Freephoneline doesn't proxy outbound audio. There's no need to specify outbound proxy. Stun servers introduce an additional point of failure (when they drop, so does your service).
If you're using multiple VoIP devices simultaneously, ensure they're not all using the same local SIP port and RTP port range.

If you can't hear incoming audio, then RTP packets (audio stream) aren't reaching your device.
Zoiper app uses UDP 8000 "and above": https://www.zoiper.com/en/support/answe ... /133/Ports.
Zoiper windows app uses random UDP port range between 32000 to 65535: https://www.zoiper.com/en/support/answe ... /116/Ports.
If the problem is a NAT firewall issue, according to their Zoiper Windows screenshot, you'd have to port forward UDP 8000 and then the entire UDP port range from 32000 to 65535 to the LAN IP
of your Windows computer. Port forwarding is a security risk and should only be attempted when all else fails.

If the problem is the RTP stream isn't even reaching your router in the first place, then the issue likely involves SIP headers (possibly RTP packets are being sent to a LAN IP instead of your WAN IP from FPL's server). I would try using voip4.freephoneline.ca:6060. I notice Zoiper has a community forum located at https://community.zoiper.com/. You might want to contact the developer or support team and provide them with log files from Zoiper to help you troubleshoot: https://www.zoiper.com/en/contact.

You could try using voip4.freephoneline.ca:6060. That server works fine for everyone. It has nothing to do with Rogers specifically. That server's purpose is to circumvent SIP ALG issues. DD-WRT does not have a SIP ALG feature that I'm aware of. Regardless, it may be worth trying voip4.freephoneline.ca:6060 anyway.

For testing purposes only, you may also want to try disabling IPv6 and using IPv4 only to see if that makes a difference (in the past, there were some issues involving Fongo Mobile and IPv6, but that should have been fixed by now).



Yes, there have been changes: viewtopic.php?f=15&t=19702.
Also visit https://status.fongo.com/.
Again, I'm not experiencing issues, but I'm not using Zoiper.


1) Have you tried your own ATA?

In your PAP2T, navigate to the SIP tab-->NAT Support Parameters, and make sure that the following settings are enabled:

a)Handle VIA received-->yes
b)Handle VIA rport-->yes
c)Substitute VIA Addr-->yes

Enabling those settings in your ATA helps to ensure RTP packets are being sent to your WAN IP instead of nowhere (your LAN IP) from FPL's servers.


2) Have you tried the Freephoneline desktop app?

If your ATA or the Freephoneline desktop app works for you, then the issue might specific to using Zoiper with Freephoneline.


---

For the Freephoneline desktop app . . .

Make sure that you're not muting anything (microphone/speakers), and that you tested to ensure your mic is working before fiddling around with the app: http://win10faq.com/fix-microphone-settings/

And make sure you test incoming calls for 1-way audio issues before paying anything to FPL (you'll need a mic and headphones/speakers to test). Test on a computer that's connected to your router (without DMZ or port forwarding enabled). Should you encounter 1-way audio issues, look for a feature called SIP ALG in your router (you may need to call your ISP if you're using a modem/router combo) and disable that feature.

a. Netgear R7000 routers

Update firmware. Disable SIP ALG in this router. Then reboot modem, router, and ATA in that order. Then test again.

If you have a Netgear R7000 router, you may need to install third party XWRT-Vortex firmware. I recommend doing this anyway to obtain easy access to both UDP Unreplied and UDP Assured timeout settings. Afterwards, turn off the router and the ATA. Turn on the router. Wait for it to be fully up and running (including Wi-Fi). Then turn on the ATA. Download XWRT-Vortex here: http://xvtx.ru/xwrt/download.htm. In your router, navigate to Advanced Settings–>WAN–>NAT Passthrough–>SIP Passthrough. Change SIP Passthrough to “Enabled + NAT helper.” Click “Apply.”

b. Nettis 4422 modem from Carry Telecom (click the "Internet" tab)
http://www.carrytel.ca/support.aspx
c : DSL - My VoIP phone does not work with Netis 4422 modem.
d : Please download the newest Netis firmware at http://www.carrytel.ca/download/netis1228.zip. Unzip the netis1228.zip file and update the firmware file netis1228.img for your modem. The new firmware has been tested and working with most of Voip phone providers

Re: One way audio - only recently

PostPosted: 02/12/2020
by Liptonbrisk
(continued)


e. Asus VLAN

A number of people have been trying to eliminate Bell Hubs from their setups by using Asus VLAN.
At the time of this guide being written, NAT acceleration must be disabled in that VLAN setup in order for SIP services, including Freephoneline, to work properly. In your router, navigate to Advanced Settings-->LAN-->Switch Control-->NAT Acceleration. Select "disable." Click "apply."Then reboot your modem, router (wait for Wi-Fi SSIDs to populate first before rebooting ATA), and your ATA, in that order.

To determine whether you need NAT Acceleration enabled, visit https://routerguide.net/nat-acceleration-on-or-off/. If you do require NAT Acceleration to be enabled, don’t use VLAN with Asus routers.

f. Hitron CGN series gateway modem/router combos (from Rogers, Shaw, or another ISP) or any modem/router combo from any ISP with SIP ALG forced on

If you don’t have your own router, and if you can’t get someone from Rogers or your ISP to disable SIP ALG for you in their modem/router combo, your ATA may need to register with voip4.freephoneline.ca:6060. The purpose of voip4.freephoneline.ca:6060 is to help circumvent faulty SIP ALG features in routers. So, if you’re experiencing one-way audio issues as a result of SIP ALG, this is the SIP server to try. Check to ensure that you can’t disable SIP ALG yourself (refer to point E below).

g. Hitron CGN3ACSMR and CODA-4582 series gateway modem/router combos from Rogers (and possibly other ISPs)
Open your web browser, and login at 192.168.0.1. Default username is cusadmin.
Select the “Basic” tab and disable “SIP ALG.” Click the “save changes” button.


h. Concerning Bell Hubs, (This may also apply to Telus)

Typically it's better to have your own router and to stick whatever modem/router combo your ISP gives you into bridge mode:
http://forums.redflagdeals.com/please-s ... r-1993629/







Steps i,ii, and iv below are for help dealing with 1-way audio issues with Freephoneline desktop application.


from http://forums.redflagdeals.com/fongo-at ... #p27011164

You can try the Freephoneline desktop app for free: https://www.fongo.com/app/desktop/
It requires 32-bit Java to run. If you have problems installing the desktop app, visit viewtopic.php?f=8&t=19063&p=74810.


A.Use winmtr http://winmtr.net/download-winmtr/

B. For Freephoneline.ca (based in Ontario), test to voip.freephoneline.ca (let winmtr ping about 100 times), voip2.freephoneline.ca, and voip4.freephoneline.ca. You can copy text to clipboard and paste your results (do not post your own IP public address though) and post them for others to examine if you want.

C. Look at the very last hop or line. Take a look at your average ping--and your maximum. You want those values to be relatively close.
You do not want high pings and lots of jitter (you do not want a lot of variation between each ping). If you get horrible results (pings over 200ms), you should probably avoid FPL.

I get between 11 (voip.freephoneline.ca and voip2.freephoneline.ca)-24ms (voip4.freephonline.ca) on average, depending on the server I'm testing to. Preferably, you want pings below 100ms.

Anything over 200ms is unacceptable.

What you don't want to see is 40, 45, 50, 35, 500, 40, 30, 45, 700. That's bad jitter.
You want relatively consistent pings without a lot of variation.

Try the free FPL desktop app first: https://www.fongo.com/app/desktop/

Make sure that you're not muting anything (microphone/speakers), and that you tested to ensure your mic is working before fiddling around with the app: http://win10faq.com/fix-microphone-settings/

And make sure you test incoming calls for 1-way audio issues. Test on a computer that's connected to your router (without DMZ or port forwarding enabled). Should you encounter 1-way audio issues, look for a feature called SIP ALG in your router (you may need to call your ISP if you're using a modem/router combo) and disable that feature.


i. Typically it's better to have your own router and to stick whatever modem/router combo your ISP gives you into bridge mode.

ii. Disable SIP ALG in your own router. Many modem/router combos that are issued by ISPs have faulty SIP ALG/SPI functions enabled, with no way to disable them. These features can mangle SIP headers. If you don't know how to disable SIP ALG, contact your router's brand or contact your ISP.

To understand why SIP ALG is often a serious headache visit https://www.voip-info.org/routers-sip-alg/
(scroll down to "SIP ALG Problems")

iii. Properly enable QoS in your router for your computer that's running the Freephoneline desktop app (and ensure no other programs are running on your computer that are hogging bandwidth while using the Freephoneline desktop app). Refer to your router's manual or contact your ISP if you were issued a modem/router combo from them (typically those routers suck and have horrible or absent QoS functions).

I'm not a huge fan of this website, but it suffices for an explanation of QoS: http://www.voipmechanic.com/qos-for-voip.htm
Avoid anything it says about the G.729


iv. If you still get one-way audio issues with the Freephoneline desktop app, you may need to port forward, which is a security risk (and not advisable).

The FPL desktop app uses ports 5060-5061,6060-6061,13000-13001 if you're going to port forward for the desktop app (you need to port forward to the LAN IP of the computer you're using. For most home networks the IP will begin 192.168.xxx.x). Refer to your router's manual to learn how to port forward (if your router came from your ISP, contact your ISP).

I would start just by port forwarding 13000-13001 only, which is for RTP (audio packets). If that still doesn't work, you can try adding 6060 or 6061. The most dangerous ports to forward are 5060-5061 and really shouldn't be necessary if you're forwarding 6060 or 6061 anyway. I guess if all else fails, forward all of them: 5060, 5061,6060, 6061,13000, and 13001.

These are all UDP ports.

5060, 5061, 6060, and 6061 should be alternate SIP ports.

Only port forward if all else fails (and only do it temporarily, since it's a security risk).

Re: One way audio - only recently

PostPosted: 02/14/2020
by jpstoppa
Like I said in my original post, the service has always worked for me. Never had one-way audio issues. The one-way audio started happening around January 28th. Both on my android phone and on my windows PC. I even bypassed my router and connected directly to my DSL modem, disabled firewall, tried voip4.freephoneline.ca:6060, still a no go. Same with my phone, be it on Wi-Fi or using my carriers LTE connection, still get one-way audio.

I tried all the suggestions mentioned. One thing of note is that I am not using Fongo, i have a Freephoneline unlock key which i purchased years ago and never had issues with any type of connection I used or whatever software, be it XLite, Acrobits, Zoiper, Androids built in VOIP, etc.

Could it be that this is being caused by a server-side change???

Re: One way audio - only recently

PostPosted: 02/14/2020
by jpstoppa
Just out of curiosity in hopes to get the service working, I installed the Freephoneline app for windows. Still the same issue, I am unable to hear the other party when calling landline or mobiles. Only calls to FPL and Fongo work correctly.

Re: One way audio - only recently

PostPosted: 02/14/2020
by Liptonbrisk
jpstoppa wrote:Like I said in my original post, the service has always worked for me.


I'm aware.

Your situation is different given the service isn't working for you over LTE either, but typically having the service work fine previously isn't useful information given that NAT corruption can develop in routers without users doing anything. In your case, it is possible one of the changes made during server migration is affecting you, but I'm not positive. viewtopic.php?f=15&t=19702

Never had one-way audio issues.


This user didn't either: viewtopic.php?f=8&t=19736. Then he had an incoming audio issue and followed my instructions. Problem solved.

I even bypassed my router and connected directly to my DSL modem, disabled firewall


Are you using DD-WRT? You should be using PPPoE login using your own router instead to bypass the router features in the modem/router combo issued by your ISP: http://forums.redflagdeals.com/please-s ... r-1993629/.
Preferably, test using your ATA by performing PPPoE login using your ATA instead; that's how you can truly rule out your ISP's modem/router combo and your own router as being causes.


tried voip4.freephoneline.ca:6060, still a no go


Then it's unlikely a SIP ALG issue.

Have you tried using your ATA and doing PPPoE login using the ATA in addition to enabling the VIA settings I mentioned earlier?
If logging in using PPPoE works in your ATA, the problem involves your ISP's modem/router combo. Using PPPoE login in your ATA completely bypasses potential buggy NAT/router features in the modem/router combo.

Then these settings also need to be enabled in your ATA as well:
a)Handle VIA received-->yes
b)Handle VIA rport-->yes
c)Substitute VIA Addr-->yes

LTE rules out your modem and router while using your smartphone, but it doesn't rule out an issue that might be specific to using Freephoneline with Zoiper, your specific Android firmware, or your mobility service provider (something involving IPv6, potentially).

One thing of note is that I am not using Fongo,


That's apparent. You can't use Fongo Mobile nor Fongo Home phone with Zoiper. While the front-end for each service differs, the VoIP portion of those services are the same as FPL.

Could it be that this is being caused by a server-side change?


Yes (changes have been made affecting caller ID; you can't spoof CID anymore, but that specific change shouldn't cause a 1-way audio problem). Your problem could involve a change made in SIP headers.
But there could also be a number of other possible causes, including codec mismatch (try G.711u only in Zoiper). A problem involving the Freephoneline desktop app should not be a codec mismatch issue.

Bottom line is RTP audio packets (UDP ports are used for RTP) aren't reaching your VoIP device(s). I do not know what the cause is.

I'm not having an issue with Groundwire (LTE or Wi-Fi), the Freephoneline desktop app (Windows 10), nor ATAs/IP phones on any of my FPL accounts.

If you're convinced the problem is with your FPL account (it's possible there was an issue during migration), then you can try submitting a ticket to have your account looked at: https://support.fongo.com/hc/en-us/requests/new. But they don't officially offer free technical support for Freephoneline.

Re: One way audio - only recently

PostPosted: 02/14/2020
by Liptonbrisk
jpstoppa wrote:Just out of curiosity in hopes to get the service working, I installed the Freephoneline app for windows. Still the same issue, I am unable to hear the other party when calling landline or mobiles.


Try forwarding the RTP ports (UDP 13000 and UDP 13001) to the LAN IP of your computer.

The FPL desktop app uses ports 5060-5061,6060-6061,13000-13001 if you're going to port forward for the desktop app (you need to port forward to the LAN IP of the computer you're using. For most home networks the IP will begin 192.168.xxx.x). Refer to your router's manual to learn how to port forward (if your router came from your ISP, contact your ISP).

I would start just by port forwarding 13000-13001 only, which is for RTP (audio packets). If that still doesn't work, you can try adding 6060 or 6061 (these alternative ports are used for SIP signalling). The most dangerous ports to forward are 5060-5061 (these are traditional UDP ports used for SIP signalling; also buggy SIP ALG features in routers listen to these 5060 and/or 5061 UDP ports and mangle SIP headers) and really shouldn't be necessary if you're forwarding 6060 or 6061 anyway. I guess if all else fails, forward all of them: 5060, 5061,6060, 6061,13000, and 13001. Port forwarding UDP 5060 and 5061 is dangerous because those are usually the first ports SIP scanners attack. Port forwarding is always a security risk.

These are all UDP ports.

If that doesn't work, then you'd have to start looking at SIP traces (getting logs) and looking at SIP headers. I would begin to suspect that the RTP audio stream isn't reaching your modem/router combo in the first place.
If you have logs for people to inspect, you might want to try asking at https://www.dslreports.com/forum/voip for further help unless other people are willing to parse SIP headers for you. Unfortunately, I don't have the time.

Only calls to FPL and Fongo work correctly.


Those (FPL to FPL or to Fongo) are treated as SIP URI calls, as far as I know, whereas calls to landlines and regular mobile numbers wouldn't be.

Other than what I've already stated in this thread, I have no further suggestions.