Can't hear the other side on inbound calls

Have a question or problem with your Fongo application? This forum is the place to get help from both staff and fellow community members.
Fongo recommends Fongo Home Phone for a fully supported Home Phone system for only $4.95/mo

Can't hear the other side on inbound calls

Postby richardjhy » 07/12/2019

Since using frephoneline for so many years, it's my first time having an issue with.
Late last month I switched to Virgin Mobile Home Internet FTTH 50D/10U. They provided me a modem called Valerie. Every thing works perfectly except I can't hear the other side when someone called my freephone line number (The other side can hear me, and freephone line is OK for outbound calls).
My ATA is Linksys WRTP54G (It's router and voip adapter combo but I only use it as the adapter for freephone line) and it was hooked up directly to Valerie modem.
Called Virgin tech support and was told that there were nothing they can do with modem settings. The support asked me to contact Freephoneline support. Hope someone here can help me solve the problem.
Thanks in advance for any input.
richardjhy
Just Passing Thru
 
Posts: 5
Joined: 03/21/2013
SIP Device Name: Linksys WRTG54G
Firmware Version: 3.1.27
ISP Name: Virgin Mobile Home Internet, FTTH
Computer OS: WINDOWS 10
Router: TP-LINK

Re: Can't hear the other side on inbound calls

Postby Liptonbrisk » 07/12/2019

richardjhy wrote:Since using frephoneline for so many years, it's my first time having an issue with.
Late last month I switched to Virgin Mobile Home Internet FTTH 50D/10U. They provided me a modem called Valerie.


That's not just a modem. It's a modem/router combo (should be a Virgin rebranded Bell Home Hub 3000 or Virgin rebranded Sagemcom Fast 5566), and it's the router portion of that device that's causing issues.
If there's no way to disable SIP ALG in it (or to use that device in bridge mode), you can try doing PPPoE login using your WRTP54G. The settings should be found under Setup-->Basic Setup-->Internet Connection Type. Using the WRTP45G to do PPPoE login bypasses any NAT or SIP ALG features in Valerie. Alternatively, you can use voip4.freephoneline.ca:6060 for the proxy in WRTP54G to circumvent SIP ALG in Valerie. Then reboot Valerie, wait for it to be fully up and running, and finally, reboot, the WRTP54G.

Proper device reboot order is always Modem-->router (wait for Wi-Fi SSiDs to populate first)--> and finally ATA.

If you don’t have your own (decent . . .as defined below) standalone router, and if you can’t get someone from your ISP to disable SIP ALG for you in their modem/router combo, your ATA may need to register with voip4.freephoneline.ca:6060 instead of what you're currently using. The purpose of voip4.freephoneline.ca:6060 is to help circumvent faulty SIP ALG features in routers. So, if you’re experiencing one-way audio issues as a result of SIP ALG, that is the SIP proxy server to try.

Follow these steps, step by step:

1. In your WRTP54G, Navigate to Voice-->Line -->SIP settings, change SIP Port to a random number between 30000 and 60000. Do this for security reasons.


2. In your WRTP54G, Navigate to Voice--> SIP tab-->NAT Support Parameters, and make sure that the following settings are enabled (if they are available):

a)Handle VIA received-->yes
b)Handle VIA rport-->yes
c)Substitute VIA Addr-->yes

This helps to ensure RTP audio packets are being sent to your public WAN IP address as opposed to somewhere in space (LAN IP address). Not enabling these settings can cause 1-way audio problems when using Freephoneline.

3. Do PPPoE login (you'll need your username and virgin password credentials) using WRTP54G to circumvent potential NAT and SIP ALG issues in Valerie, and save settings. Then reboot devices in order listed above.
The settings should be found under Setup-->Basic Setup-->Internet Connection Type. Test with an incoming call. If everything works, don't bother with steps 4 to 6.


4. Alternatively, In your WRTP54G, Navigate to Voice-->Line-->Proxy and Registration-->change proxy to voip4.freephoneline.ca:6060
Again, this is done to circumvent buggy SIP ALG features in routers. In some cases these features are forced on with no way for the customer to disable them.

5. Save settings.

6. Reboot Valerie (wait for Wi-Fi SSiDs to populate), and then reboot WRTP54G. Retest with an incoming call.




---
Typically, for VoIP SIP services, especially for freephoneline, you want

A) a router that does not have a full cone NAT,

Visit https://www.think-like-a-computer.com/2 ... es-of-nat/.
Mango from the Obitalk.com forums writes,
“Use a restricted cone NAT router, and do not use port forwarding or DMZ. Restricted cone NAT will only permit
inbound traffic from the service provider you're registered to. If you have a full cone NAT router, it will allow traffic
from any source. This is probably not what you intend.
If you have a Windows computer, you can test your router using the utility here:
http://www.dslreports.com/forum/remark,22292023. To run it, use stun stun.ekiga.net from a command prompt.”
Essentially, you download the stun-test.zip file; extract the stun.exe file from within the zip file to an easily
accessible location; use an elevated command prompt (visit
http://www.thewindowsclub.com/how-to-ru ... inistrator); change directory (cd) to the
directory or location where you extracted stun.exe (visit
http://www.digitalcitizen.life/command- ... c-commands); and type “stun stun.ekiga.net” without
the quotation marks followed by the enter/return button on your keyboard.
Asus routers, at the time of this writing, produce port restricted cone NAT routers, for example and are fine,
provided you’re using one with Asuswrt-Merlin, third party firmware installed.

B) a router that lets you disable SIP ALG if it's buggy,

To understand why SIP ALG often causes horrible problems, please visit
http://www.voip-info.org/wiki/view/Routers+SIP+ALG (scroll down to the section on SIP ALG problems).

If you're dealing with a modem/router combo issued by an ISP or a router with SIP ALG forced on, you may have
to use voip4.freephoneline.ca:6060 for the Proxy Server. The purpose of voip4.freephoneline.ca:6060 is to circumvent
faulty SIP ALG features in routers.

C) a router that allows you to set QoS or assign highest priority to your ATA or IP Phone over all other devices on your LAN (local area network),

For a very general description of what QoS can do for you, visit https://www.voipmechanic.com/qos-for-voip.htm.
The basic idea is if you're torrenting or have a bunch of other computers, smartphones, tablets, etc. downloading and uploading (hogging all your available bandwidth), you don't want
your ATA not to have access to enough bandwidth to make or receive calls properly. So QoS or a Bandwidth Monitor feature (which is just another form of QoS) is a really good idea for VoIP users.

I often get an occasional relative complaining to me, "Hey my calls sound choppy." And then when I go visit, some kids are playing MMOs on a computer, while another person is downloading a huge file,
and another person is backing up files to a cloud service all at the same time someone else is trying to talk on the phone. All those devices, without QoS enabled, are fighting over available bandwidth along with the ATA.

and D) A router that lets you adjust both Unreplied and Assured UDP timeouts.

Thanks to Mango, many of us now understand that in order for ATAs to remain registered and working properly with a VoIP SIP provider like Freephoneline, in particular after power failures, the following conditions must be met:

UDP Unreplied Timeout (in your router) < SIP OPTIONS Keep Alive Interval (in your ATA; for Obihai ATAs this is X_KeepAliveExpires) < UDP Assured Timeout (in your router) < SIP Registration Failure Retry Wait Time:(or RegisterRetryInterval in Obihai ATAs)

“<“ means less than.

When a modem leases a new IP address, a problem can arise where prior associations using the old IP address are maintained in the router. When the ATA attempts to communicate using the old IP address, the response is unreplied, and then if the UDP Unreplied timeout is greater than the Keep Alive Interval (and UDP Unreplied timeout is often set to 30 by default in consumer routers) a problem arises where the corrupted connection persists. If UDP Unreplied timeout is, for example, 17, and the NAT Keep Alive Interval is 20, then the corrupted connection will timeout or close. A new connection will be created, and everything will work fine.

Another problem can occur when the Keep-Alive interval is greater than UDP Assured Timeout (often 180 by default in consumer routers): the NAT hole will close due to the ATA not communicating frequently enough with the SIP server. In turn, incoming calls may, intermittently, not reach the ATA. Again, X_Keepalives expires is supposed to be 20 with FPL.

(the above settings are making reference to those in Obihai ATAs)

Getting access to both UDP Unreplied Timeout and UDP Assured Timeout settings in consumer routers may be difficult, if not impossible. Asuswrt-Merlin (I would avoid any model below/less powerful than an RT-AC68U), third party firmware for Asus routers, does offer easy access to these two settings, which are found under General–>Tools-->Other settings. My understanding is that third party Tomato firmware has these two settings as well. So if your router supports Tomato firmware, that may be another option. Note that I will not be held accountable any damage resulting from failed firmware updates. Apparently, Mikrotik routers also allow users to change both Assured and Unreplied UDP timeout settings as well: https://forums.redflagdeals.com/recomme ... 2115672/2/

The keep alive interval for FPL is 20. The SIP Registration Failure Retry Wait Time is 120. I use 17 for UDP Unreplied Timeout and 117 for UDP Assured Timeout.



ISPs do not issue customers routers that can do all four things I just listed. Typically it's far better to have your own router with strong QoS functions and a restricted cone NAT firewall,
disable whatever SIP ALG feature is enabled in the router, and stick whatever modem/router combo your ISP gives you into bridge mode. For Bell Hubs, visit http://forums.redflagdeals.com/please-s ... r-1993629/. For Rogers, visit https://www.rogers.com/customer/support ... ridgemodem.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 978
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Can't hear the other side on inbound calls

Postby Liptonbrisk » 07/12/2019

Full steps can be found at http://forums.redflagdeals.com/freephon ... #p26808549 (different ATA model, but the settings are similar). Refer to steps 1 to 12 towards the bottom of the post.

Lastly, double check your settings against those listed at viewtopic.php?f=15&t=16294. They should be similar. Note that voip4.freephoneline.ca:6060 isn't just for Rogers Hitron modem/router combos. voip4.freephoneline.ca:6060 is for any router that doesn't allow you to disable a buggy SIP ALG feature.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 978
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Can't hear the other side on inbound calls

Postby richardjhy » 07/12/2019

Liptonbrisk wrote:Full steps can be found at http://forums.redflagdeals.com/freephon ... #p26808549 (different ATA model, but the settings are similar). Refer to steps 1 to 12 towards the bottom of the post.

Lastly, double check your settings against those listed at viewtopic.php?f=15&t=16294. They should be similar. Note that voip4.freephoneline.ca:6060 isn't just for Rogers Hitron modem/router combos. voip4.freephoneline.ca:6060 is for any router that doesn't allow you to disable a buggy SIP ALG feature.


Thanks you very much. You're a life saver! Now my freephoneline works normal.
richardjhy
Just Passing Thru
 
Posts: 5
Joined: 03/21/2013
SIP Device Name: Linksys WRTG54G
Firmware Version: 3.1.27
ISP Name: Virgin Mobile Home Internet, FTTH
Computer OS: WINDOWS 10
Router: TP-LINK

Re: Can't hear the other side on inbound calls

Postby Liptonbrisk » 07/12/2019

richardjhy wrote:
Thanks you very much. You're a life saver! Now my freephoneline works normal.



I’m glad the service is working well for you again.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 978
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Can't hear the other side on inbound calls

Postby mrmastii » 08/06/2019

I am facing same problem, with no voice on incoming calls. Outgoing calls has no issue and no issue with registration as well.
I have followed the steps and setting mention above with no luck.
PS: I had this FPL for over two years and problem started since yesterday.
ATA :-> Cisco SPA-122, Version 1.4.1 (SR4)
ISP: Bell fiber to the home, SAP ALG disabled

please advise
mrmastii
One Hit Wonder
 
Posts: 1
Joined: 08/06/2019

Re: Can't hear the other side on inbound calls

Postby Liptonbrisk » 08/06/2019

mrmastii wrote:I am facing same problem, with no voice on incoming calls. Outgoing calls has no issue and no issue with registration as well.


Just to confirm, when you login at https://www.freephoneline.ca/showSipSettings, you see that SIP Status shows "connected" and SIP User Agent indicates
your SPA122, correct?

Registration is required for incoming calls. Registration is not required for outgoing calls.

Note that only one registration per FPL account is allowed at any time. When there are multiple devices/softphones using the same account, only the most recent registration is valid. The previous device will lose registration.



I have followed the steps and setting mention above with no luck.
PS: I had this FPL for over two years and problem started since yesterday.
ATA :-> Cisco SPA-122, Version 1.4.1 (SR4)
ISP: Bell fiber to the home, SAP ALG disabled



What brand and model router are you using? I was under the impression it's impossible to disable SIP ALG in Bell Hubs. Has that changed?


Proper device reboot order is always Modem-->router (wait for Wi-Fi SSiDs to populate first)--> and finally ATA.
A hub is a modem/router combo. So device reboot order would be Hub (wait for Wi-Fi SSiDs to populate first)-->ATA if you're not using your own router.

Typically it's far better to have your own router with strong QoS functions and a restricted cone NAT firewall,
disable whatever SIP ALG feature is enabled in the router, and stick whatever modem/router combo your ISP gives you into bridge mode. For Bell Hubs, visit http://forums.redflagdeals.com/please-s ... r-1993629/.

1) Log into your ATA

2) Navigate to Voice-->Line (choose the one used for FPL) -->SIP settings.

Change SIP Port to a random number between 30000 and 60000. Do this for security reasons.

Submit settings.

3) Navigate to Voice-->SIP-->NAT Support Parameters

Make these changes:
a)Handle VIA received-->yes
b)Handle VIA rport-->yes
c)Substitute VIA Addr-->yes

Submit settings.

This helps to ensure RTP audio packets are being sent to your public WAN IP address as opposed to somewhere in space (LAN IP address). Not enabling these settings can cause 1-way audio problems when using Freephoneline.

4) Do PPPoE login (you'll need your Bell username and password credentials) using SPA122 to circumvent potential NAT and SIP ALG issues in the Bell Hub, and save settings. Then reboot devices in order listed above.
The settings should be found under Network Setup-->Basic Setup-->Internet Settings-->Internet Connection Type (Choose PPPoE). Test with an incoming call. If everything works, don't bother with steps 5 to 7.

5. Alternatively, In your SPA122, Navigate to Voice-->Line (FPL)-->Proxy and Registration-->change proxy to voip4.freephoneline.ca:6060
Again, this is done to circumvent buggy SIP ALG features in routers. In some cases these features are forced on in routers and modem/router combos or gateways with no way for the customer to disable them.

6. Save settings.

7. Reboot using the device reboot order listed above. Retest with an incoming call.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 978
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin


Return to Community Support

Who is online

Users browsing this forum: No registered users and 5 guests

cron