Incoming calls go straight to voice mail

Have a question or problem with your Fongo application? This forum is the place to get help from both staff and fellow community members.
Fongo recommends Fongo Home Phone for a fully supported Home Phone system for only $4.95/mo

Incoming calls go straight to voice mail

Postby mjazster » 08/11/2019

I am new to freephone line and am using the Grandstream HT802 as the ATA. Although everything else seems to be working fine, I have issues with my incoming calls going straight to voice mail. People calling me have indicated that as soon as the line connects, it does not ring but a standard message states that ''The person you are trying to call is not available". I have tried this myself by calling my freephone line number from my cell and can confirm the same. When I unplug my ATA and replug, it seems to work for one incoming call only and then the subsequent calls go to voice mail. Also, want to mention that my ATA is connected to a Home Hub 200 modem supplied by Bell - my ISP. If someone experienced a similar problem and resolved it, I would be very grateful for your help!
Thank you.
mjazster
Just Passing Thru
 
Posts: 3
Joined: 08/10/2019
SIP Device Name: Grandstream HT802
ISP Name: Bell Canada DSL
Computer OS: macOS Mojave
Router: Home Hub 2000

Re: Incoming calls go straight to voice mail

Postby Liptonbrisk » 08/11/2019

1. Use this PDF guide to ensure your ATA is configured properly: viewtopic.php?f=15&t=18839#p74000.
I appreciate that your have a different model ATA, but the settings should be similar.

Check all settings, especially

a. Enable SIP Options Keep Alive: Yes
b. SIP OPTIONS Keep Alive Interval: 20
c. SIP REGISTER Contact Header Use: WAN Address
d. Use Random SIP Port: Yes
e. Register Expiration: 60 minutes (default)
f. SIP Registration Failure Retry Wait Time: 120 seconds


2. Log in at https://www.freephoneline.ca/showSipSettings. Ensure that SIP Status indicates "connected" and that SIP User Agent shows your ATA. Registration is required for incoming calls, but it's not a requirement for outgoing calls.

3. Login at https://www.freephoneline.ca/voicemailSettings. Ensure "Rings Before Voicemail" isn't set to 1.

4. Perhaps you've accidentally enabled Do Not Disturb. I believe with Grandstream ATAs, you dial *79 to disable DND.

5. If incoming calls still don't work, the problem is the Bell Hub, which isn't just a modem. It's a modem/router combo, and it's the router portion of the device that's causing problems.
In the ATA, use PPPoE to bypass NAT issues/SIP ALG in the Bell Hub.

Log into your ATA, and navigate to Basic Settings-->IP address.
Select "use PPPoE".
You'll require your PPPoE account username and password from Bell. Fill them in.
Click "apply".

Proper device reboot order is always Modem-->router (wait for Wi-Fi SSiDs to populate first)--> and finally ATA.

Then test again with an incoming call.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 989
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Incoming calls go straight to voice mail

Postby Liptonbrisk » 08/11/2019

Liptonbrisk wrote:
3. If incoming calls still don't work, the problem is the Bell Hub, which isn't just a modem. It's a modem/router combo, and it's the router portion of the device that's causing problems.
In the ATA, use PPPoE to bypass NAT issues/SIP ALG in the Bell Hub.





---


Typically, for VoIP SIP services, especially for freephoneline, you want

A) a router that does not have a full cone NAT,

Visit https://www.think-like-a-computer.com/2 ... es-of-nat/.
Mango from the Obitalk.com forums writes,
“Use a restricted cone NAT router, and do not use port forwarding or DMZ. Restricted cone NAT will only permit
inbound traffic from the service provider you're registered to. If you have a full cone NAT router, it will allow traffic
from any source. This is probably not what you intend.
If you have a Windows computer, you can test your router using the utility here:
http://www.dslreports.com/forum/remark,22292023. To run it, use stun stun.ekiga.net from a command prompt.”
Essentially, you download the stun-test.zip file; extract the stun.exe file from within the zip file to an easily
accessible location; use an elevated command prompt (visit
http://www.thewindowsclub.com/how-to-ru ... inistrator); change directory (cd) to the
directory or location where you extracted stun.exe (visit
http://www.digitalcitizen.life/command- ... c-commands); and type “stun stun.ekiga.net” without
the quotation marks followed by the enter/return button on your keyboard.
Asus routers, at the time of this writing, produce port restricted cone NAT routers, for example and are fine,
provided you’re using one with Asuswrt-Merlin, third party firmware installed.

B) a router that lets you disable SIP ALG if it's buggy,

To understand why SIP ALG often causes horrible problems, please visit
http://www.voip-info.org/wiki/view/Routers+SIP+ALG (scroll down to the section on SIP ALG problems).

If you're dealing with a modem/router combo issued by an ISP or a router with SIP ALG forced on, you may have
to use voip4.freephoneline.ca:6060 for the Proxy Server. The purpose of voip4.freephoneline.ca:6060 is to circumvent
faulty SIP ALG features in routers.

C) a router that allows you to set QoS or assign highest priority to your ATA or IP Phone over all other devices on your LAN (local area network),

For a very general description of what QoS can do for you, visit https://www.voipmechanic.com/qos-for-voip.htm.
The basic idea is if you're torrenting or have a bunch of other computers, smartphones, tablets, etc. downloading and uploading (hogging all your available bandwidth), you don't want
your ATA not to have access to enough bandwidth to make or receive calls properly. So QoS or a Bandwidth Monitor feature (which is just another form of QoS) is a really good idea for VoIP users.

I often get an occasional relative complaining to me, "Hey my calls sound choppy." And then when I go visit, some kids are playing MMOs on a computer, while another person is downloading a huge file,
and another person is backing up files to a cloud service all at the same time someone else is trying to talk on the phone. All those devices, without QoS enabled, are fighting over available bandwidth along with the ATA.

and D) A router that lets you adjust both Unreplied and Assured UDP timeouts.

Thanks to Mango, many of us now understand that in order for ATAs to remain registered and working properly with a VoIP SIP provider like Freephoneline, in particular after power failures, the following conditions must be met:

UDP Unreplied Timeout (in your router) < SIP OPTIONS Keep Alive Interval (in your ATA; for Obihai ATAs this is X_KeepAliveExpires) < UDP Assured Timeout (in your router) < SIP Registration Failure Retry Wait Time:(or RegisterRetryInterval in Obihai ATAs)

“<“ means less than.

When a modem leases a new IP address, a problem can arise where prior associations using the old IP address are maintained in the router. When the ATA attempts to communicate using the old IP address, the response is unreplied, and then if the UDP Unreplied timeout is greater than the Keep Alive Interval (and UDP Unreplied timeout is often set to 30 by default in consumer routers) a problem arises where the corrupted connection persists. If UDP Unreplied timeout is, for example, 17, and the NAT Keep Alive Interval is 20, then the corrupted connection will timeout or close. A new connection will be created, and everything will work fine.

Another problem can occur when the Keep-Alive interval is greater than UDP Assured Timeout (often 180 by default in consumer routers): the NAT hole will close due to the ATA not communicating frequently enough with the SIP server. In turn, incoming calls may, intermittently, not reach the ATA. Again, X_Keepalives expires is supposed to be 20 with FPL.

(the above settings are making reference to those in Obihai ATAs)

Getting access to both UDP Unreplied Timeout and UDP Assured Timeout settings in consumer routers may be difficult, if not impossible. Asuswrt-Merlin (I would avoid any model below/less powerful than an RT-AC68U), third party firmware for Asus routers, does offer easy access to these two settings, which are found under General–>Tools-->Other settings. My understanding is that third party Tomato firmware has these two settings as well. So if your router supports Tomato firmware, that may be another option. Note that I will not be held accountable any damage resulting from failed firmware updates. Apparently, Mikrotik routers also allow users to change both Assured and Unreplied UDP timeout settings as well: https://forums.redflagdeals.com/recomme ... 2115672/2/

The keep alive interval for FPL is 20. The SIP Registration Failure Retry Wait Time is 120. I use 17 for UDP Unreplied Timeout and 117 for UDP Assured Timeout.



ISPs do not issue customers routers that can do all four things I just listed. Typically it's far better to have your own router with strong QoS functions and a restricted cone NAT firewall,
disable whatever SIP ALG feature is enabled in the router, and stick whatever modem/router combo your ISP gives you into bridge mode. For Bell Hubs, visit http://forums.redflagdeals.com/please-s ... r-1993629/. For Rogers, visit https://www.rogers.com/customer/support ... ridgemodem.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 989
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Incoming calls go straight to voice mail

Postby jarfgames » 08/11/2019

I am having a very similar issue which appears to have just started this weekend. I have been using FPL through an obi200 since April 2016 with no issues. Wondering if there is something server-side going on here? Been playing around with my settings for an hour and haven't been able to find a resolution yet. Outbound calls continue to work perfectly fine, inbound calls only ring through if I reset the device, and then only for a few minutes.
jarfgames
Just Passing Thru
 
Posts: 12
Joined: 04/16/2016
SIP Device Name: Obi200

Re: Incoming calls go straight to voice mail

Postby Liptonbrisk » 08/11/2019

jarfgames wrote: Wondering if there is something server-side going on here? .


I'm not experiencing any problems.
Visit https://status.fongo.com/.

Other than the possibility of you encountering intermittent internet issues or having problems with other devices on your LAN not leaving sufficient bandwidth for your ATA (QoS features in routers are a good idea for VoIP services; refer to point C above), keep in mind that only one registration per FPL account is allowed at any time. When there are multiple devices/softphones using the same account, only the most recent registration is valid. The previous device will lose registration. This is especially important to consider if someone else is using your SIP credentials (username and password) that are found after logging in at https://www.freephoneline.ca/showSipSettings (or if you're trying to register your FPL account with a smartphone SIP app or with another device). Registration is required for incoming calls. It is not required for outgoing calls.

Log in at https://www.freephoneline.ca/showSipSettings. Ensure that SIP Status indicates "connected" and that SIP User Agent shows your ATA when you're experiencing problems. Registration is required for incoming calls, but it's not a requirement for outgoing calls. If SIP user agent isn't something you recognize, you've been hacked.

The relevant sections of the PDF guide you want to look at are on pages 42 to 44 and 47 to 48: viewtopic.php?f=15&t=18805#p73839.
The top of page 48 concerning UDP timeouts may also be of interest:
"Another problem can occur when the Keep-Alive interval is greater than UDP Assured Timeout (often 180 by default in consumer routers): the NAT hole will close due to the ATA not communicating frequently enough with the SIP server. In turn, incoming calls may, intermittently, not reach the ATA. Again, X_Keepalives expires is supposed to be 20 with FPL."
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 989
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Incoming calls go straight to voice mail

Postby jarfgames » 08/11/2019

First thing I checked was my SIP settings page on freephoneline.ca. It showed that I was Connected and that the device was my obi200 (I have never tried to connect another device to my account at any time). I have been using the same router for about 18 months (Google Wifi). At the moment, I am using to Telus Fibre internet (since Dec 2018), previously Shaw and a Shaw reseller. No issues at any time with FPL. Given that my internet is 300/300, I don't think it's a bandwidth issues (no major downloads or uploads happening at the moment - I double-checked this through my router as well).

I believe I have found at least a temporary solution... Previously, my obi200 was set up to connect to FPL's servers using the following priority (same settings since April 2016):
1)voip.freephoneline.ca, 2)voip2.freephoneline.ca and 3)voip4.freephoneline.ca:6060

I have now adjusted the order so that the voip4 server gets top priority, with the other two following below it. Since I made this change about 30 minutes ago, incoming calls seem to be working again.

I will update again if it stops working but for now this seems to have helped. Again, I have no idea why this is happening since I have not changed my ISP recently, using the same router and ATA with no recent changes to any settings. All I can possibly conclude is that my ISP (Telus) made some sort of change on their end or that there is some sort of (unreported) issue at the moment with some connections to freephoneline. I also double-checked for certainty that my Google Wifi firmware has not recently updated and confirmed that the last update was July 1 (so I don't think it's that since my phone has been working fine since then until this weekend).
jarfgames
Just Passing Thru
 
Posts: 12
Joined: 04/16/2016
SIP Device Name: Obi200

Re: Incoming calls go straight to voice mail

Postby Liptonbrisk » 08/11/2019

jarfgames wrote: Again, I have no idea why this is happening since I have not changed my ISP recently, using the same router and ATA with no recent changes to any settings.


NAT corruption in routers and UDP timeout issues can occur without consumers doing anything.

With respect to potential Telus issues to voip.freephoneline.ca, try using WinMTR: https://winmtr.en.uptodown.com/windows. Test to voip.freephoneline.ca when the problem occurs. If you see bad jitter (large fluctuations between each successive ping), then that could be indicative of a larger issue. During large ping spikes, incoming calls will drop to voicemail.

I'll test with voip.freephoneline.ca for the next hour to see if I encounter issues. I wasn't using that server.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 989
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Incoming calls go straight to voice mail

Postby jarfgames » 08/11/2019

Liptonbrisk wrote:
jarfgames wrote: Again, I have no idea why this is happening since I have not changed my ISP recently, using the same router and ATA with no recent changes to any settings.


NAT corruption in routers and UDP timeout issues can occur without consumers doing anything.

I'll test with voip.freephoneline.ca for the next hour to see if I encounter issues. I wasn't using that server.



Thank you very much for your help.
jarfgames
Just Passing Thru
 
Posts: 12
Joined: 04/16/2016
SIP Device Name: Obi200

Re: Incoming calls go straight to voice mail

Postby Liptonbrisk » 08/11/2019

With respect to potential Telus issues to voip.freephoneline.ca, try using WinMTR: https://winmtr.en.uptodown.com/windows. Test to voip.freephoneline.ca when the problem occurs. If you see bad jitter (large fluctuations between each successive ping), then that could be indicative of a larger issue. During large ping spikes, incoming calls will drop to voicemail.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 989
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Incoming calls go straight to voice mail

Postby jarfgames » 08/11/2019

Liptonbrisk wrote:With respect to potential Telus issues to voip.freephoneline.ca, try using WinMTR: https://winmtr.en.uptodown.com/windows. Test to voip.freephoneline.ca when the problem occurs. If you see bad jitter (large fluctuations between each successive ping), then that could be indicative of a larger issue. During large ping spikes, incoming calls will drop to voicemail.


Will try that next... I am on a Mac but I can get Windows up and running and download that software to try.
jarfgames
Just Passing Thru
 
Posts: 12
Joined: 04/16/2016
SIP Device Name: Obi200

Re: Incoming calls go straight to voice mail

Postby jarfgames » 08/11/2019

Here is the output from voip.freephoneline.ca:

|------------------------------------------------------------------------------------------|
| WinMTR statistics |
| Host - % | Sent | Recv | Best | Avrg | Wrst | Last |
|------------------------------------------------|------|------|------|------|------|------|
| db.fongo.com - 0 | 34 | 34 | 76 | 77 | 81 | 77 |
|________________________________________________|______|______|______|______|______|______|
WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider

And just for fun, here is voip4.freephoneline.ca:

|------------------------------------------------------------------------------------------|
| WinMTR statistics |
| Host - % | Sent | Recv | Best | Avrg | Wrst | Last |
|------------------------------------------------|------|------|------|------|------|------|
| host-162-213-111-21.static.295.ca - 0 | 41 | 41 | 67 | 67 | 68 | 68 |
|________________________________________________|______|______|______|______|______|______|
WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider

Both seem relatively steady, I think (not sure if the number of pings I ran is statically significant enough to qualify as a "full test".
jarfgames
Just Passing Thru
 
Posts: 12
Joined: 04/16/2016
SIP Device Name: Obi200

Re: Incoming calls go straight to voice mail

Postby Liptonbrisk » 08/11/2019

jarfgames wrote:At the moment, I am using to Telus Fibre internet (since Dec 2018)


I hope you have whatever they gave you running in bridge mode so that you're bypassing the router portion of the gateway (modem/router combo) they gave you. Or do PPPoE login using your router, and have your ATA connected to it. Doing PPPoE login using your own router bypasses the router portion of the gateway, which could be causing issues, that Telus gave you.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 989
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Incoming calls go straight to voice mail

Postby Liptonbrisk » 08/11/2019

jarfgames wrote:Here is the output from voip.freephoneline.ca:.



When you experience the problem, run that test for 200 pings. Basically, that test needs to be running while the problem occurs so that you can try to monitor whether the issue is jitter related.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 989
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Incoming calls go straight to voice mail

Postby jarfgames » 08/11/2019

Liptonbrisk wrote:
jarfgames wrote:At the moment, I am using to Telus Fibre internet (since Dec 2018)


I hope you have whatever they gave you running in bridge mode so that you're bypassing the router portion of the device they gave you. Or do PPPoE login using your router, and have your ATA connected to it. Doing PPPoE login using your router bypasses the router portion of the device that Telus gave you.


Yes, I had them put it on bridge mode from day 1. I suppose it’s possible something could have somehow reset itself on the Telus modem. Will check later. Thanks again.
jarfgames
Just Passing Thru
 
Posts: 12
Joined: 04/16/2016
SIP Device Name: Obi200

Re: Incoming calls go straight to voice mail

Postby Liptonbrisk » 08/11/2019

jarfgames wrote:
Liptonbrisk wrote:
Yes, I had them put it on bridge mode from day 1. I suppose it’s possible something could have somehow reset itself on the Telus modem. Will check later. Thanks again.


If you perform PPPoE login using your own router, you don't have to worry about what happens with the Telus device. I'm uncertain if Telus allows you to connect using PPPoE, but you can with Bell Hubs.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 989
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Incoming calls go straight to voice mail

Postby Liptonbrisk » 08/11/2019

Liptonbrisk wrote:
I'll test with voip.freephoneline.ca for the next hour to see if I encounter issues. I wasn't using that server.



As promised, I've tested for an hour using voip.freephoneline.ca. Incoming calls are still working.
Typically, if rebooting the ATA works, provided the ATA is registered when the problem occurs, it's a router issue.
I don't believe it's possible to adjust UDP timeout settings with Google WI-FI routers, so troubleshooting potential UDP issues becomes
tricky. There's no harm in increasing RegisterRetryInterval in the ATA higher than 120s (other than it will take longer for the ATA
to try to register again after a failure). It would be bad idea to increase X_KeepAliveExpires.

If the Telus device is truly in bridge mode, then you should be bypassing potential NAT and SIP ALG issues in it.
If voip4.freephoneline.ca:6060, which exists to bypass SIP ALG problems in routers, works for you, then continue using it.

Proper device reboot order is always Modem-->router (wait for Wi-Fi SSiDs to populate first)--> and finally ATA.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 989
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Incoming calls go straight to voice mail

Postby Liptonbrisk » 08/11/2019

jarfgames wrote:Here is the output from voip.freephoneline.ca:

|------------------------------------------------------------------------------------------|
| WinMTR statistics |
| Host - % | Sent | Recv | Best | Avrg | Wrst | Last |
|------------------------------------------------|------|------|------|------|------|------|
| db.fongo.com - 0 | 34 | 34 | 76 | 77 | 81 | 77 |
|________________________________________________|______|______|______|______|______|______|
WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider

And just for fun, here is voip4.freephoneline.ca:

|------------------------------------------------------------------------------------------|
| WinMTR statistics |
| Host - % | Sent | Recv | Best | Avrg | Wrst | Last |
|------------------------------------------------|------|------|------|------|------|------|
| host-162-213-111-21.static.295.ca - 0 | 41 | 41 | 67 | 67 | 68 | 68 |
|________________________________________________|______|______|______|______|______|______|
WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider

Both seem relatively steady, I think (not sure if the number of pings I ran is statically significant enough to qualify as a "full test".



Well, I forgot to mention that's the proxy server. The RTP audio stream will come from another server, possibly 208.65.240.142, for example.

It may be useful to check RTP stats for "PacketsLost". Ideally, there should be none.
Dial ***1, and enter the IP you're told into your web browser.
Login and navigate to Status-->SP Services Stats-->RTP Statistics-->SP(FPL) Service Status-->PacketsLost
RTP stats are only going to be valid for the FPL proxy server you're currently using.
But it would have been interesting if you had a lot of lost packets while using voip.freephoneline.ca.

Again, If voip4.freephoneline.ca:6060, which exists to bypass SIP ALG problems in routers, works for you, then continue using it.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 989
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Incoming calls go straight to voice mail

Postby jarfgames » 08/11/2019

Thanks. I will play around a bit more tonight with some of your suggestions. Like you said, worst case I will just stick with the voip4 server. Perhaps that solution will also work for the person whose thread I appear to have hijacked! As always, thanks for your help.
jarfgames
Just Passing Thru
 
Posts: 12
Joined: 04/16/2016
SIP Device Name: Obi200

Re: Incoming calls go straight to voice mail

Postby Liptonbrisk » 08/11/2019

jarfgames wrote:Thanks. I will play around a bit more tonight with some of your suggestions. Like you said, worst case I will just stick with the voip4 server. Perhaps that solution will also work for the person whose thread I appear to have hijacked! As always, thanks for your help.



It may work: viewtopic.php?f=8&t=19624#p76567.


I suggest that as an alternative to trying PPPoE in other threads where Bell Hubs are involved. PPPoE login using the ATA typically fixes the issue.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 989
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Incoming calls go straight to voice mail

Postby jarfgames » 08/11/2019

It’s still working a few hours later now on voip4. I am wondering if at some point recently Telus pushed out an update to their modems that reset things back to default. I will dig in further on that but for now it seems voip4 has made incoming calls work again. Thanks for your help Liptonbrisk.
jarfgames
Just Passing Thru
 
Posts: 12
Joined: 04/16/2016
SIP Device Name: Obi200

Re: Incoming calls go straight to voice mail

Postby Liptonbrisk » 08/11/2019

jarfgames wrote: I am wondering if at some point recently Telus pushed out an update to their modems


That’s possible.
Is it still in bridge mode?
https://forum.telus.com/t5/Home/Bridge- ... ta-p/52181
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 989
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Incoming calls go straight to voice mail

Postby jarfgames » 08/13/2019

Didn’t have a chance to check my Telus router last night, but I can confirm that incoming calls continued to work properly all day yesterday using the voip4 server. Will try to double check my Telus router tonight.
jarfgames
Just Passing Thru
 
Posts: 12
Joined: 04/16/2016
SIP Device Name: Obi200

Re: Incoming calls go straight to voice mail

Postby Liptonbrisk » 08/13/2019

voip.freephoneline.ca is still working fine.

The purpose of voip4.freephoneline.ca:6060 is to bypass buggy SIP ALG features
in routers, hubs, and gateways. If there’s a hidden SIP ALG feature in your Telus gateway with no way for you to disable it,
or if it’s not in bridge mode (or if it’s bridge mode isn’t a true bridge mode), that may be the cause.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 989
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Incoming calls go straight to voice mail

Postby mjazster » 08/13/2019

Thank you so much for all of your replies. I will try out your suggestions tonight and will update this post once I have done that to let you know if I was able to resolve the problem. Also the Bell supplied modem/router is Home Hub 2000 and not 200 as mentioned in my post.
mjazster
Just Passing Thru
 
Posts: 3
Joined: 08/10/2019
SIP Device Name: Grandstream HT802
ISP Name: Bell Canada DSL
Computer OS: macOS Mojave
Router: Home Hub 2000

Re: Incoming calls go straight to voice mail

Postby Liptonbrisk » 08/13/2019

mjazster wrote:Thank you so much for all of your replies. I will try out your suggestions tonight and will update this post once I have done that to let you know if I was able to resolve the problem.


Hi, only my first two replies in this thread apply to you. The rest were responses to jarfgames, mostly.


Also the Bell supplied modem/router is Home Hub 2000 and not 200 as mentioned in my post.


Right, there is no Bell Home Hub 200. There are 2000 and 3000 models.

If you still experience problems after setting up PPPoE correctly in your ATA (go through the steps, step by step, in the order listed in my first reply) to bypass the NAT firewall and SIP ALG settings in your Bell Hub, you could try setting Primary SIP Server in your ATA to voip4.freephoneline.ca:6060, but you really shouldn't have to do that if you're connecting using PPPoE with your ATA.

Also, keep in mind that only one registration per FPL account is allowed at any time. When there are multiple devices/softphones using the same account, only the most recent registration is valid. The previous device will lose registration. This is especially important to consider if someone else is using your SIP credentials (username and password) that are found after logging in at https://www.freephoneline.ca/showSipSettings (or if you're trying to register your FPL account with a smartphone SIP app or with another device). Registration is required for incoming calls. It is not required for outgoing calls.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 989
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Next

Return to Community Support

Who is online

Users browsing this forum: No registered users and 3 guests