GrandStream HT812 - Enable Call Features

Here you can post your own working configurations of hardware or software to share with other users who may be using the same device!
Fongo recommends Fongo Home Phone for a fully supported Home Phone system for only $4.95/mo
Forum rules
DISCLAIMER
This forum is for those users who have already purchased a configuration file with the SIP settings needed to configure any SIP compatible device.

1. Please use this forum only as a means to share your configuration advice and guides for ATA devices and SIP clients that you are using with our service.
2. For any questions relating to device configuration, please use the other forum sections or post your question directly in the device topic that your question is meant for.
3. Please title your topics with only the name and model of your device so users can easily find the information they need.
4. Preferable format for posting here is compressing your screenshots of your successfully configured device into a .zip file, and post a brief description of the configuration.

Please stay on topic

GrandStream HT812 - Enable Call Features

Postby Leftwinger » 02/21/2020

Good Day All, Looking to get some assistance on enabling Call Features on my new HT812 device with freephoneline. The Service and Device work exceptionally well, however i'm looking to have the Call Features such as *67 or *69 turned on. In the device settings, more specifically within Profile 1 they are all turned on, however when dialing *67 ahead of a number I simply get a flashing tone similar to a busy signal. Not sure if it has to do with the dial plan (Below)

{*xx|[2-9]xxxxxxxxx|1[2-9]xxxxxxxxx|0xxx+}

Any assistance would be greatly appreciated. Again...the device is fully functional, calls in and out work well it's just a matter of enabling call features which are turned on within the device and they're all set to yes.
Attachments
Call Features.JPG
Call Features.JPG (87.32 KiB) Viewed 799 times
Leftwinger
Just Passing Thru
 
Posts: 2
Joined: 02/21/2020
SIP Device Name: HT812
Firmware Version: 1.0.15.4
ISP Name: Cogeco Cable
Computer OS: Windows 10
Router: WRT1900ACS

Re: GrandStream HT812 - Enable Call Features

Postby Liptonbrisk » 02/21/2020

Unless something has changed after server migration, *67 is not officially supported at the provider level (by Freephoneline) at this time (*67 is supported by Fongo Home Phone). *69 has never been supported by Freephoneline (*69 will produce a 403 SIP error code, and you'll hear "This call is not covered by your tariff plan."). Consequently, trying to make them work in a dial plan won't help.

Regardless, if you wanted to support *67 in a dialplan, it would need to go before [2-9]xxxxxxxxx and not be separated by |
You'd also need to remove *xx
Then you would dial *675191234567, for example, without pausing. However, that won't work because, again, FPL doesn't not officially support *67 at the provider level.

The other option is to have the ATA process both star codes (as opposed to Freephoneline). I don't have a Grandstream to test, but in theory, you would remove anything that could possibly match *67 (*xx for example) from your dial plan so that the ATA processes the star code instead of sending the star code to the provider (FPL). *67 still won't work properly when calling Fongo Mobile numbers, even if the star code is processed by the ATA. The receiving provider has to comply with the anonymous flag that's sent in the SIP header. Some providers recognize the anonymous flag and comply. Others don't. It's better to have *67 supported at the provider level (the provider blocks outgoing CID info completely), which FPL doesn't officially support.

I'm not sure whether *69 will work if that star code is processed by your ATA (as opposed to having *69 sent to FPL) since I don't have a Grandstream to test.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 1247
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: GrandStream HT812 - Enable Call Features

Postby Leftwinger » 02/24/2020

Thanks for the response.

I will try and work with Grandstream on this item. However I also have a SPA 112 and it does support the calling features though they use different codes such as *81 to block number on the outbound call. One of the reasons I switched to Grandstream was that it supported the standard * Functions such as *67, *69 etc whereas the Cisco Spa utilizes different codes to achieve these features.
Leftwinger
Just Passing Thru
 
Posts: 2
Joined: 02/21/2020
SIP Device Name: HT812
Firmware Version: 1.0.15.4
ISP Name: Cogeco Cable
Computer OS: Windows 10
Router: WRT1900ACS

Re: GrandStream HT812 - Enable Call Features

Postby Liptonbrisk » 02/24/2020

Yes, so your SPA is processing the star codes and not FPL. You might be misinterpreting what I wrote previously.

There's two possible ways *67 (block outgoing CID) works:

1)You can send *67 through the service provider, who then either accepts the code or doesn't do anything. FPL, by default, doesn't do anything. At least that was the case before server migration: viewtopic.php?f=15&t=19702. There have been a few exceptions made for certain individuals, but it's rare. My FPL account doesn't do anything for *67 after server migration.

When you're using *xx in your dial plan (*xx matches *67), you're trying to have *67 sent to FPL, which doesn't do anything for most FPL accounts.

2) You can have *67 processed by your ATA, which sends an anonymous call flag in the SIP header along the path to the receiving carrier that, in turn, has to recognize and agree to not show CID. *67 (outgoing CID block) calls to Telus mobile numbers work when *67 is processed by the ATA. That is, no caller ID is displayed. When *67 is parsed by an ATA or IP Phone, my FPL number constantly appears when calling Fongo Mobile numbers. But it's blocked when calling regular Telus mobile numbers, for example. Telus Mobility acknowledges the flag and complies. Fongo Mobile doesn't.

How blocking CID behaves when processed by the device (as opposed to the service provider) should be the similar regardless of the device being used. So it shouldn’t matter what brand ATA is being used.

If you're trying to get your ATA to do #2, you'd need to remove *xx from your dial plan so that *67 isn't sent to FPL.

If my FPL account accepted the *67 code (when sending *67 through FPL and not having the star code processed by my ATA instead) and agreed to block outgoing CID, my FPL number would not appear when calling Fongo Mobile numbers. Refer to point #1.

For *69, method #1 won't work at all (FPL won't process it). Your ATA might (method #2), but I don't have your ATA and can't test. Again, you'd need to remove *xx from your dial plan so that *69 isn't sent to FPL
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 1247
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin


Return to Device Configuration Sharing

Who is online

Users browsing this forum: Google [Bot] and 2 guests