[SOLVED] No audio (both ways) for incoming calls

Have a question or problem with your Fongo application? This forum is the place to get help from both staff and fellow community members.
Fongo recommends Fongo Home Phone for a fully supported Home Phone system for only $4.95/mo

[SOLVED] No audio (both ways) for incoming calls

Postby goldenmeadow » 04/07/2020

Liptonbrisk wrote:1) In your Obihai ATA or at Obitalk.com, (whichever method you originally used; don't use both methods), navigate to Voice Services-->SP(FPL) Service-->X_UserAgentPort
X_UserAgentPort should be a random port number between 30000 and 60000. Just pick a port number in that range.
Click save. Reboot.


Thanks Liptonbrisk.

I started having the same issue (not sure for how long). So I found this topic.
First I switched to voip2 - it worked.
Then I checked my OBi200 - it had blank field (default) for X_UserAgentPort. So I put random number and switched to voip - it works.
Thanks again!

UPDATE: still issue, but different one. Incoming calls get through, but both parties can't hear each other...

FINAL UPDATE: did factory reset and put all settings back - got calls and audio back!
Слава Україні!
User avatar
goldenmeadow
Just Passing Thru
 
Posts: 13
Joined: 09/10/2013
SIP Device Name: OBi200
ISP Name: Carrytel
Computer OS: Windows 10
Router: Asus RT-N56U

Re: One Way audio issue

Postby Liptonbrisk » 04/07/2020

goldenmeadow wrote:
UPDATE: still issue, but different one. Incoming calls get through, but both parties can't hear each other...


If the other party is using a VoIP service, the issue may be on their end.

If switching to voip4.freephoneline.ca:6060 (try it) fixes the issue, you're dealing with a buggy SIP ALG feature in your router.

1) What brand and model modem are you using?

2) What brand and model router are you using?

3) Make sure whatever modem/router combo your ISP gave you is in bridge mode if you are using your own router. Call/contact your ISP if you have to.

a. Netgear R7000 routers

Update firmware. Disable SIP ALG in this router. Then reboot modem, router, and ATA in that order. Then test again.

If you have a Netgear R7000 router, you may need to install third party XWRT-Vortex firmware. Doing this makes it easy to obtain access to both UDP Unreplied and UDP Assured timeout settings. Afterwards, turn off the router and the ATA. Turn on the router. Wait for it to be fully up and running (including Wi-Fi). Then turn on the ATA. Download XWRT-Vortex here: http://xvtx.ru/xwrt/download.htm. In your router, navigate to Advanced Settings–>WAN–>NAT Passthrough–>SIP Passthrough. Change SIP Passthrough to “Enabled + NAT helper.” Click “Apply.”

b. Nettis 4422 modem from Carry Telecom (click the "Internet" tab)
http://www.carrytel.ca/support.aspx
c : DSL - My VoIP phone does not work with Netis 4422 modem.
d : Please download the newest Netis firmware at http://www.carrytel.ca/download/netis1228.zip. Unzip the netis1228.zip file and update the firmware file netis1228.img for your modem. The new firmware has been tested and working with most of Voip phone providers


c. e. Asus VLAN

A number of people have been trying to eliminate Bell Hubs from their setups by using Asus VLAN.
At the time of this guide being written, NAT acceleration must be disabled in that VLAN setup in order for SIP services, including Freephoneline, to work properly. In your router, navigate to Advanced Settings-->LAN-->Switch Control-->NAT Acceleration. Select "disable." Click "apply."Then reboot your modem, router (wait for Wi-Fi SSIDs to populate first before rebooting ATA), and your ATA, in that order.

To determine whether you need NAT Acceleration enabled, visit https://routerguide.net/nat-acceleration-on-or-off/. If you do require NAT Acceleration to be enabled, don’t use VLAN with Asus routers.

f. Hitron CGN series gateway modem/router combos (from Rogers, Shaw, or another ISP) or any modem/router combo from any ISP with SIP ALG forced on

If you don’t have your own router, and if you can’t get someone from Rogers or your ISP to disable SIP ALG for you in their modem/router combo, your ATA may need to register with voip4.freephoneline.ca:6060. The purpose of voip4.freephoneline.ca:6060 is to help circumvent faulty SIP ALG features in routers. So, if you’re experiencing one-way audio issues as a result of SIP ALG, this is the SIP server to try. Check to ensure that you can’t disable SIP ALG yourself (refer to point E below).

g. Hitron CGN3ACSMR and CODA-4582 series gateway modem/router combos from Rogers (and possibly other ISPs)
Open your web browser, and login at 192.168.0.1. Default username is cusadmin.
Select the “Basic” tab and disable “SIP ALG.” Click the “save changes” button.


h. Concerning Bell Hubs, (This may also apply to Telus)

Typically it's better to have your own router and to stick whatever modem/router combo your ISP gives you into bridge mode:
http://forums.redflagdeals.com/please-s ... r-1993629/


4. Use this PDF guide fully to configure your ATA properly: download/file.php?id=2065 (viewtopic.php?f=15&t=18805#p73839). Then follow the steps on pages 43 to 44 under the section entitled "Are you getting one way audio issues with an OBi200/202 and Freephoneline?"
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 1247
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: One Way audio issue

Postby goldenmeadow » 04/07/2020

Thanks Liptonbrisk for separating my post in separate thread!

I tried them all - voip, voip2, voip4... I tried random AgentPort (45555)... I did reboot router every time. Still the same...

BUT no issues for outgoing calls!!!!!!!!!!!!!!!!!

1. I'm in Kitchener with Carrytel - they rent Roger's cable. Modem is Technicolor TC4350
2. Router - Asus RT-N56U, stock firmware
3. Modem is definitely in bridge mode

I've been with FPL for loooong time and had no issues. I don't know if it's related, but on April 1st someone cut fiber-optic cable in Rogers DC in Etobicoke and whole Carrytel (ON and QC) was down for one day. May be it started then... I'm not sure.

I followed pages 44 and 45 - still the same - when I call my home number even from cell phone - there is no audio on both ends...

Any ideas?

Thanks for being around! Stay safe!

EDIT: I just noticed, that even-though I have voip4 in my OBi, the FPL SIP settings page says "Inbound/Outbound Proxy: voip.freephoneline.ca"

Is it correct?

Liptonbrisk wrote:
If switching to voip4.freephoneline.ca:6060 (try it) fixes the issue, you're dealing with a buggy SIP ALG feature in your router.

1) What brand and model modem are you using?

2) What brand and model router are you using?

3) Make sure whatever modem/router combo your ISP gave you is in bridge mode if you are using your own router. Call/contact your ISP if you have to.
Слава Україні!
User avatar
goldenmeadow
Just Passing Thru
 
Posts: 13
Joined: 09/10/2013
SIP Device Name: OBi200
ISP Name: Carrytel
Computer OS: Windows 10
Router: Asus RT-N56U

Re: One Way audio issue

Postby Liptonbrisk » 04/07/2020

goldenmeadow wrote:Thanks for being around! Stay safe!


Thank you. You too


EDIT: I just noticed, that even-though I have voip4 in my OBi, the FPL SIP settings page says "Inbound/Outbound Proxy: voip.freephoneline.ca"


Yes, those suggested settings are in my accounts as well. Everyone can use voip4.freephoneline.ca:6060 regardless of the ISP or device being used.

1) When you login at https://www.freephoneline.ca/showSipSettings, does your SIP Status shows connected? And do you recognize the SIP User agent?

2) a) Dial ***1. Enter the IP address you hear into a web browser.
b)Log into the ATA (default username and password are "admin" without quotation marks).
c)Navigate to Status-->System Status-->SP(FPL) Service Status

What does the registration status indicate? Please copy and paste the status here.



3) If you used the Obitalk web portal (http://www.obitalk.com) to configure your ATA, keep in mind that you must continue using it to configure your ATA. Otherwise whatever settings you change will eventually be overwritten by what you previously entered at obitalk.com anyway. If you wish to disable this behaviour, dial ***1. Enter that IP address into a web browser. Navigate to System Management-->OBiTalk Provisioning-->select Disabled for the method. Save. Reboot ATA. Now obitalk.com won't overwrite whatever changes you make via the device's interface (via IP address).

Pick one method (obitalk.com) or the other (IP address of device) for changing device settings. But do not use both methods. Keep in mind that activating Google Voice requires using the Obitalk.com web portal.

(In Obitalk.com, you will need to enable and enter expert settings to do the following, if you want to use Obitalk.com. You do this by selecting Edit Profile-->Advanced Options-->check Enable OBi Expert Entry from Dashboard-->submit))

Keep in mind too, that if you're using the Obitalk.com web portal, after you submit a new setting, it take several minutes before Obitalk.com pushes the changes you've made to your ATA. Your ATA should reboot automatically after the changes are submitted.

4) Navigate to Service Providers-->ITSP Profile (FPL)-->SIP

i) ensure X_DiscoverPublicAddress is enabled (it is by default)

ii) enable X_UsePublicAddressInVia (it's not by default)
You will need to uncheck default, device default, and Obitalk settings boxes. Then check the box to enable the feature

5) Ensure you're using voip4.freephoneline.ca:6060 (just use that one for now for testing purposes)

If that doesn't work, then I'm at a loss. Your cable modem that doesn't have a router built into it, and, so, it shouldn't be producing this problem.
And If you use voip4.freephoneline.ca:6060, SIP Passthrough (which is SIP ALG) in your router shouldn't be causing this issue either.

I'm reluctant to suggest doing step #12 on page 44 (forwarding RTP ports), but you can test to see if that works.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 1247
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: One Way audio issue

Postby goldenmeadow » 04/07/2020

Liptonbrisk wrote:1) When you login at https://www.freephoneline.ca/showSipSettings, your SIP Status shows connected? And do you recognize the SIP User agent?


YOUR SIP STATUS
SIP Status: connected
SIP User Agent: OBIHAI/OBi200 - this is my box

Liptonbrisk wrote:2) a) Dial ***1. Enter the IP address you hear into a web browser.
b)Log into the ATA (default username and password are "admin" without quotation marks).
c)Navigate to Status-->System Status-->SP(FPL) Service Status

What does the registration status indicate? Please copy and paste the status here.


SP1 Service Status
Parameter Name Value
Status Registered (server=162.213.111.21:6060; expire in 3227s)
PrimaryProxyServer
SecondaryProxyServer
CallState 0 Active Calls

I don't use obitalk portal:

Auto Firmware Update - disabled
LUA Script Update - disabled
ITSP Provisioning - disabled
OBiTalk Provisioning - disabled

All other settings are as you told.


Liptonbrisk wrote:If that doesn't work, then I'm at a loss. Your cable modem that doesn't have a router built into it, and, so, it shouldn't be producing this problem.
And If you use voip4.freephoneline.ca:6060, SIP Passthrough (which is SIP ALG) in your router shouldn't be causing this issue either.

I'm reluctant to suggest doing step #12 on page 44 (forwarding RTP ports), but you can test to see if that works.


No worries - at least there is something I can kill time with :)
It's funny, but now all my incoming calls are not going through at all!

I guess I'll do factory reset and follow great manual you referenced to from the beginning (I used older version of it when set OBi initially) - it's just I don't know if it's OBi's or router's issue...

Stay safe!

PS. I have Google Voice for second SP (got US number while on vacation in Florida) - it works.
Last edited by Liptonbrisk on 04/07/2020, edited 1 time in total.
Reason: edited to obscure sip user agent
Слава Україні!
User avatar
goldenmeadow
Just Passing Thru
 
Posts: 13
Joined: 09/10/2013
SIP Device Name: OBi200
ISP Name: Carrytel
Computer OS: Windows 10
Router: Asus RT-N56U

Re: One Way audio issue

Postby Liptonbrisk » 04/07/2020

goldenmeadow wrote: it's just I don't know if it's OBi's or router's issue


Try removing your router from the equation. Connect the ATA directly to your modem (instead of your router), briefly for testing purpose, and test with an incoming call.
Power cycle the ATA first after connecting it to the modem before testing.

If the issue disappears, the problem involves your router. The latest firmware version for it can be found at https://www.asus.com/ca-en/Networking/R ... Desk_BIOS/.
I won't be held responsible for failed firmware updates.

The only way I see to disable SIP ALG in your router is to do this: https://support.onsip.com/hc/en-us/arti ... nd-RT-N66U. It doesn't make sense to me that you'd have to disable SIP ALG if you're using voip4.freephoneline.ca:6060 though. Using voip4.freephoneline.ca:6060 should bypass SIP ALG in your router. SIP ALG monitors traffic on UDP port 5060 and can cause problems, depending on the router. Asus routers, which I've been using for almost as long as I've been using FPL, don't typically cause issues with FPL even when SIP ALG (called "SIP Passthrough" in Asus routers) is enabled in them. You're registering on UDP 6060 and also using a non-standard X_Useragentport (local sip port). In theory, SIP ALG should be completely bypassed. That said, it might be worth trying to disable SIP ALG in your router.


If the issue persists after removing your router, maybe submit a ticket at https://support.fongo.com/hc/en-us/requests/new and ask for a "forced registration" to see if that helps.
They don't offer free technical support, but they might make an exception. Mention there's been a server migration and ever since then you haven't been able to hear incoming calls.
I'm just posting this link to show there's been a server migration: viewtopic.php?f=15&t=19702#p76878. It's possible something has happened to your FPL account during the migration.


I guess another way to test your account is by configuring your FPL account on a smartphone SIP app or trying the Freephoneline desktop application: viewtopic.php?f=8&t=19755&p=77155.

Another possibility might include your ISP, but that seems unlikely to me if outgoing calls work fine. I doubt they'd be blocking or filtering ports.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 1247
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: One Way audio issue

Postby goldenmeadow » 04/08/2020

Thanks for all support!

Short reply - it works!
I gave up playing around and simply did factory reset :) Then connected to Obitalk to get my GV, disconnected from them and followed instructions. I didn't do server fail-over, just simply put voip4. Both calls worked. Then I tried voip2 - everything works too! I didn't try voip - my pings are pretty the same for all 3.

My only suspicion why incoming calls/sound didn't work is about X_InboundCallRoute in Voice Services >> SP1 Service... Long time ago I followed this guide:
https://toao.net/500-mangos-guide-to-co ... an-obi-ata

that suggested to use value:
{>Insert your AuthUserName here:ph}

So I had my phone number there:
{>1519xxxxxxx:ph}

But the newest guide says to leave default value, ph... MAY BE it was rejecting calls, I don't know. Oh well - by resetting OBi and putting fresh config back I made sure everything is up-to-day :)

Thanks again!

Stay safe!


Liptonbrisk wrote:I guess another way to test your account is by configuring your FPL account on a smartphone SIP app or trying the Freephoneline desktop application: viewtopic.php?f=8&t=19755&p=77155.

Another possibility might include your ISP, but that seems unlikely to me if outgoing calls work fine. I doubt they'd be blocking or filtering ports.
Слава Україні!
User avatar
goldenmeadow
Just Passing Thru
 
Posts: 13
Joined: 09/10/2013
SIP Device Name: OBi200
ISP Name: Carrytel
Computer OS: Windows 10
Router: Asus RT-N56U

Re: One Way audio issue

Postby Liptonbrisk » 04/08/2020

goldenmeadow wrote:I didn't do server fail-over


That's a shame. It works well.


My only suspicion why incoming calls/sound didn't work is about X_InboundCallRoute in Voice Services >> SP1 Service... Long time ago I followed this guide:
https://toao.net/500-mangos-guide-to-co ... an-obi-ata

that suggested to use value:
{>Insert your AuthUserName here:ph}

So I had my phone number there:
{>1519xxxxxxx:ph}

But the newest guide says to leave default value, ph


That's because OBi1xx doesn't have the option to enable X_EnforceRequestUserID, which is exactly the same as {>Insert your AuthUserName here:ph}. Mango's guide applies to the OBi1xx series, although the same instruction also works for the OBi2xx series, which Mango doesn't own, as far as I know.

OBi2xx and OBi3xx have X_EnforceRequestUserID, which is enabled to accept SIP invite requests only if the request userid matches AuthUserName or X_ContactUserID (found under Voice Services > SP(service you're using) Service-->SIP Credentials).

Having X_EnforceRequestUserID enabled or {>Insert your AuthUserName here:ph} in use would not cause a lack of RTP (the audio stream) to reach your ATA. I have X_EnforceRequestUserID enabled. Its purpose is to help thwart SIP Scanners or hackers.

The PDF guide you used instructs to enable X_EnforceRequestUserID at the top of page 28.

Anyway, I'm glad your problem is resolved.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 1247
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin


Return to Community Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron