Calls are mute after 15 minutes using Groundwire on iOS

Have a question or problem with your Fongo application? This forum is the place to get help from both staff and fellow community members.
Fongo recommends Fongo Home Phone for a fully supported Home Phone system for only $4.95/mo

Calls are mute after 15 minutes using Groundwire on iOS

Postby kamil6x » 06/10/2020

I have the same issue for about 6 months now.
After 15 minutes the call goes dead.

Using Groundwire iOS app.
kamil6x
Just Passing Thru
 
Posts: 2
Joined: 06/10/2020
SIP Device Name: Groundwire iOS app
Firmware Version: latest
ISP Name: WiFi
Computer OS: iOS iPhone X
Router: Apple router.

Re: Calls are mute after 15 minutes using Groundwire on iOS

Postby Liptonbrisk » 06/10/2020

I've moved your post to its own thread since the other user wasn't using Groundwire.

I also use Groundwire on iOS.

1. In the Groundwire app in advanced settings for your FPL account,
a) NAT Traversal should be set to Auto and keep alive packets should be 20s
b) switch Proxy to voip4.freephoneline.ca:6060 to try to rule out a SIP ALG issue
c) Set Expires to 3600
d) G.711u-law should be the highest enabled codec, and packet time should be 20ms
e) "Outgoing calls need registration" should be disabled
Edit:
As a result of the new 15 minute session timer that Freephoneline doesn't seem to want to remove (based on my ticket being closed without any response), "Outgoing calls need registration" has to be enabled due to Freephoneline's new 15 minute session timers that weren't in place before.



f) Set a display name using your name and not "anon"
g) transport protocol is udp
h) Expires needs to be 3600
i) Caller ID can be left blank
j) Called ID Method is "From Username"
k) Call Waiting can be enabled (not related to the problem)

2. Test on cellular data. Works fine?

3. Test on Wi-Fi.

If you still have an issue on Wi-Fi, but not while using cellular data, the problem involves your router(s).
a) what brand and model modem are you using?
b) If you have a modem/router combo issued by your ISP is it in bridge mode (refer to the post below)?
Unfortunately, there's no way to adjust UDP timeouts in Apple routers. I'm not sure if they contain SIP ALG, but if they do I'm not aware that they can be disabled.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 1311
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Calls are mute after 15 minutes using Groundwire on iOS

Postby Liptonbrisk » 06/10/2020

(Generic info)
Typically, for VoIP SIP services, especially for freephoneline, you want

1) a router that does not have a full cone NAT,

Visit https://www.think-like-a-computer.com/2 ... es-of-nat/.
Mango from the Obitalk.com forums writes,
“Use a restricted cone NAT router, and do not use port forwarding or DMZ. Restricted cone NAT will only permit
inbound traffic from the service provider you're registered to. If you have a full cone NAT router, it will allow traffic
from any source. This is probably not what you intend.
If you have a Windows computer, you can test your router using the utility here:
http://www.dslreports.com/forum/remark,22292023. To run it, use stun stun.ekiga.net from a command prompt.”
Essentially, you download the stun-test.zip file; extract the stun.exe file from within the zip file to an easily
accessible location; use an elevated command prompt (visit
http://www.thewindowsclub.com/how-to-ru ... inistrator); change directory (cd) to the
directory or location where you extracted stun.exe (visit
http://www.digitalcitizen.life/command- ... c-commands); and type “stun stun.ekiga.net” without
the quotation marks followed by the enter/return button on your keyboard.
Asus routers, at the time of this writing, produce port restricted cone NAT routers, for example and are fine,
provided you’re using one with Asuswrt-Merlin, third party firmware installed.

2) a router that lets you disable SIP ALG if it's buggy,

To understand why SIP ALG often causes horrible problems, please visit
https://www.voip-info.org/routers-sip-alg/ (scroll down to the section on SIP ALG problems).

If you're dealing with a modem/router combo issued by an ISP or a router with SIP ALG forced on, you may have
to use voip4.freephoneline.ca:6060 for the Proxy Server. The purpose of voip4.freephoneline.ca:6060 is to circumvent
faulty SIP ALG features in routers.

3) a router that allows you to set QoS or assign highest priority to your ATA or IP Phone over all other devices on your LAN (local area network),

For a very general description of what QoS can do for you, visit https://www.voipmechanic.com/qos-for-voip.htm.
The basic idea is if you're torrenting or have a bunch of other computers, smartphones, tablets, etc. downloading and uploading (hogging all your available bandwidth), you don't want
your ATA not to have access to enough bandwidth to make or receive calls properly. So QoS or a Bandwidth Monitor feature (which is just another form of QoS) is a really good idea for VoIP users.

I often get an occasional relative complaining to me, "Hey my calls sound choppy." And then when I go visit, some kids are playing MMOs on a computer, while another person is downloading a huge file,
and another person is backing up files to a cloud service all at the same time someone else is trying to talk on the phone. All those devices, without QoS enabled, are fighting over available bandwidth along with the ATA.


and 4) A router that lets you adjust both Unreplied and Assured UDP timeouts.

Thanks to Mango, many of us now understand that in order for ATAs to remain registered and working properly with a VoIP SIP provider like Freephoneline, in particular after power failures, the following conditions must be met:

UDP Unreplied Timeout (in your router) < NAT Keep-alive Interval (in your ATA; for Obihai ATAs this is X_KeepAliveExpires) < UDP Assured Timeout (in your router) < SIP Registration Failure Retry Wait Time (or RegisterRetryInterval in Obihai ATAs)

“<“ means less than.

When a modem leases a new IP address, a problem can arise where prior associations using the old IP address are maintained in the router. When the ATA attempts to communicate using the old IP address, the response is unreplied, and then if the UDP Unreplied timeout is greater than the Keep Alive Interval (and UDP Unreplied timeout is often set to 30 by default in consumer routers) a problem arises where the corrupted connection persists. If UDP Unreplied timeout is, for example, 17, and the NAT Keep Alive Interval is 20, then the corrupted connection will timeout or close. A new connection will be created, and everything will work fine.

Another problem can occur when the Keep-Alive interval is greater than UDP Assured Timeout (often 180 by default in consumer routers): the NAT hole will close due to the ATA not communicating frequently enough with the SIP server. In turn, incoming calls may, intermittently, not reach the ATA. Again, X_Keepalives expires is supposed to be 20 with FPL.

(the above settings are making reference to those in Obihai ATAs)

Getting access to both UDP Unreplied Timeout and UDP Assured Timeout settings in consumer routers may be difficult, if not impossible. Asuswrt-Merlin (I would avoid any model below/less powerful than an RT-AC68U), third party firmware for Asus routers, does offer easy access to these two settings, which are found under General–>Tools-->Other settings. My understanding is that third party Tomato firmware has these two settings as well. So if your router supports Tomato firmware, that may be another option. Note that I will not be held accountable any damage resulting from failed firmware updates. Apparently, Mikrotik routers also allow users to change both Assured and Unreplied UDP timeout settings as well: https://forums.redflagdeals.com/recomme ... #p28056619.

The keep alive interval for FPL is 20. The SIP Registration Failure Retry Wait Time is 120. I use 17 for UDP Unreplied Timeout and 117 for UDP Assured Timeout.



ISPs do not issue customers routers that can do all four things I just listed. Typically it's far better to have your own router with strong QoS functions and a restricted cone NAT firewall,
disable whatever SIP ALG feature is enabled in the router, and stick whatever modem/router combo your ISP gives you into bridge mode. For Bell Hubs, visit http://forums.redflagdeals.com/please-s ... r-1993629/. For Rogers, visit https://www.rogers.com/customer/support ... ridgemodem.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 1311
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Calls are mute after 15 minutes using Groundwire on iOS

Postby kamil6x » 06/12/2020

Dear Lipfonbrisk,

Thanks for your amazing response about groundwire settings; there are so many that a VOIP noob would never figure them out.
I have updated my settings to your suggestion and hopefully it will work now. I doubt it's a router issue as the issue was happening with a WD 900 router, Apple and at the office which are cisco routers.

Looking forward to testing this on my next call which lasts over 15 minutes.
kamil6x
Just Passing Thru
 
Posts: 2
Joined: 06/10/2020
SIP Device Name: Groundwire iOS app
Firmware Version: latest
ISP Name: WiFi
Computer OS: iOS iPhone X
Router: Apple router.

Re: Calls are mute after 15 minutes using Groundwire on iOS

Postby Liptonbrisk » 06/12/2020

Actually, I just decided to test, and I'm currently encountering the same issue with Groundwire over LTE (completely bypassing my router), and I know I was able to call over 15 minutes a few months ago following FPL's server migration. I'm honestly surprised.

Calls from FPL to Telus Mobility numbers drop after 15 minutes using Groundwire.
Calls from FPL to other FPL numbers work fine using Groundwire.

I'm currently swamped and won't be able to follow up on this issue for awhile, unfortunately.

In the interim, it might be a good idea to submit a ticket to Acrobits at https://hesk.acrobits.net/index.php?a=add to see what they say. Select "default".
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 1311
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Calls are mute after 15 minutes using Groundwire on iOS

Postby Liptonbrisk » 06/15/2020

I'm not entirely sure what's going on, but I took a quick look at SIP log files from Groundwire, and there doesn't appear to be an Invite and an acknowledgement (ACK) between Groundwire and Freephoneline at the 15 minute mark. In turn, the call drops on the other end, but the Groundwire app doesn't receive "BYE" and doesn't automatically end the call. So, you'll get blank air on Groundwire's end (no RTP audio being sent), but really, the call has been disconnected on the other end. Freephoneline appears to be using 15 minute session timers. Without the re-invite and acknowledgement occurring at the 15 minute mark, the call can't continue.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 1311
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Calls are mute after 15 minutes using Groundwire on iOS

Postby Liptonbrisk » 06/16/2020

I've submitted a request to Freephoneline to ask to have the 15 minute session timer removed. I have no idea whether they'll agree or even whether my request will be read.

Putting the call on hold in Groundwire will force a Re-INVITE with the Freephoneline proxy server being used. So, provided you put the call on hold before 15 minutes is over, the call can continue, presumably for another 15 minutes. However, that's not an ideal situation. Users shouldn't have to remember to put the call on hold every 14 minutes.

There's another matter of why Groundwire isn't receiving the Re-INVITE request at all from Freephoneline at the 15 minute mark. I would guess the reason has something to do with how Freephoneline is handling or generating SIP headers, but since I can't see any INVITE at the 15 minute mark in Groundwire's logs, I have no idea what's causing the problem.

Asterisk users have the capacity to use canreinvite=no. But there's no way to do that in a number of SIP apps, including Groundwire.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 1311
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Calls are mute after 15 minutes using Groundwire on iOS

Postby Liptonbrisk » 06/16/2020

My Freephoneline ticket was closed without a response, so there’s nothing else I can do.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 1311
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Calls are mute after 15 minutes using Groundwire on iOS

Postby Liptonbrisk » 06/17/2020

Liptonbrisk wrote:e) "Outgoing calls need registration" should be disabled



As a result of the new 15 minute session timer that Freephoneline doesn't seem to want to remove (based on my ticket being closed without any response),
1. "Outgoing calls need registration" has to be enabled in Groundwire due to Freephoneline's new 15 minute session timers that weren't in place before. That means if you want to place an outgoing call to a regular landline or mobility number that lasts longer longer than 15 minutes, your FPL account on Groundwire needs to be registered. In turn, incoming calls won't work on any other device you've used to register the same FPL account.

Only one registration per FPL account is allowed at any time. When there are multiple devices/softphones using the same account, only the most recent registration is valid. The previous device will lose registration, and incoming calls will not work on it. Registration is required for incoming calls.

2. If you have "outgoing calls need registration" off in Groundwire, putting the call on hold in Groundwire will force a Re-INVITE with the Freephoneline proxy server being used. So, provided you put the call on hold before 15 minutes is over, the call can continue, presumably for another 15 minutes. However, that's not an ideal situation. Users shouldn't have to remember to put the call on hold every 14 minutes.

Those are the only workarounds I see at the moment.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 1311
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:5921EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin


Return to Community Support

Who is online

Users browsing this forum: Bing [Bot] and 6 guests