Page 1 of 1

Aastra 6731i delay after dialing

PostPosted: 09/10/2010
by visioncraft
I am using an Aastra 6731i IP phone. Overall, the configuration I am using works well in terms of sound quality, etc. There is one problem, however.

After dialing, the phone waits 30 seconds before completing the call. Adding a # after dialing does not help. I have tried using various dial plans, but all seem to have the same problem. (My current plan is: 1[2-9]XXXXXXXXX|416XXXXXXX|647XXXXXXX|905XXXXXXX|01155XXXXXXXXXX|011XXXXXXXXXX|911|411|311|211|*98)

Has anyone been successful using Aastra phones on freephonline.ca without the dialing delay? If so, what did you do?

Many thanks!

Re: Aastra 6731i delay after dialing

PostPosted: 09/10/2010
by visioncraft
I resolved the problem. It had nothing to do with the dialing plan, but instead with the DNS server. In the network section of the phone configuration, uncheck DHCP, then add Google's DNS as the Secondary DNS (8.8.8.8). If you are using a static IP address for the phone (as I am, via my router configuration), you can keep the DHCP box uncheck and specify both DNS servers (8.8.8.8 and 8.8.4.4). Or, if using DHCP, just keep the Secondary DNS as Google, recheck the Enabled box, and save the settings. No change to the defaul dialing plan is needed. I'll post the configuration files by themselves....

Aastra 6731i and similar configuration

PostPosted: 09/10/2010
by visioncraft
I managed to get the Aastra 6731i working with freephoneline.ca. It works great - I would highly recommend it.

Just watch the DNS server configuration in the Network section. Make sure to have a public DNS server as at least one of the servers. The phone configuration will automatically chose your router for one (which is really incorrect!). I use Google's DNS servers: 8.8.8.8 and 8.8.4.4

The network and SIP settings are attached here as a PDF. Note that you can configure multiple lines on this phone, so the Global settings are based on the default line. I've used 1647247000 as a sample phone number, so this and your account name, screen name, caller id, and password will need to be customised.

This same configuration should probably work on other Aastra phones using the same firmware, including 9143i, 9480i, and other 67xxi series phones.

Re: Aastra 6731i and similar configuration

PostPosted: 01/15/2014
by francisd84
Just a rectification that the delay problem mentionned here is not due to DNS. You must remove voip.freephoneline.ca from "Outboud Proxy Server" and "Registrar Server". Only keep "proxy server" with port 5060. The delay will disapear.

Tested with 9112i