Page 1 of 1

D-Link DIR 825

PostPosted: 02/19/2011
by badgerb0b
Has anyone got this router to work with SIP?
I have forwarded ports 13000, 13001, 5060, 5061, 6060 and 6061 and I cannot connect using the softphone. I have even moved the computer into the DMZ zone with out any results. Windows or any other firewall are not blocking these ports. I downloaded a port checking utility and it says all the ports are open except 5060?? I currently have a Shaw phone, could that be using this port and somehow causing a conflict? Any help is appreciated.

Re: D-Link DIR 825

PostPosted: 02/19/2011
by bridonca
Wow, another Dlink firmware that does a horrid job at SIP. This is what drives me nuts, the router is barely a year old, and for all the years it has been in the business, Dlink still has not figured out how to make a firmware that can properly forward ports! And this is a $100 router! That is inexcusable!

Ok, less rant, more solutions. One option is to get the latest firmware that is supposed to fix the problem. Maybe.

A much better option is to flash with DD-WRT, a much more stable firmware. Because the DD-WRT crew put out an open source firmware to forward ports properly since the beginning at least 5 years ago, you will have a better performing, stable router because of it. It has be constantly improved and debugged since then. unlike the garbage Dlink puts out.

There is always a chance your Windows firewall is messing things up. Your router already is a firewall, and the Windows firewall is worse than useless. Disable it.

Re: D-Link DIR 825

PostPosted: 02/20/2011
by badgerb0b
After hours and hours of trying different things I have fixed the problem. Even after flashing the router to the latest firmware 2.05NA, SIP would still not work.

Below is the fix copied from another forum.

"The problem with SIP on the DIR-825 A & B is that the SIP ALG firewall does not take into account port 5060 used my many VoIP service providers. To fix this, check the logs for outbound ports that are being blocked by the SIP ALG firewall. Go to Advanced, Application rules and add a rule, ie Voip for UDP port 5060, trigger and firewall, this will stop the port 5060 outbound blocked messages in the log.

Next assign the Voip TA a DHCP IP reservation under Setup, Network Settings then add the now static DHCP IP address to Advanced, QOS rules and only give that IP address, ie thru a Priority of 1, "Any" Protocol, ports 0 thru 65535. I recommend changing the VoIP TA IP address to, leaving the DHCP leased / expires in the 170 to 190 range. ie, what IP you assign on the router the TA will pick up based on mac address. Leave the Remote IP Range thru You must place the VoIP TA in the DHCP reservation list because the QOS Rules will not follow a DHCP IP lease expiration if your TA is assigned a new IP address by the router.

Limited to a number of SIP applications this router recognizes automatically, ie Skype, AIM Talk, Calista, ICQ, Pal Talk - all PC based applications, D-Link engineers did not take into account firewall settings for physical TA's like Vonage, ITPVoIP, and others. Your VoIP TA and service provider may be slightly different, but you get the idea how to use Status, Logs and Advanced, Application rules to open blocked outbound ports and use QOS firewall settings to prioritize VoIP traffic. If you follow this setup you will also eliminate the "Blocked outgoing ICMP packet (ICMP type 3)" message in logs."