Page 1 of 1

D-Link DVG-1120S

PostPosted: 02/26/2010
by djs5916
Managed to get a hold of the SIP version of this product :) , which has apparently been successfully used by other VOIP customers. I don't know if it is supported by but I'm willing to give it a try once I have my configuration file.

Any help regarding settings would be welcomed, but I can probably sort out a number of them by myself.

The major issues with this device appears to be related to where it is located on the users LAN. It doesn't work with NAT and requires its own public IP, although maybe it can be used in the DMZ.

I'm happy to post my settings if this works out OK.


Hints: 8-)

Re: D-Link DVG-1120S

PostPosted: 03/07/2010
by djs5916
Finally some luck in configuring the DVG-1120s using CallCentric's support for the DVG-1402s on

NOTE: Settings listed (other options in brackets)

Telephony Configuration ----------------------
Signaling ToS: 5 (0..7)
RTP ToS: 5 (0..7)
Receive Gain: -3 dB
Transmission Gain: -11 dB
DTMF Relay: RFC2833 (G.711,RFC2833)
Echo Cancel: enabled (enabled,disabled)
VAD: enabled (enabled,disabled)
Digital Timer: 4 sec
Hook Flash: 700 ms
Dial Pulse: PB ( PB,DP(20pps),DP(10pps) )
Call Waiting Alert Tone: enabled (enabled,disabled)
Area Code:

SIP Configuration - Server ------------------
Server FQDN: enabled (enabled,disabled)
IP Address: . . . (only selectable when Server FQDN is disabled)
Domain Name:
Port: 5060
Service Domain:
User Parameter Phone: enabled (enabled,disabled)
Timer T2: 4 sec (4,8,16,32)

Register Expiration: 3600 sec
Session Expires: 180 sec
Min-SE: 180 sec
Session Expires Refresher: uac (uac,uas)

Codec Priority & Packet Interval
G.711a-law: 5th (no-use,1st,2nd,3rd,4th,5th) 20 ms (10,20,30)
G.711u-law: 4th (no-use,1st,2nd,3rd,4th,5th) 20 ms (10,20,30)
G.723.1: 2nd (no-use,1st,2nd,3rd,4th,5th) 30 ms (30,60)
G.729a: 1st (no-use,1st,2nd,3rd,4th,5th) 20 ms (10,20,30)
G.726: 3rd (no-use,1st,2nd,3rd,4th,5th) 20 ms (10,20,30)

SIP Configuration - User Agent ----------------------------
Same Phone Number: disabled (enabled,disabled)
Index: 1 (1,2)
Phone Number: 1604283xxxx
Display Name: 1604283xxxx
Caller ID Delivery: YES (YES,NO)
Display CID: disabled (enabled,disabled)
User Agent Port: 5060
Authentication Username: 1604283xxxx
Authentication Password: <PASSWORD>
Confirm Password: <PASSWORD>


If there are any further tweaks available I hope others will contribute.

Note that without STUN support the DVG-1120s will not work attached to a NAT server (a typical router) unless appropriate UDP port forwarding and QoS is addressed or the 1120s is located in the DMZ. Generally it should be directly attached to the broadband modem first, and the home router WAN port can be attached to the 1120s "ETHERNET" or LAN port.

Hope this helps!


Re: D-Link DVG-1120S

PostPosted: 12/16/2010
by k-2
Thanks OP,
Any one can help.
I have cofigured my device but the problem I am facing I can call out but cannot call in. When trying calling in I get ROL saying "Customer you are trying to reach in unavailable".

It looks like my DID is not properly registered becuase all the settings looks good. I have cable modem& wireless router combined so wan port of my ATA (D-Link) is connected to a LAN port on router+cable modem.

I have added ip on my wan link to DMZ zone on modem+router and also have added 5060-6061 ports in port forwarding.

help will be highly appreciated.


Re: D-Link DVG-1120S

PostPosted: 12/16/2010
by laurent
Do you have G711 codec enabled? It's required to receive calls.

Re: D-Link DVG-1120S

PostPosted: 12/17/2010
by k-2
Yes I have G711 enabled still getting "The person you are trying to reach is not available, please record your message".

I am not sure if this observation will help. I am able to record VM and can play those from my online portal. It looks like freephoneline server is responding on my behalf and not even trying to send call to my device.

Re: D-Link DVG-1120S

PostPosted: 12/17/2010
by laurent
Actually, what most likely happens is that the FPL server tries to reach one, fails, and moves on the the voicemail as a backup.

3 typical causes for not receiving a call:
- g711 codec not available
- ports not forwarded
- ATA not registered properly

Re: D-Link DVG-1120S

PostPosted: 12/17/2010
by k-2
I have tried all possible options for these scenerios,
G711 selected,
ports are forwarded
Status light is solid green on D-Link

only thing I am not able to test is directly connect D-Link with my DSL modem as I have cable modem + wireless router combined (SMC)

I have also tried to add another router Trendnet between SMC and D-Link just thinking it might give me more options and control over this

thanks for your continious support

Re: D-Link DVG-1120S

PostPosted: 12/17/2010
by laurent
It's possible your forwarding is missing a tiny part to make it work properly. Can you provide a few screenshots of your configuration? I'D like to see the router's forwarding page for starters.

Re: D-Link DVG-1120S

PostPosted: 12/18/2010
by k-2
cannot add more than 3 attachements, please look at next post as well, if sustem allowed me to post another one

Re: D-Link DVG-1120S

PostPosted: 12/18/2010
by k-2

Re: D-Link DVG-1120S

PostPosted: 12/20/2010
by laurent
You seem to be doing everything properly, I can't spot anything wrong with these settings, assuming that the IP of th ATA is really set to .100

It's been said several times that a lot of routers don't play nice with VoIP traffic. Perhaps you could try and see if your router (heck, the ATA too) would have a firmware update available?

If you have cable modem (not DSL), I'd also suggest you try to put the ATA directly on the modem and see if that works.

Re: D-Link DVG-1120S

PostPosted: 12/21/2010
by djs5916
Don't know if you've tried to match the settings I used to get my DVG working, but I have spotted a couple of differences:

Telephony Config
DTMF Relay: RFC2833

SIP Config - Server:
Server FQDN: enabled

SIP Config - User Agent
Phone Number: 1604283xxxx
Display Name: 1604283xxxx
If I can remember that far back I seem to remember the DVG used the Display Name parameter in establishing the call, not the phone number. Any way, it's worth a try to make them the same.

Maybe you can check your other settings on the DVG to make sure they are similar.

Good luck.

Re: D-Link DVG-1120S

PostPosted: 03/26/2014
by cpospish
Just got my SIP information from FPL. I have a DLink DVG-1120S (I am on a very tight budget). I entered SIP values as per previous posts but no joy.
I am NOT using a router. Cable modem goes directly into the DVG-1120 WAN port. Internet works fine from LAN port to computer.
I have a dial tone, but when I dial any number it just results in a loud chirping noise. Will this older ATA no longer work with FPL?

OK, did lots of playing around and I got it to work at about 75%. I can now make out-going calls, but the incoming calls go right to voicemail. The phone does not ring. If I pick up the phone it is just a dial tone. My FPL voicemail is setup to go to voicemail after 4 rings. Does anyone know if this is a problem at my end or the FPL end?