Bug Report - Block Non-Contact Calls Blocks All Calls

Have a question or problem with your Fongo Mobile App? This forum is the place to get help from both staff and fellow community members.
Visit The Fongo Mobile Support Knowledge-base for more.

Bug Report - Block Non-Contact Calls Blocks All Calls

Postby MichaelVoIP » 05/27/2023

I submitted the bug report below to Fongo, but I am also posting it here, for comments. App version is 2023.5.1 and iOS version is 16.5.

Issue #1: When Account -> Settings -> Blocked Numbers -> Block Non-Contact Calls is set to ON, the app sends all calls to the voicemail, including the calls from numbers saved in Contacts. Clearly, this is incorrect and a bug in the system. It happens regardless if the number is stored in Contacts in the format +1 (xxx) xxx-xxxx, or xxx xxx xxxx. This function is equivalent to the function “Silence Unknown Callers” in iOS, but it does not work as the iOS function does.

Issue #2: When Account -> Settings -> Blocked Numbers -> Block Non-Contact Calls is set to OFF, the app does not recognize that a call from a number with caller ID in the format xxx xxx xxxx is the same as the format +1 (xxx) xxx-xxxx. For example, if an entry in Contacts is saved in the format +1 (xxx) xxx-xxxx and the call ID received is xxx xxx xxxx, the app does not recognize that these are the same number and displays the calling number (xxx xxx xxxx) instead of showing the name of the person calling. By comparison, iOS recognizes correctly that the two number formats are the same.

I trust Fongo could address these two issues in a timely manner.
MichaelVoIP
Quiet One
 
Posts: 34
Joined: 03/03/2012
SIP Device Name: Cisco SPA122
Firmware Version: 1.4.1(SR5)
ISP Name: EBox/Nexicom 50/10 Mbps
Computer OS: macOS Ventura 13.4
Router: Apple Time Capsule
Smartphone Model: iPhone 14 Pro Max
Android Version: No way!
iOS Version: 16.5

Re: Bug Report - Block Non-Contact Calls Blocks All Calls

Postby Liptonbrisk » 05/27/2023

MichaelVoIP wrote:Issue #1: When Account -> Settings -> Blocked Numbers -> Block Non-Contact Calls is set to ON, the app sends all calls to the voicemail, including the calls from numbers saved in Contacts.


I can’t reproduce this. Contacts, as defined within the app, are able to ring my Fongo Mobile number (not immediately sent to voicemail) when that setting is enabled on 2023.5.1 and when using iOS version 16.5. Call Forwarding is, of course, disabled when testing for incoming call issues, and SIP ALG is disabled in my router (I could use “Alternate Fongo Connection” instead). Rings Before Voicemail is also greater than 1. Failover for Fongo Mobile is voicemail. https://support.fongo.com/hc/en-us/arti ... ngo-Mobile

With respect to the second issue, I’m not aware of any ATA or IP Phone that blocks both number formats when only one is entered (without a rule being created for it, for example, in Obihai devices). So, I’m not going to bother testing to verify Fongo Mobile app behaviour since what you described is what I would have anticipated (given how FPL works with SIP devices). However, the suggestion seems reasonable to me.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 2693
Joined: 04/26/2010
SIP Device Name: Obihai 202/2182, Groundwire
Firmware Version: various
ISP Name: gateway/hub in bridge mode
Computer OS: Windows 64 bit
Router: Asuswrt-Merlin & others

Re: Bug Report - Block Non-Contact Calls Blocks All Calls

Postby MichaelVoIP » 05/29/2023

I use Fongo Mobile only when I travel. I am currently in the UK. With the Block Non-Contact Calls setting set to ON, if a call comes from a number which IS saved in Contacts - I tried ringing myself from my GV number - Fongo rings once or not at all, then the call goes straight to Voicemail. My Rings Before Voicemail is set to 8 and Call Forwarding to Never. I tried this on several Wi-Fi networks in the UK, as well on the local cellular network (Three), and the behaviour is consistent. (Note: I am not sure if the same behaviour happens when I’m in Canada, because I don’t use Fongo Mobile when in the country.)

Liptonbrisk wrote:I can’t reproduce this. Contacts, as defined within the app, are able to ring my Fongo Mobile number (not immediately sent to voicemail) when that setting is enabled on 2023.5.1 and when using iOS version 16.5. Call Forwarding is, of course, disabled when testing for incoming call issues, and SIP ALG is disabled in my router (I could use “Alternate Fongo Connection” instead). Rings Before Voicemail is also greater than 1. Failover for Fongo Mobile is voicemail. https://support.fongo.com/hc/en-us/arti ... ngo-Mobile
MichaelVoIP
Quiet One
 
Posts: 34
Joined: 03/03/2012
SIP Device Name: Cisco SPA122
Firmware Version: 1.4.1(SR5)
ISP Name: EBox/Nexicom 50/10 Mbps
Computer OS: macOS Ventura 13.4
Router: Apple Time Capsule
Smartphone Model: iPhone 14 Pro Max
Android Version: No way!
iOS Version: 16.5

Re: Bug Report - Block Non-Contact Calls Blocks All Calls

Postby Liptonbrisk » 05/29/2023

MichaelVoIP wrote:I use Fongo Mobile only when I travel. I am currently in the UK. With the Block Non-Contact Calls setting set to ON, if a call comes from a number which IS saved in Contacts - I tried ringing myself from my GV number - Fongo rings once or not at all, then the call goes straight to Voicemail.


Incoming calls from Google Voice numbers ring my Fongo Mobile numbers when that setting is enabled. I am not in the U.K., but unless being in the UK changes the prefix to GV's outbound CID number (seems unlikely), I don't see why that would affect anything with respect to call blocking.

The rule is (or should be since the last time I checked) either an inbound CID number matches a number in Fongo Mobile's contact list exactly, or it doesn't.

Login at https://account.fongo.com/admin/reports/call-logs/ (account-->call logs), select the current month, and click "submit". Look at the "From" field. The incoming number that is shown must match the number exactly in the Contact section of Fongo Mobile.

Note that GV calls to Fongo Mobile do not have a "1" (Fongo Mobile appears to recognize that 1 doesn't matter when blocking) or "+" in front of the outbound CID number in Fongo Mobile's call logs when I checked. Ensure that your GV number in Fongo Mobile's contact section matches exactly what you see under "From" at https://account.fongo.com/admin/reports/call-logs (admin-->call logs).

I can't reproduce your problem when using multiple Fongo Mobile accounts and when receiving calls from multiple Google Voice numbers.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 2693
Joined: 04/26/2010
SIP Device Name: Obihai 202/2182, Groundwire
Firmware Version: various
ISP Name: gateway/hub in bridge mode
Computer OS: Windows 64 bit
Router: Asuswrt-Merlin & others

Re: Bug Report - Block Non-Contact Calls Blocks All Calls

Postby MichaelVoIP » 05/29/2023

In the Fongo Mobile call logs, the number calling appears in the format: xxx-xxx-xxxx. In Contacts on iOS the number can be saved either as (xxx) xxx- xxxx or as +1 (xxx) xxx-xxxx. It cannot be saved as xxx-xxx-xxxx in iOS since iOS formats the number automatically.

The issue is not only with my GV number, I simply used this whilst in the UK for testing purposes. If Block Non-Contact Calls is set to ON, all calls from callers in Canada saved in my Contacts go to Voicemail - no exceptions. Sometimes there is a short ring but the call cannot be answered regardless, as it’s redirected to Voicemail.

After I’m back in Canada, in about three weeks, I shall test again… but I don’t expect anything different.

Liptonbrisk wrote:Incoming calls from Google Voice numbers ring my Fongo Mobile numbers when that setting is enabled. I am not in the U.K., but unless being in the UK changes the prefix to GV's outbound CID number (seems unlikely), I don't see why that would affect anything with respect to call blocking.

The rule is (or should be since the last time I checked) either an inbound CID number matches a number in Fongo Mobile's contact list exactly, or it doesn't.

Login at https://account.fongo.com/admin/reports/call-logs/ (account-->call logs), select the current month, and click "submit". Look at the "From" field. The incoming number that is shown must match the number exactly in the Contact section of Fongo Mobile.

Note that GV calls to Fongo Mobile do not have a "1" (Fongo Mobile appears to recognize that 1 doesn't matter when blocking) or "+" in front of the outbound CID number in Fongo Mobile's call logs when I checked. Ensure that your GV number in Fongo Mobile's contact section matches exactly what you see under "From" at https://account.fongo.com/admin/reports/call-logs (admin-->call logs).

I can't reproduce your problem when using multiple Fongo Mobile accounts and when receiving calls from multiple Google Voice numbers.
MichaelVoIP
Quiet One
 
Posts: 34
Joined: 03/03/2012
SIP Device Name: Cisco SPA122
Firmware Version: 1.4.1(SR5)
ISP Name: EBox/Nexicom 50/10 Mbps
Computer OS: macOS Ventura 13.4
Router: Apple Time Capsule
Smartphone Model: iPhone 14 Pro Max
Android Version: No way!
iOS Version: 16.5

Re: Bug Report - Block Non-Contact Calls Blocks All Calls

Postby Liptonbrisk » 05/29/2023

MichaelVoIP wrote:In the Fongo Mobile call logs, the number calling appears in the format: xxx-xxx-xxxx. In Contacts on iOS the number can be saved either as (xxx) xxx- xxxx


Those two are equivalent. The parentheses can be ignored. All of my GV contacts are stored in that format with no "+" or "1" in front.

I'm testing inbound calls using Canadian and U.S. numbers. None of them are stored with + or 1 prefix.


+1 (xxx) xxx-xxxx


It can be saved without the "+".

None of my Fongo Mobile contacts have "+" in front.

None of my U.S. contacts have "1" in front either since it's not required to complete calls.

I was wondering whether your contact numbers have a "+" in front.

The issue is not only with my GV number, I simply used this whilst in the UK for testing purposes. If Block Non-Contact Calls is set to ON, all calls from callers in Canada saved in my Contacts go to Voicemail - no exceptions. Sometimes there is a short ring but the call cannot be answered regardless, as it’s redirected to Voicemail.


I wanted to try to use the same services in order to reproduce the problem.
Again, I can't reproduce this on more than one Fongo Mobile account. I tested with Telus carrier numbers, Freephoneline (Fibernetics), and GV. I could test with more carriers, but that seems useless at this point. I tested on two different iPhones and with three different Fongo Mobile accounts.

I suppose I could try adding "+ 1" and testing.


After I’m back in Canada, in about three weeks, I shall test again… but I don’t expect anything different.


Provided all inbound calls to your Fongo Mobile number work for you when Block Non-Contact Calls is disabled while you're in the U.K., I have no clue what's going on.
Incoming calls for you aren't showing up as 00 1 area code phone number.

Reply to your ticket (if you have one open), and provide Fongo Mobile call log entries (from, to, time of call) for them to refer to if needed, please.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 2693
Joined: 04/26/2010
SIP Device Name: Obihai 202/2182, Groundwire
Firmware Version: various
ISP Name: gateway/hub in bridge mode
Computer OS: Windows 64 bit
Router: Asuswrt-Merlin & others

Re: Bug Report - Block Non-Contact Calls Blocks All Calls

Postby Liptonbrisk » 05/29/2023

Liptonbrisk wrote:I suppose I could try adding "+ 1" and testing.


Surprisingly, to me, this made no difference.

I entered a contact that appears as +1xxxxxxxxxx for a GV contact within the Fongo Mobile app, called Fongo Mobile from that GV number (Fongo Mobile call logs see it as xxxxxxxxxx), and the incoming call worked when Block Non-Contact Calls was enabled.

+1 is recognized and works properly.
By the way, this means I can't reproduce issue #2 either. Stored contact name appeared. I should have tested before simply guessing that I could reproduce your issue. I can't.

So, I give up for now.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 2693
Joined: 04/26/2010
SIP Device Name: Obihai 202/2182, Groundwire
Firmware Version: various
ISP Name: gateway/hub in bridge mode
Computer OS: Windows 64 bit
Router: Asuswrt-Merlin & others


Return to Community Support

Who is online

Users browsing this forum: No registered users and 8 guests