Page 1 of 1

[Resolved] No outgoing audio with PAP2T

PostPosted: 04/22/2021
by nvieira
Hi all. I've been using FPL with a PAP2T for years without issue. However about a week ago, two-way audio stopped working completely. I could place and receive calls but neither party could hear anything once the connection was established.

I made this config change to the PAP2T after searching the forums:

2) In your PAP2T, Navigate to the SIP tab-->NAT Support Parameters, and make sure that the following settings are enabled:
(Thanks to Mango)
a)Handle VIA received-->yes
b)Handle VIA rport-->yes
c)Substitute VIA Addr-->yes

This fixed 50% of the problem. I can now hear the other party, but they still can't hear me; regardless of whether it's an outgoing or incoming call. I've installed the FPL desktop app and verified that two-way audio does indeed work from within my network so I don't think it's a router / NAT issue.

Would appreciate any suggestions of what to try next. Thanks.

Re: No outgoing audio with PAP2T

PostPosted: 04/22/2021
by Liptonbrisk
nvieira wrote: so I don't think it's a router / NAT issue.

Not necessarily. The server specified in the ATA could be different than the one used in the desktop app in addition to other possibilities.
What it does mean, however, is that you should be able to get FPL working for you with your ATA.

Follow the steps below, slowly and carefully, in the order listed:

1) Try another phone first to ensure there isn't a physical problem with the transmitter/microphone. Check all cords to ensure they aren't loose.

2) Try calling the Toronto or Vancouver number listed at Try the echo test.
If you hear yourself, then the problem is likely to be on the end of the people you're calling, in particular if they're using a SIP service, such as Freephoneline.

You can probably stop at this point if you do hear yourself unless the problem occurs with all numbers you dial.

3) In your ATA, specify "" (without the quotation marks) for proxy. Refer to page 6 from download/file.php?id=1722

The purpose of is to help circumvent a buggy SIP ALG feature in routers. It doesn't matter if you're not using Rogers. works for anyone.

4) What brand and model modem are you using?
If you're using a modem/router combo or Hub issued by your ISP, contact your ISP to ask for assistance for disabling SIP ALG.

5) What brand and model router are you using?
a) Make sure whatever modem/router combo or Hub your ISP gave you is in bridge mode if you are using your own router. Call/contact your ISP if you have to.

b) Try disabling SIP ALG if you're using own router:

To understand why SIP ALG often causes horrible problems, please visit (scroll down to the section on SIP ALG problems).

6) Login to your ATA. Specify a high random SIP port in your ATA between 30000 and 60000.
Navigate to Line 1 (or whatever you're using for FPL)-->SIP settings, change SIP Port to a random number between 30000 and 60000.
Do not use the same random SIP port for any other Line. Always choose a different random local SIP port for each Line you're using.

Using a high random SIP port may help to bypass SIP ALG, and it also helps to avoid SIP Scanners (or hackers).
Also, changing local SIP port will reset a potential corrupted NAT association that developed between your router and ATA due to UDP timeouts, but that shouldn't be related to this specific issue.

7) In the ATA, navigate to Voice-->SIP tab-->NAT Support Parameters, and make sure that the following settings are enabled:

a)Handle VIA received-->yes
b)Handle VIA rport-->yes
c)Substitute VIA Addr-->yes
d) NAT Keep Alive Interval--> 20 seconds

d) click "Save Settings" button

This helps to ensure the RTP audio stream is being sent to your WAN IP as opposed to your LAN IP.

8. Navigate to Voice-->Line (whichever you use for FPL)-->NAT settings
a) NAT Mapping Enable should be yes
b) NAT Keep Alive Enable should be yes
c) NAT Keep Alive Msg should be $NOTIFY

d) click "Save Settings" button if changes were made

9) Log in your ATA, navigate to Voice-->Line-->Proxy and Registration-->Register Expires needs to be 3600 seconds (it probably already is set to 3600)

This is not related to your issue, but timers are important, so check anyway.

10) Navigate to Voice-->SIP-->SIP Timer Values (sec)
Reg Retry Intvl should be 120 seconds

Click "Save Settings" button if changes were made

Many older guides for FPL don't include this setting.
This is not related to your issue, but timers are important, so check anyway.

10) Proper device reboot order is always modem (wait for it to be fully up before turning on your)-->router (ensure Wi-Fi SSIDs are populated first on your devices)-->ATA (wait for router to be fully up and running before turning on ATA). That's always proper device reboot order.

11) Try the echo test in step 2 again.


Note that only one registration per FPL account is allowed at any time. When there are multiple devices/softphones using the same account, only the most recent registration is valid. The previous device will lose registration, and, consequently, incoming calls will not work on it. This is especially important to consider if someone else is using your SIP credentials (username and password) that are found after logging in at or if you're trying to register your FPL account with a smartphone SIP app/FPL desktop application or with another device. Registration is required for incoming calls. It is not required for outgoing calls. A more significant concern, though, is that multiple registration attempts can lead to temporary IP bans. The more devices being used can make the temporary ban happen more quickly. Note that each time you reboot or restart your ATA or FPL desktop application, it's attempting to register with Freephoneline again. Multiple registration attempts within a short period can result in temporary IP ban. Each time you reboot your ATA it's attempting to register with FPL's proxy server.

Re: No outgoing audio with PAP2T

PostPosted: 04/27/2021
by nvieira
Thanks for all your suggestions.

After trying most of the suggestions and still having the issue, I was almost certain it was my PAP2T device. I had already tried a myriad of other _software_ based VOIP/SIP clients and they all worked fine. So I borrowed a HT802 and it had the exact same issue! I had restarted my router (OpenWRT based) several times but never the ISP's (Shaw) modem (Hitron). I avoided touching the modem because of the disruption it would cause to my customers. But late last night, in desperation, I power cycled the modem and lo and behold, the outgoing audio issue was resolved on both the PAP2T and HT802. I'm at a loss to explain why software VOIP/SIP clients worked fine but the two different hardware clients didn't. I guess the adage "reboot everything" holds true.

Re: No outgoing audio with PAP2T

PostPosted: 04/27/2021
by Liptonbrisk
nvieira wrote: ISP's (Shaw) modem (Hitron)

To help avoid encountering this issue again, follow the steps below, step by step:

1) Contact Shaw to enable bridge mode in the Hitron gateway or Hitron modem/router combo:
They can do it. But you have to call them since the feature to enable bridge mode is hidden in the UI.
One of my family member's is with Shaw. They had to call Shaw to get their Hitron gateway in bridge mode.

2) I haven't used OpenWRT, but you may be able to adjust UDP timeouts (see #4 below). You may be able to ask here:


ip_conntrack_udp_timeout_stream is Assured

ip_conntrack_udp_timeout is Unreplied

But late last night, in desperation, I power cycled the modem and lo and behold, the outgoing audio issue was resolved

I'm glad your issue is resolved. You shouldn't have to do step 10 (from my original post) as often once bridge mode is enabled with UDP timeouts adjusted (refer to step #4 below).

the two different hardware clients didn't.

It was likely NAT related.

Re: No outgoing audio with PAP2T

PostPosted: 04/27/2021
by Liptonbrisk
(Generic info)

Typically, for VoIP SIP services, especially for Freephoneline/Fongo, you want

1) a router that does not have a full cone NAT,

Visit ... -punching/.
Mango from the forums writes,
“Use a restricted cone NAT router, and do not use port forwarding or DMZ. Restricted cone NAT will only permit
inbound traffic from the service provider you're registered to. If you have a full cone NAT router, it will allow traffic
from any source. This is probably not what you intend.
If you have a Windows computer, you can test your router using the utility here:,22292023. To run it, use stun from a command prompt.”
Essentially, you download the file; extract the stun.exe file from within the zip file to an easily
accessible location; use an elevated command prompt (visit ... inistrator); change directory (cd) to the
directory or location where you extracted stun.exe (visit ... c-commands); and type “stun” without
the quotation marks followed by the enter/return button on your keyboard.
Asus routers, at the time of this writing, produce port restricted cone NAT routers, for example and are fine,
provided you’re using one with Asuswrt-Merlin, third party firmware installed.

2) a router that lets you disable SIP ALG if it's buggy,

To understand why SIP ALG often causes horrible problems, please visit (scroll down to the section on SIP ALG problems).

If you're dealing with a modem/router combo issued by an ISP or a router with SIP ALG forced on, you may have
to use for the Proxy Server. The purpose of is to circumvent
faulty SIP ALG features in routers.

3) a router that allows you to set QoS or assign highest priority to your ATA or IP Phone over all other devices on your LAN (local area network),

For a very general description of what QoS can do for you, visit
The basic idea is if you're torrenting or have a bunch of other computers, smartphones, tablets, etc. downloading and uploading (hogging all your available bandwidth), you don't want
your ATA not to have access to enough bandwidth to make or receive calls properly. So QoS or a Bandwidth Monitor feature (which is just another form of QoS) is a really good idea for VoIP users.

I often get an occasional relative complaining to me, "Hey my calls sound choppy." And then when I go visit, some kids are playing MMOs on a computer, while another person is downloading a huge file,
and another person is backing up files to a cloud service all at the same time someone else is trying to talk on the phone. All those devices, without QoS enabled, are fighting over available bandwidth along with the ATA.

and 4) A router that lets you adjust both Unreplied and Assured UDP timeouts.

Thanks to Mango, many of us now understand that in order for ATAs to remain registered and working properly with a VoIP SIP provider like Freephoneline, in particular after power failures, the following conditions must be met:

UDP Unreplied Timeout (in your router) < NAT Keep-alive Interval (in your ATA; for Obihai ATAs this is X_KeepAliveExpires; for Grandstream, the setting is SIP OPTIONS Keep Alive Interval) < UDP Assured Timeout (in your router) < SIP Registration Failure Retry Wait Time (or RegisterRetryInterval in Obihai ATAs)

“<“ means less than.

When a modem leases a new IP address, a problem can arise where prior associations using the old IP address are maintained in the router. When the ATA attempts to communicate using the old IP address, the response is unreplied, and then if the UDP Unreplied timeout is greater than the Keep Alive Interval (and UDP Unreplied timeout is often set to 30 by default in consumer routers) a problem arises where the corrupted connection persists. If UDP Unreplied timeout is, for example, 15, and the NAT Keep Alive Interval is 20, then the corrupted connection will timeout or close. A new connection will be created, and everything will work fine.

Another problem can occur when the Keep-Alive interval is greater than UDP Assured Timeout (often 180 by default in consumer routers): the NAT hole will close due to the ATA not communicating frequently enough with the SIP server. In turn, incoming calls may, intermittently, not reach the ATA. Again, X_Keepalives expires is supposed to be 20 with FPL.

(the above settings are making reference to those in Obihai ATAs)

Getting access to both UDP Unreplied Timeout and UDP Assured Timeout settings in consumer routers may be difficult, if not impossible. Asuswrt-Merlin (I would avoid any model below/less powerful than an RT-AC68U), third party firmware for Asus routers, does offer easy access to these two settings, which are found under General–>Tools-->Other settings. My understanding is that third party Tomato firmware has these two settings as well. So if your router supports Tomato firmware, that may be another option. Note that I will not be held accountable any damage resulting from failed firmware updates. Apparently, Mikrotik routers also allow users to change both Assured and Unreplied UDP timeout settings as well: ... #p28056619.

Router firmware that allows users to adjust Assured and Unreplied UDP timeouts include


The keep alive interval for FPL is 20. The SIP Registration Failure Retry Wait Time is 120. I use 15 for UDP Unreplied Timeout and 115 for UDP Assured Timeout.

ISPs do not issue customers routers that can do all four things I just listed. Typically it's far better to have your own router with strong QoS functions and a restricted cone NAT firewall,
disable whatever SIP ALG feature is enabled in the router, and stick whatever modem/router combo your ISP gives you into bridge mode. For Bell Hubs, visit ... r-1993629/. For Rogers, visit ... ridgemodem.