No outgoing calls - Grandstream HT801 and pfSense

Have a question or problem with your Fongo application? This forum is the place to get help from both staff and fellow community members.
Fongo recommends Fongo Home Phone for a fully supported Home Phone system for only $4.95/mo
Post Reply
09uoijh
Just Passing Thru
Posts: 2
Joined: 12/31/2023
SIP Device Name: Grandstream HT801
Firmware Version: 1.0.51
Router: pfSense

No outgoing calls - Grandstream HT801 and pfSense

Post by 09uoijh »

Hi all,

Set up FPL on my Grandstream HT801 with latest firmware. Incoming calls work perfectly, but outgoing calls just yield a fast busy. Looking at the logs, I see an error 500, service unavailable.


HT801 --- 2023-12-31 17:51:37.587 RECEIVING FROM redacted:6060
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 192.168.1.2:34056;branch=z9hG4bK333003253;rport=34056;received=redacted
From: "redacted" <sip:redacted@voip4.freephoneline.ca:6060>;tag=1114463430
To: <sip:redacted@voip4.freephoneline.ca:6060>
Call-ID: 1627484533-34056-10768@BJC.BGI.B.C
CSeq: 105861 INVITE
Server: Fongo Home Phone Proxy
Content-Length: 0


HT801 --- 2023-12-31 17:51:37.903 RECEIVING FROM redacted
SIP/2.0 500 Service Unavailable
Via: SIP/2.0/UDP 192.168.1.2:34056;branch=z9hG4bK333003253;rport=34056;received=WANIPADDRESS
From: "redacted" <sip:redacted@voip4.freephoneline.ca:6060>;tag=1114463430
To: <sip:redacted@voip4.freephoneline.ca:6060>;tag=d7837ce6bbd631122d10546eb75bb4cf-bbaf
Call-ID: 1627484533-34056-10768@BJC.BGI.B.C
CSeq: 105861 INVITE
Server: Fongo Home Phone Proxy
Content-Length: 0


Dial plan in use which i found on these forums:
{911|<311=5148720311>|<411=18005551212>|<511=18883550511>|<811=18003613977>|x11|*xx|[2-9]xxxxxxxxx|1xxxxxxxxxx|011xxxxxxxxxxxx.|^1900x.|^1976x.}


My router is pf Sense and i have source port rewriting disabled. Before I go through the difficulty of trying a different router, does anyone have any ideas? Dount there's a router issue if the incoming calls work perfectly, right?
User avatar
Liptonbrisk
Technical Support
Posts: 2772
Joined: 04/26/2010
SIP Device Name: Obihai 202/2182, Groundwire
Firmware Version: various
ISP Name: FTTH
Computer OS: Windows 64 bit
Router: Asuswrt-Merlin & others

Re: No outgoing calls - Grandstream HT801 and pfSense

Post by Liptonbrisk »

09uoijh wrote: I see an error 500, service unavailable.
Refer to https://www.ietf.org/rfc/rfc3261.txt (pages 189 and 190)

SIP error code 500 means Internal Server Error, but for 503, which is Service Unavailable, if no Retry-After is provided, the client acts as if it
received a 500 (Server Internal Error) response.

I expect last night was busy with calls, generally. Do you still receive the same error right now?
I can make outbound calls while registered with voip4.freephoneline.ca:6060 right now.

So if you didn't change anything and if outbound calls work for you now, that suggests either server congestion or a problem at the other end of the call.

Also, log in at https://www.freephoneline.ca/callLogs, select "current and previous month", and see if the failed calls are listed. If they are, check the "disconnect reason".



HT801 --- 2023-12-31 17:51:37.903 RECEIVING FROM redacted
SIP/2.0 500 Service Unavailable
Via: SIP/2.0/UDP 192.168.1.2:34056;branch=z9hG4bK333003253;rport=34056;received=your WAN IP address
From: "redacted" <sip:redacted@voip4.freephoneline.ca:6060>;tag=1114463430
To: <sip:redacted@voip4.freephoneline.ca:6060>;tag=d7837ce6bbd631122d10546eb75bb4cf-bbaf
Call-ID: 1627484533-34056-10768@BJC.BGI.B.C
CSeq: 105861 INVITE
Server: Fongo Home Phone Proxy
Content-Length: 0
You pasted your WAN IP address for "received". I've removed it.

By the way, your setup guide is located at viewtopic.php?f=15&t=20252#p79162.

a) Ensure in your ATA that "SIP REGISTER Contact Header Uses:" is set to "WAN Address".

b) Ensure that you're not attempting to send anonymous outbound caller ID and that your Name field in the ATA doesn't have "anonymous" in it. Just use your first name and last name.
Also don't use *67.

c) Dial *31 to ensure caller ID is being sent.


Dial plan in use which i found on these forums:
{911|<311=5148720311>|<411=18005551212>|<511=18883550511>|<811=18003613977>|x11|*xx|[2-9]xxxxxxxxx|1xxxxxxxxxx|011xxxxxxxxxxxx.|^1900x.|^1976x.}
Tha'ts outdated. There's no need to define n11 numbers, mostly: visit https://support.fongo.com/hc/en-us/arti ... 1-911-etc-.
https://www.fongo.com/government-service-numbers/
211,311,511, and 811 are all supported by Freephoneline for Quebec. It is unnecessary to change a default dialplan to support those service numbers.

The default Grandstream ATA dialplan should work.

Before I go through the difficulty of trying a different router, does anyone have any ideas?
You can rule out pfSense by connecting the ATA directly the modem (or modem/router combo, gateway, or hub you were issued by your ISP while it's in bridge mode, briefly. Keep in mind that if it's in bridge mode, nothing will be protecting your ATA).
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at http://forum.fongo.com/viewforum.php?f=15.
09uoijh
Just Passing Thru
Posts: 2
Joined: 12/31/2023
SIP Device Name: Grandstream HT801
Firmware Version: 1.0.51
Router: pfSense

Re: No outgoing calls - Grandstream HT801 and pfSense

Post by 09uoijh »

Thanks for your help. I double checked the options and found that SRTP was set to “enabled, not forced”. When I set it to disabled both incoming and outgoing calls are now working well.

I have also restored the default dial plan. Only issue now is *98 for voicemail doesn’t work it just reads back my phone number (may be a grand stream specific setting). I will play with it some more. Not a huge issue since VMs go to email anyway.
User avatar
Liptonbrisk
Technical Support
Posts: 2772
Joined: 04/26/2010
SIP Device Name: Obihai 202/2182, Groundwire
Firmware Version: various
ISP Name: FTTH
Computer OS: Windows 64 bit
Router: Asuswrt-Merlin & others

Re: No outgoing calls - Grandstream HT801 and pfSense

Post by Liptonbrisk »

09uoijh wrote:Thanks for your help. I double checked the options and found that SRTP was set to “enabled, not forced”. When I set it to disabled both incoming and outgoing calls are now working well.
Thanks for reporting back. I'm glad the issue wasn't server congestion.

Freephoneline doesn't support SRTP. Was "enabled, not forced" the default setting?
I have also restored the default dial plan. Only issue now is *98 for voicemail doesn’t work it just reads back my phone number (may be a grand stream specific setting).
Okay, I see at some point Grandstream added *98 as a code that the ATA can process: https://documentation.grandstream.com/w ... _Guide.pdf (page 8).
"Dial *98 to announce the extension number of the port." I wasn't aware of that. The ATA is processing the *98 code instead of sending it through Freephoneline.

1. a) Dial ***
b) Then dial 02
c) Enter the IP address you hear into a web browser.
d) Login to your ATA.

Default login password is admin.

2. Navigate to FXS Port tab being used-->scroll down to "Call Features Settings"
a. Is "98" listed anywhere or any setting? If so, disable the corresponding call feature. Set it to "No".
b. Alternatively, set "Enable Call Features" to "No".

Click the "Update" button.

3. Ensure SUBSCRIBE for MWI is set to No. Freephoneline sends unsolicited MWI.
This is unrelated to the specific issue you're describing, but check regardless.

At default, *98 should be permitted to dial through FPL in the dial plan. If not, a rule needs to be added to your dialplan. Try adding "*98" separated by "|".

For example, try {[2345689]11|988|*98|[2-9]xxxxxxxxx|1[2-9]xxxxxxxxx|011xx.} for your dialplan.

Alternatively, you could try *xx instead of *98, but that means allow * plus any two digits to send via Freephoneline; and the only star code FPL supports at default account settings is *98, as far as I know. I would want other star codes to be processed by the ATA.


Lastly, you can reach voicemail by dialing your own FPL number.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at http://forum.fongo.com/viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
Posts: 2772
Joined: 04/26/2010
SIP Device Name: Obihai 202/2182, Groundwire
Firmware Version: various
ISP Name: FTTH
Computer OS: Windows 64 bit
Router: Asuswrt-Merlin & others

Re: No outgoing calls - Grandstream HT801 and pfSense

Post by Liptonbrisk »

I do see this: https://forums.grandstream.com/t/98-fun ... mber/57144.

However, it must be possible for *98 to work via the ITSP (Freephoneline, in this case) for voicemail. Otherwise, I don't see how Fongo is using HT-801s for Fongo Home Phone.
*98 instructions for Fongo Home Phone are listed at https://support.fongo.com/hc/en-us/arti ... Home-Phone.
Fongo Home Phone sells HT-801s: https://support.fongo.com/hc/en-us/arti ... HT-801-ATA.

You might want to use the same firmware version that Fongo Home Phone does: viewtopic.php?f=15&t=20506.


Also, this person dialed *98 on an HT-802 to check voicemail: viewtopic.php?t=19942#p78085.


Anyway, try setting "Enable Call Features" to "No", and try {[2345689]11|988|*98|[2-9]xxxxxxxxx|1[2-9]xxxxxxxxx|011xx.} for your dialplan.

If you want an explanation for this plan,[2345689]11 means the digits 2,3,4,5,6,8, and 9 can be dialed before 11.
So 211,311,411,511,611,811, and 911 can be sent through FPL.

988 is for the suicide prevention hotline.

https://support.fongo.com/hc/en-us/arti ... 1-911-etc-

*98 is for voicemail.

[2-9] means any single digit from 2 to 9
x represents any digit
011xx. means a minimum of 2 digits is required after 011 (for international calls). You can change the number of x's if you want. However, I often see dial plans with 011 followed by 11 or 12 x's, which won't work if the international call happens to require less digits. You can't call Niue from Canada using "011xxxxxxxxxxxx.", for example.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at http://forum.fongo.com/viewforum.php?f=15.
Post Reply