[Resolved] FPL no registration response using FreePBX

Have a question or problem with your Fongo application? This forum is the place to get help from both staff and fellow community members.
Fongo recommends Fongo Home Phone for a fully supported Home Phone system for only $4.95/mo
Post Reply
Must
Just Passing Thru
Posts: 3
Joined: 09/28/2017
SIP Device Name: Asterisk w FreePBX
Firmware Version: fpbx12
ISP Name: Compton cable
Computer OS: MacOS
Router: Cisco

[Resolved] FPL no registration response using FreePBX

Post by Must »

I have used freephoneline with asterisk quite successfully for many years, seems to work well and lets us have phones at both ends of the house and in the basement. Our telephone use is low so I can't justify paying a subscription fee to Fongo or Bell or whatever.

Our old machine with Asterisk 8 running on RHEL 6 has apparently gone past it's best-before date and is now not working. As a result I am trying to bring things back to life with FreePBX and Asterisk 16 using the old configuration data. It seems that freephoneline is not rejecting the registration but isn't responding to it either. Any ideas what the issue could be?

outgoing settings:
username=PHONE_NUMBER
type=peer
secret=PASSWORD
host=voip.freephoneline.ca

incoming settings:
type=user
secret=PASSWORD
context=from-trunk

registration string:
PHONE_NUMBER:PASSWORDk@voip.freephoneline.ca/PHONE_NUMBER

What I see in the log now is messages like this
[2024-01-04 22:53:55] NOTICE[6314] chan_sip.c: -- Registration for 'PHONE_NUMBER@voip.freephoneline.ca' timed out, trying again

In the above "PHONE_NUMBER" is the full 11-digit phone number and "PASSWORD" is the SIP password copied from my connection details on the freephoneline.ca site.

This is happening for both our number and my daughter's number that was associated with the phone in her room.

When I had typed in the password incorrectly it returned with an error so I have confidence that it is getting there. I wish that FFL would give an actionable error so I knew what to look into fixing.

Thanks for any thoughts that could help this
Must
Just Passing Thru
Posts: 3
Joined: 09/28/2017
SIP Device Name: Asterisk w FreePBX
Firmware Version: fpbx12
ISP Name: Compton cable
Computer OS: MacOS
Router: Cisco

FreePhoneLine (FPL) no registration response using FreePBX

Post by Must »

I had FFL working fine for years on Asterisk 8 on RHEL 6 managed by some old version of FreePBX but it has finally died so I am trying to move to a new machine, this with a new FreePBX install and Asterisk 16, yay?

Well almost everything is fine but FFL won't connect, isn't even giving an error. I have done the copy-paste thing for the secret from the FFL page into the SIP config so I am sure that the secret is correct and as well I have verified that the the proxy address is correct and the correct codecs are the only ones enabled and yet :

1019[2024-01-04 23:53:56] NOTICE[6314] chan_sip.c: -- Registration for '1FPLnumber@voip.freephoneline.ca' timed out, trying again (Attempt #3)
1020[2024-01-04 23:53:56] NOTICE[6314] chan_sip.c: -- Registration for '1FPLnumber@voip.freephoneline.ca' timed out, trying again (Attempt #3)

Yes, the registration delay is set to 3600 seconds.

Any idea what I don't have set correctly?
User avatar
Liptonbrisk
Technical Support
Posts: 2770
Joined: 04/26/2010
SIP Device Name: Obihai 202/2182, Groundwire
Firmware Version: various
ISP Name: FTTH
Computer OS: Windows 64 bit
Router: Asuswrt-Merlin & others

Re: FreePhoneLine (FPL) not responding when using FreePBX

Post by Liptonbrisk »

Generally, I've decided to stop trying to assist with FreePBX/Asterisk because I'm not using it and don't want to spend time setting it up again and troubleshooting.

Use voip4.freephoneline.ca:6060 while troubleshooting to help avoid potential SIP ALG issues.
Also, if a server isn't responding, check to see whether you can ping it and whether you haven't been temporarily IP banned by a proxy server.
If you can't ping the server, check for a DNS issue.

registertimeout needs to be 120 seconds to help avoid potential IP bans for too many registration attempts within a short interval.
If you've been temporarily IP banned by a specific proxy server, try a different one.

"As May 2013, our servers will rate limit REGISTER requests to a maximum of 10 requests per 5 minutes. Each authentication round usually consumes 2 requests (digest auth), so it is a fair number given our guidelines."
https://community.freepbx.org/t/trunk-s ... ca/22479/8

If that rate limit has changed since then, I'm not aware. I've encountered being temporarily IP banned before by a proxy a long time ago. It's annoying, and I'm not going to try to reproduce it by testing.

Being temporarily IP banned can occur when using registration timers with short intervals with Freephoneline.

Other than using what's posted in the thread at viewtopic.php?f=15&t=19601, I suggest asking at https://community.freepbx.org/, particularly if no one else responds here.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at http://forum.fongo.com/viewforum.php?f=15.
Must
Just Passing Thru
Posts: 3
Joined: 09/28/2017
SIP Device Name: Asterisk w FreePBX
Firmware Version: fpbx12
ISP Name: Compton cable
Computer OS: MacOS
Router: Cisco

Re: FreePhoneLine (FPL) no registration response using FreeP

Post by Must »

Well, by the time this was approved I have it sorta registering with a slightly different logon string

PHONE_NUMBER:PASSWORDk@voip.freephoneline.ca/PHONE_NUMBER:5060~3600

Asterisk reports "request sent" for registration but no response. But I can now call out, incoming calls seem to get lost but that could be due to some remembered routing trying to send things to the old machine.

For others struggling, the outbound SIP setting is just
username=PHONE_NUMBER
type=peer
secret=PASSWORD
host=voip.freephoneline.ca

And inbound is:
type=user
secret=PASSWORD
context=from-trunk

Though inbound is not reaching Asterisk yet, I suspect some networking issue.

Now, changing to use a pjsip trunk using just the phone number and password it just worked. Calls in and out work with sound just fine and with NO explicit port fowards set up through the router either! Hopefully this helps someone else.
User avatar
Liptonbrisk
Technical Support
Posts: 2770
Joined: 04/26/2010
SIP Device Name: Obihai 202/2182, Groundwire
Firmware Version: various
ISP Name: FTTH
Computer OS: Windows 64 bit
Router: Asuswrt-Merlin & others

Re: FreePhoneLine (FPL) no registration response using FreeP

Post by Liptonbrisk »

Must wrote: Now, changing to use a pjsip trunk using just the phone number and password it just worked. Calls in and out work with sound just fine
That appears to coincide with what was mentioned by ilneofita: viewtopic.php?f=15&t=19601&p=81034#p81034.

Anyway, I'm glad your situation is resolved. Thank you for reporting back.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at http://forum.fongo.com/viewforum.php?f=15.
Post Reply