Page 1 of 1

Doesn't pick up input keys during a bot menu during a conver

Posted: 01/13/2024
by pa1lab
With freephoneline I don't know how to solve this problem, it happened 2-3 times, example I chat to a bank employee and to authenticate himself, he plays a voice message and to accept the terms or enter your PIN you have to use the keys on the phone. I enter the necessary keys but they don't get anything. The voicemail message does not pick up any digits. What can be done about it?

I'm using the GrandStream HT801

Re: Doesn't pick up input keys during a bot menu during a co

Posted: 01/13/2024
by Liptonbrisk
It's a DTMF issue.
Ensure that you don't use a hands-free speaker mode on your phone the next time you call your bank.

The problem may be isolated to the system that your bank uses.

You can check whether all phone buttons are recognized by calling the free 416 or 250 numbers listed at http://thetestcall.blogspot.com. Wait for voice message. Press # to end echo test.
Press 2 to enter DTMF testing. Press all digits on phone number pad. Press #. What you pressed should be read back to you.
If that works, then all the buttons on your phone are fine, and the current DTMF setting the ATA is using worked for the specific system being called.


By the way, the latest Grandstream firmware version for your ATA is 1.0.51.1: https://www.grandstream.com/support/firmware.
That firmware version added an option to "Force DTMF to be sent via SIP INFO simultaneously".



For the bank, try these steps:

1a) Dial ***
b) Then dial 02
c) Enter the IP address you hear into a web browser.
d) Login to your ATA.

Default login password is admin.


2. Navigate to FXS Port tab used for Freephoneline-->Preferred DTMF method (in listed order)

Priority 1 should be RFC2833
Priority 2 should be In-audio
Priority 3 should be SIP INFO

3. Change "Disable DTMF Negotiation" to "Yes (use above DTMF order without negotiation)"

4. Use First Matching Vocoder in 200OK SDP should be "No"


5. Preferred Vocoder
(in listed order):

choice 1: PCMU

The only codecs that Freephoneline supports are G.711u (PCMU) and G729a (which sounds worse than PCMU).

Don't use G729a for banking or DTMF. I would set all choices to PCMU.


6. Click "Apply" and "Reboot"

Re: Doesn't pick up input keys during a bot menu during a co

Posted: 01/15/2024
by pa1lab
Hi, thanks for your help, my grandStream is already up to date, I did the testcall and everything seems to work for the DTMF.
The Preferred DTMF method was already in the right order.
The only change I made was Change "Disable DTMF Negotiation" to "Yes (use above DTMF order without negotiation).
I'll see in the near future if my problem returns.

Re: Doesn't pick up input keys during a bot menu during a co

Posted: 01/15/2024
by Liptonbrisk
pa1lab wrote: I'll see in the near future if my problem returns.
If the bank is TD, visit viewtopic.php?f=38&t=20580&p=81019#p81016 for a related thread.