[Resolved] Calls from certain numbers go to VM.

Have a question or problem with your Fongo application? This forum is the place to get help from both staff and fellow community members.
Fongo recommends Fongo Home Phone for a fully supported Home Phone system for only $4.95/mo

[Resolved] Calls from certain numbers go to VM.

Postby Jas63 » 11/23/2021

No issues with making & receiving any calls.
But last few months when get call from a specific phone #, it just goes to VM, phone never rings or missed call on my phone display.

The number carrier is...
Carrier:TELUS Alberta/1

I first thought my cordless phone blocking it, but it does not have any such feather, then I check my VoIP device, same.
How do I get this fixed?

No network or firewall issue, all calls come & I can make outgoing without issue, only 1 specific number.

Under website call logs, it shows
Disconnect reason as "Normal call clearing"

Please help.



Some additional info:
Product Model: HT802

Hardware Version: V1.6A Part Number -- 9610003716A
Software Version: Program -- 1.0.11.6 Bootloader -- 1.0.11.1 Core -- 1.0.11.2 Base -- 1.0.11.5
CPE -- 1.0.1.118
Software Status: Running Mem: 20628
System Up Time: 08:55:11 up 22 days
CPU Load: 16%
Network Cable Status: Up 100Mbps Full
PPPoE Link Up: Disabled
NAT: Unknown NAT
Port Status:
Port Hook User ID Registration
FXS 1 On Hook 1778XXXXXXX Registered
FXS 2 On Hook Not Registered
Jas63
Just Passing Thru
 
Posts: 11
Joined: 11/23/2021
SIP Device Name: Grandstream HT802
Firmware Version: 1.0.11.6
ISP Name: TELUS
Computer OS: Windows 7
Router: pfSense

Re: Specific phone number (landline) goes to VM.

Postby Jas63 » 11/23/2021

Firewall/Gateway is
pfSense 2.5.2-RELEASE
Jas63
Just Passing Thru
 
Posts: 11
Joined: 11/23/2021
SIP Device Name: Grandstream HT802
Firmware Version: 1.0.11.6
ISP Name: TELUS
Computer OS: Windows 7
Router: pfSense

Re: Specific phone number (landline) goes to VM.

Postby Liptonbrisk » 11/23/2021

Latest firmware for your ATA can be found at http://www.grandstream.com/support/firmware

Follow the steps below, step by step, down the list.


1. Are you using a Telus Wi-Fi Hub?
For Telus Wi-Fi Hubs, put LAN port 1 on the Hub in bridge mode (I've had to go through this process before for a family member). Then connect pfSense router/gateway to LAN port 1.
Alternatively, contact Telus and ask them how to enable bridge mode.

2. Make sure you're not using Siproxd, which is similar to SIP ALG, in pfSense. It wouldn't make sense that you are using Siproxd, but you might want to double check to ensure it's not installed. Or make sure that it's disabled.

A number of people using Asus routers have had to disable SIP Passthrough, which is the setting for SIP ALG in Asus routers, to get incoming calls from Rogers working:
http://forum.fongo.com/viewtopic.php?f=8&t=20211#p79016
viewtopic.php?f=8&t=20182#p78916 (Fido is Rogers)
I realize this isn't a Rogers issue, but it could be SIP ALG related (in either the Telus Hub or with Siproxd).

3. Ensure the ATA is not running behind a VPN.

4. In your ATA, set Primary SIP Server to "voip4.freephoneline.ca:6060" without the quotation marks. The purpose of voip4.freephoneline.ca:6060 is to help circumvent buggy SIP ALGs (which is why bridge mode in Telus Hub should be enabled and Siproxd not installed).
Apply changes.


5. Ensure that (in your ATA)

a)SIP REGISTER Contact Header Uses "WAN Address"

b) NAT Traversal: "Keep-Alive"

c) Register Expiration: 60 minutes

d) SIP Registration Failure Retry Wait Time: 120 seconds

e) OPTIONS/NOTIFY Keep Alive is set to anything other than NO

f) SIP OPTIONS/NOTIFY Keep Alive Interval is 20 seconds

g) Use Random SIP Port: YES

h) Use Random RTP Port: YES

Apply changes.

6. Reboot Modem/Telus Hub. Wait for it to be fully up and running. Reboot pfSense device. Wait for it to be fully up and running. Reboot ATA
This is always proper device reboot order.

7. a. Login at https://www.freephoneline.ca/showSipSettings
b. Ensure that SIP Status shows "connected"
c. SIP User Agent reflects the ATA you're using

8. Navigate to https://www.freephoneline.ca/voicemailSettings
a. Ensure Rings Before Voicemail is not set to 1.
b. Change Rings before voicemail to 12. Click "Update".
c. Change Rings before voicemail to 5 (or something reasonable). Click "Update".

9. Dial *79 to disable Do Not Disturb just in case.

10. Test again with incoming call from Telus number

11. If 10 doesn't work, try testing with the ATA connected directly to the Telus Hub LAN port 1 to rule out pfSense being the issue.

By the way, kiekar believed all incoming calls weren't working, but incoming calls from Bell carrier numbers worked while others (unspecified carrier) didn't. After reinstalling a fresh version of pfSense (not a backup of the config file), all incoming calls worked: viewtopic.php?f=38&t=20221&p=79059#p79060.

12. Do incoming calls from other Telus numbers from that same area code work? If so, then submit a ticket: https://support.fongo.com/hc/en-us/requests/new
Provide the phone number that doesn't work in the ticket and mention that it's a Telus carrier number. You will likely receive an automated response, but hopefully someone will take a look without automatically closing the ticket.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 2019
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:8680EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Specific phone number (landline) goes to VM.

Postby Jas63 » 11/23/2021

Liptonbrisk wrote:Latest firmware for your ATA can be found at http://www.grandstream.com/support/firmware

Follow the steps below, step by step, down the list.


1. Are you using a Telus Wi-Fi Hub? NO
For Telus Wi-Fi Hubs, put LAN port 1 on the Hub in bridge mode (I've had to go through this process before for a family member). Then connect pfSense router/gateway to LAN port 1.
Alternatively, contact Telus and ask them how to enable bridge mode.

2. Make sure you're not using Siproxd, which is similar to SIP ALG, in pfSense. It wouldn't make sense that you are using Siproxd, but you might want to double check to ensure it's not installed. Or make sure that it's disabled. NO

A number of people using Asus routers have had to disable SIP Passthrough, which is the setting for SIP ALG in Asus routers, to get incoming calls from Rogers working:
http://forum.fongo.com/viewtopic.php?f=8&t=20211#p79016
viewtopic.php?f=8&t=20182#p78916 (Fido is Rogers)
I realize this isn't a Rogers issue, but it could be SIP ALG related (in either the Telus Hub or with Siproxd).

3. Ensure the ATA is not running behind a VPN. NO

4. In your ATA, set Primary SIP Server to "voip4.freephoneline.ca:6060" without the quotation marks. The purpose of voip4.freephoneline.ca:6060 is to help circumvent buggy SIP ALGs (which is why bridge mode in Telus Hub should be enabled and Siproxd not installed).
Apply changes.That is what I have


5. Ensure that (in your ATA)

a)SIP REGISTER Contact Header Uses "WAN Address" Just changed from LAN to WAN

b) NAT Traversal: "Keep-Alive" YES

c) Register Expiration: 60 minutes YES

d) SIP Registration Failure Retry Wait Time: 120 seconds Changed from 20 to 120

e) OPTIONS/NOTIFY Keep Alive is set to anything other than NO

f) SIP OPTIONS/NOTIFY Keep Alive Interval is 20 seconds Changed from 30 to 20

g) Use Random SIP Port: YES Do you really need this, I have already port forwarding enabled for a specific one?

h) Use Random RTP Port: YES Do you really need this, I have already port forwarding enabled for a specific one?

Apply changes.

6. Reboot Modem/Telus Hub. Wait for it to be fully up and running. Reboot pfSense device. Wait for it to be fully up and running. Reboot ATA
This is always proper device reboot order.

7. a. Login at https://www.freephoneline.ca/showSipSettings
b. Ensure that SIP Status shows "connected"
c. SIP User Agent reflects the ATA you're using

SIP Status: connected
SIP User Agent: Grandstream HT802 1.0.11.6



8. Navigate to https://www.freephoneline.ca/voicemailSettings
a. Ensure Rings Before Voicemail is not set to 1.
b. Change Rings before voicemail to 12. Click "Update".
c. Change Rings before voicemail to 5 (or something reasonable). Click "Update".
Just changed 6

9. Dial *79 to disable Do Not Disturb just in case. Confirmed

10. Test again with incoming call from Telus number

11. If 10 doesn't work, try testing with the ATA connected directly to the Telus Hub LAN port 1 to rule out pfSense being the issue. (will try that too... don't think that should be issue as all other calls comes fine)

By the way, kiekar believed all incoming calls weren't working, but incoming calls from Bell carrier numbers worked while others (unspecified carrier) didn't. After reinstalling a fresh version of pfSense (not a backup of the config file), all incoming calls worked: viewtopic.php?f=38&t=20221&p=79059#p79060.

12. Do incoming calls from other Telus numbers from that same area code work? If so, then submit a ticket: https://support.fongo.com/hc/en-us/requests/new
Thanks will try that last
Provide the phone number that doesn't work in the ticket and mention that it's a Telus carrier number. You will likely receive an automated response, but hopefully someone will take a look without automatically closing the ticket.
Jas63
Just Passing Thru
 
Posts: 11
Joined: 11/23/2021
SIP Device Name: Grandstream HT802
Firmware Version: 1.0.11.6
ISP Name: TELUS
Computer OS: Windows 7
Router: pfSense

Re: Specific phone number (landline) goes to VM.

Postby Liptonbrisk » 11/23/2021

Jas63 wrote:
1. Are you using a Telus Wi-Fi Hub? NO


What is the brand and model modem being used? If it's a Telus modem/router combo or gateway, ensure that it's in bridge mode so that SIP ALG is not enabled in it and that its router features can not interfere in any manner.
Sometimes the devices that ISPs issue to customers can be the source of the problem.



e) OPTIONS/NOTIFY Keep Alive is set to anything other than NO


I hope you have either NOTIFY or OPTIONS selected.

g) Use Random SIP Port: YES Do you really need this, I have already port forwarding enabled for a specific one?


I want to mention a couple of points here:

1. Port forwarding is a security risk. Do not use UDP 5060 or 5061 for the local SIP port and forward it. You'll just be opening yourself up to SIP Scanners/hackers.
Those are well-known ports to target for attacks.

If you don't want to use the random sip port setting, I recommend specifying a high, random, local SIP port in your ATA between 30000 and 60000. Just pick a UDP port number in that range (provided it's not being used by anything else on your LAN). Do not use the same random SIP port for any other Line. Always choose a different random local SIP port for each FPL account you're using.

Using a high random sip port may help avoid SIP ALG issues and sip scanners.

You'd have to specify the UDP local SIP port you want to use in the ATA, and then forward it, if you absolutely need to port forward. Port forwarding should
only be used if the service doesn't work without it.

2. Using random SIP port can help with one of the problems mentioned in point D from viewtopic.php?f=8&t=20199#p78976.

But no, it's not a requirement. Otherwise other ATAs and IP Phones that don't have the random SIP port setting wouldn't work.

h) Use Random RTP Port: YES Do you really need this, I have already port forwarding enabled for a specific one?


Not absolutely required, but see above.

They're recommended: https://support.freephoneline.ca/hc/en- ... redentials
"Local SIP Port: RANDOM

Local RTP Port: RANDOM"

Grandstream HT802 1.0.11.6


ATA firmware hasn't been updated to 1.0.33.4
https://firmware.grandstream.com/Releas ... 0.33.4.pdf
https://firmware.grandstream.com/Releas ... 0.33.4.zip
I will not be held responsible for failed firmware updates.


Liptonbrisk wrote:By the way, kiekar believed all incoming calls weren't working, but incoming calls from Bell carrier numbers worked while others (unspecified carrier) didn't. After reinstalling a fresh version of pfSense (not a backup of the config file), all incoming calls worked: viewtopic.php?f=38&t=20221&p=79059#p79060.


That link might be worth taking a look at. Again, try testing with the ATA connected directly to whatever modem (again, if it's a modem/router combo or gateway, ensure that it's in bridge mode so that its router features can't possibly interfere or block anything) Telus gave you to rule out whether pfsense is involved in the problem.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 2019
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:8680EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Specific phone number (landline) goes to VM.

Postby Jas63 » 11/23/2021

Liptonbrisk wrote:
Jas63 wrote:
1. Are you using a Telus Wi-Fi Hub? NO


What is the brand and model modem being used? If it's a Telus modem/router combo or gateway, ensure that it's in bridge mode so that SIP ALG is not enabled in it and that its router features can not interfere in any manner.
Sometimes the devices that ISPs issue to customers can be the source of the problem.

TELUS fiber box Nokia terminates into pfSense which gets Public IP.

e) OPTIONS/NOTIFY Keep Alive is set to anything other than NO

It's NOTIFY

I hope you have either NOTIFY or OPTIONS selected.

g) Use Random SIP Port: YES Do you really need this, I have already port forwarding enabled for a specific one?


I want to mention a couple of points here:

1. Port forwarding is a security risk. Do not use UDP 5060 or 5061 for the local SIP port and forward it. You'll just be opening yourself up to SIP Scanners/hackers.
Those are well-known ports to target for attacks.
Thanks I moved to random high number.... although it should not have matter, as I set source DNS to voip4.freephoneline.ca.

If you don't want to use the random sip port setting, I recommend specifying a high, random, local SIP port in your ATA between 30000 and 60000. Just pick a UDP port number in that range (provided it's not being used by anything else on your LAN). Do not use the same random SIP port for any other Line. Always choose a different random local SIP port for each FPL account you're using.

Using a high random sip port may help avoid SIP ALG issues and sip scanners.

You'd have to specify the UDP local SIP port you want to use in the ATA, and then forward it, if you absolutely need to port forward. Port forwarding should
only be used if the service doesn't work without it.

2. Using random SIP port can help with one of the problems mentioned in point D from viewtopic.php?f=8&t=20199#p78976.

But no, it's not a requirement. Otherwise other ATAs and IP Phones that don't have the random SIP port setting wouldn't work.

h) Use Random RTP Port: YES Do you really need this, I have already port forwarding enabled for a specific one?


Not absolutely required, but see above.

They're recommended: https://support.freephoneline.ca/hc/en- ... redentials
"Local SIP Port: RANDOM

Local RTP Port: RANDOM"

Grandstream HT802 1.0.11.6


ATA firmware hasn't been updated to 1.0.33.4
https://firmware.grandstream.com/Releas ... 0.33.4.pdf
https://firmware.grandstream.com/Releas ... 0.33.4.zip
I will not be held responsible for failed firmware updates.

Surely, I will update it :)

Liptonbrisk wrote:By the way, kiekar believed all incoming calls weren't working, but incoming calls from Bell carrier numbers worked while others (unspecified carrier) didn't. After reinstalling a fresh version of pfSense (not a backup of the config file), all incoming calls worked: viewtopic.php?f=38&t=20221&p=79059#p79060.


That link might be worth taking a look at. Again, try testing with the ATA connected directly to whatever modem (again, if it's a modem/router combo or gateway, ensure that it's in bridge mode so that its router features can't possibly interfere or block anything) Telus gave you to rule out whether pfsense is involved in the problem.
Jas63
Just Passing Thru
 
Posts: 11
Joined: 11/23/2021
SIP Device Name: Grandstream HT802
Firmware Version: 1.0.11.6
ISP Name: TELUS
Computer OS: Windows 7
Router: pfSense

Re: Specific phone number (landline) goes to VM.

Postby Liptonbrisk » 11/23/2021

Jas63 wrote:TELUS fiber box Nokia terminates into pfSense which gets Public IP.


Okay, I've never tested with just the ONT. I have no feedback on whether that setup works with FPL without any issues.
I do know using the Telus Wi-Fi Hub works with a LAN port on the hub set to bridge and when also connecting to another router that's configured properly. I've helped someone set that up remotely before.

In theory using the ONT instead should work, but I do know people who have tried to completely eliminate the Bell Hub (modem/router combo) in Ontario, and they experience an issue (with NAT acceleration enabled in Asus routers) that stops two-way audio from working. The Bell Hub is required.

Test with some more incoming calls from Telus, Koodo, and Public Mobile numbers. See if any of these calls reach the ATA.
If the problem is with all Telus carrier numbers, then I suspect either an issue with pfsense configuration or using the ONT instead of a modem.
If the problem is with just one Telus number, then I would submit a ticket.
Since the call is going straight to voicemail without reaching the ATA, there's nothing I can look at. There would be no syslog to collect from the ATA, and there would be no data available to capture locally (unless the call is somehow being blocked by pfsense).
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 2019
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:8680EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Specific phone number (landline) goes to VM.

Postby Liptonbrisk » 11/24/2021

Is this incoming call from someone you know? Or did you receive voicemail spam from a spoofed (or faked) number?

Login at https://www.freephoneline.ca/doGetCallLogs
Did the call come in twice, one right after the other?

The way ringless voicemail spam works is a spammer calls you twice almost simultaneously. When the second call reaches voicemail, the first call is disconnected, and quite often this process is so fast, there’s no ring or only a very short, tiny sound. The second call will drop to voicemail due to the first making the system busy. Then the spammer can leave a pre-recorded message.
This process is all automated. Apparently, some debt collection agencies use that method in addition to advertisers or spammers.

I suspect it's not a spammer since you know that the call is from a Telus landline, but I thought I'd ask just in case.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 2019
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:8680EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Specific phone number (landline) goes to VM.

Postby Liptonbrisk » 11/29/2021

Jas63 wrote:
I first thought my cordless phone blocking it, but it does not have any such feather, then I check my VoIP device, same.


It does, by the way.

Page 36 of the admin guide for your ATA mentions a blacklist for incoming calls feature: http://www.grandstream.com/sites/defaul ... _guide.pdf.

You would find that feature under the advanced settings section of your ATA's web user interface.

Also
https://forums.grandstream.com/t/ht802- ... king/44167
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 2019
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:8680EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Specific phone number (landline) goes to VM.

Postby Jas63 » 12/14/2021

blacklist for incoming calls is BLANK

Also upgraded the firmware as well...
Hardware Version: V1.6A Part Number -- 9610003716A
Software Version: Program -- 1.0.33.4 Bootloader -- 1.0.33.1 Core -- 1.0.33.1 Base -- 1.0.33.3
CPE -- 0.21.9.23


Finally, connect it directly to WAN, so ATA gets Public IP address, so I could test without any firewall.
Same result.


Also same issue with someone else incoming as well...
Phone Number: 1778214XXXX
Carrier: Rogers Wireless-SVR/2
Is Wireless: y

Phone Number:
1780450XXXX
Carrier: TELUS Alberta/1
Is Wireless: n


So, one is TELUS & other is Roger's
One is landline & other is cell.

Their may be many others, but these are so far I got informed as they reached me on my cell to tell me that.
Have them tested, same results.

So not firewall issue
Many of the calls comes & rings phone without issue... hope someone could please help.

Email the support 2 weeks back, no response.
Jas63
Just Passing Thru
 
Posts: 11
Joined: 11/23/2021
SIP Device Name: Grandstream HT802
Firmware Version: 1.0.11.6
ISP Name: TELUS
Computer OS: Windows 7
Router: pfSense

Re: Specific phone number (landline) goes to VM.

Postby Jas63 » 12/14/2021

I will try soft phone as well.

If that also same, that means not even related to ATA, how can I get my account fixed if the issue of fongo side?
Jas63
Just Passing Thru
 
Posts: 11
Joined: 11/23/2021
SIP Device Name: Grandstream HT802
Firmware Version: 1.0.11.6
ISP Name: TELUS
Computer OS: Windows 7
Router: pfSense

Re: Specific phone number (landline) goes to VM.

Postby Liptonbrisk » 12/14/2021

Jas63 wrote:I will try soft phone as well.

If that also same, that means not even related to ATA


Do you see the calls that go to voicemail listed after logging in at https://www.freephoneline.ca/doGetCallLogs?
Copy and paste each row, for the calls in question, when submitting a ticket.

It might still be the ONT instead of using Telus Hub, but that seems very unlikely.

1) Do you have a SIP app (Acrobits Groundwire, for example) on your smartphone, using cellular data, that you can try? Make sure the registration expiry ("Expires" in Groundwire) or interval is 3600 seconds (1 hour) in the SIP app.

Unplug the ATA when testing on your smartphone, and make sure to use cellular data (disable Wi-Fi) to avoid using your LAN. When (with FPL's SIP credentials/VoIP unlock key) there are multiple devices/softphones/lines using the same account, only the most recent registration is valid. The previous device will lose registration, and, consequently, incoming calls will not work on it. This is especially important to consider if someone else is using your SIP credentials (username and password) that are found after logging in at https://www.freephoneline.ca/showSipSettings or if you're trying to register your FPL account with a smartphone SIP app (or FPL desktop app) or with another device. Registration is required for incoming calls. It is not required for outgoing calls. Only one registration per FPL account is allowed at any time. A single line on an ATA is one registration. A SIP app is another. A more significant concern, though, is that multiple registration attempts can lead to temporary IP bans. The more devices being used with the exact same FPL account can make the temporary ban happen more quickly. Each time you reboot or restart your ATA or SIP app, it's attempting to register with Freephoneline again. Multiple registration attempts within a short period can result in temporary IP ban.

2) If #1 also fails (make sure that at least some incoming calls work when testing on the smartphone SIP app), then it seems unlikely that the problem has anything to do with you. At that point you should be submitting a ticket. If no one responds to it, private message me: ucp.php?i=pm&mode=compose&u=1229.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 2019
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:8680EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Specific phone number (landline) goes to VM.

Postby Liptonbrisk » 12/14/2021

Jas63 wrote: it just goes to VM


Freephoneline's voicemail system, right?


phone never rings or missed call on my phone display


Do you mean that you see "missed call" on your phone? Or do you mean that you never see "missed call" on your phone?

"missed call" means the call is reaching your ATA.
Not only is the call reaching your ATA, but it's reaching your phone.
Have you tried a different phone? Check all phone wires and cords, and ensure that they are plugged in securely. Try a different phone cord.

If you never see "missed call", then nevermind.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 2019
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:8680EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Specific phone number (landline) goes to VM.

Postby Jas63 » 12/14/2021

Thanks a lot, I had ATA offline (unplugged).
Installed VoIP APP "freephoneline".... finally as APP requires 32bit JAVA to work.
Have the other party call me, it seems the call went through.

So it looks like ATA... which sucks... as I don't know what could be causing... could it be different SIP server compare to ATA that may cause this. Don't know what would cause, its not random... its always same phone numbers that would not work. So its not network NAT issue as most calls come in, but the ones that don't are same ones.
Jas63
Just Passing Thru
 
Posts: 11
Joined: 11/23/2021
SIP Device Name: Grandstream HT802
Firmware Version: 1.0.11.6
ISP Name: TELUS
Computer OS: Windows 7
Router: pfSense

Re: Specific phone number (landline) goes to VM.

Postby Jas63 » 12/14/2021

ok, pfsense I found this
162.213.111.21
host-162-213-111-21.static.295.ca


Does this belongs to Fongo?
Jas63
Just Passing Thru
 
Posts: 11
Joined: 11/23/2021
SIP Device Name: Grandstream HT802
Firmware Version: 1.0.11.6
ISP Name: TELUS
Computer OS: Windows 7
Router: pfSense

Re: Specific phone number (landline) goes to VM.

Postby Jas63 » 12/14/2021

ok, finally found the solution....

in pfsense you have to allow incoming from these 2 IPs.
162.213.111.21
208.65.240.44


Seems to be IPs belonging to Fongo servers.
Its working now.

Likely these are load balancing, Fango incoming server IPs change based on source phone number, it seems.
Jas63
Just Passing Thru
 
Posts: 11
Joined: 11/23/2021
SIP Device Name: Grandstream HT802
Firmware Version: 1.0.11.6
ISP Name: TELUS
Computer OS: Windows 7
Router: pfSense

Re: Specific phone number (landline) goes to VM.

Postby Liptonbrisk » 12/14/2021

Why are you reporting your own thread as "containing illegal pirate links" and closing it? :?
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 2019
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:8680EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Specific phone number (landline) goes to VM.

Postby Liptonbrisk » 12/14/2021

Jas63 wrote:162.213.111.21
Does this belongs to Fongo?


Yes, that's voip4.freephoneline.ca:6060 at the moment.
You stated you were already registering using that proxy server earlier in this thread.

I'm not sure how you managed to register with voip4.freephoneline.ca:6060 while, previously, not unblocking 162.213.111.21 in pfsense.

viewtopic.php?f=8&t=20272#p79269

Liptonbrisk wrote:
In your ATA, set Primary SIP Server to "voip4.freephoneline.ca:6060" without the quotation marks. The purpose of voip4.freephoneline.ca:6060 is to help circumvent buggy SIP ALGs (which is why bridge mode in Telus Hub should be enabled and Siproxd not installed). Apply changes.


Jas63 wrote:.That is what I have


Jas63 wrote:SIP Status: connected
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 2019
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:8680EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: Specific phone number (landline) goes to VM.

Postby Liptonbrisk » 12/14/2021

Jas63 wrote:ok, finally found the solution....

in pfsense you have to allow incoming from these 2 IPs.
162.213.111.21
208.65.240.44


Seems to be IPs belonging to Fongo servers.
Its working now.

Likely these are load balancing, Fango incoming server IPs change based on source phone number, it seems.




208.65.240.44 is voip.freephoneline.ca
162.213.111.21 is voip4.freephoneline.ca

That has nothing to do with load balancing.

Those are FPL's proxy servers.

The other is voip2.freephoneline.ca, which is currently 162.213.111.22.

Anyway, I'm glad FPL is working for you.

I'm going to mark this thread as "Resolved".
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 2019
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:8680EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: [Resolved] Specific phone number (landline) goes to VM.

Postby Jas63 » 12/14/2021

Thanks Liptonbrisk :)
I wanted to lock it so others with similar issues able to see the solution.

Yes, it is very strange. It does registered, that's how I was able to make & receive calls.
But certain phone numbers will go to VM, while most would work without any issue, that's why I never expected firewall issue.

I tried both voip.freephoneline.ca & voip4.freephoneline.ca, same results.
Finally allowed these 2 IPs, originally had DNS names allowed, so likely fongo must have updated DNS records to point to new IPs.

For now I have left primary as "voip." server, This likely means PFsense has bugs that allows UDP traffic through once a while....maybe.

That also does not make sense either, as its always same phone number, where as the one working never went to VM, they all come through.
Jas63
Just Passing Thru
 
Posts: 11
Joined: 11/23/2021
SIP Device Name: Grandstream HT802
Firmware Version: 1.0.11.6
ISP Name: TELUS
Computer OS: Windows 7
Router: pfSense

Re: [Resolved] Specific phone number (landline) goes to VM.

Postby Liptonbrisk » 12/14/2021

Okay, I’m still not sure why you reported this thread as containing pirate links, but I’m glad the problem is fixed.

I’m also glad to learn that ONT works for FPL without needing a Telus Hub. That’s good to know for future reference.
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 2019
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:8680EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin

Re: [Resolved] Calls from certain numbers go to VM.

Postby Jas63 » 01/22/2022

ok, another major update, issue returned back few days later.

I spend nearly 2 months.
**removed**

I had to purpose build gateway for packet sniffing & monitor the traffic.

Please don't trust the ** they give you, just allowing SIP servers using port forwarding is not enough.
When the request hits their server, that trigger, secondary IPs that makes RTP connections.

The permanent fix is....

Open
RTP ports to allow traffic from
208.85.218.150 (unknown IP belongs to FIBERNETICS CORPORATION, SHADY STUFF)
208.85.218.149 (unknown IP belongs to FIBERNETICS CORPORATION)
208.65.240.44 (primary SIP server)
162.213.111.21 (secondary SIP server)

So here is what you all need to do, regardless of what firewall, gateway, modem, router you have....

In your SIP ATA VoIP box, select random number for
SIP & RTP port

change it from 5060 to like 43682 (random number) for SIP
Do same for RTP so example 48691

Next
In your router Port forwarding,
Create 8 rules

Source 208.85.218.150
Source port: XXXX/any/*

Destination: 192.168.x.x (your ATA IP address)
Dest port: 43682-43683

Source 208.85.218.150
Source port: XXXX/any/*

Destination: 192.168.x.x (your ATA IP address)
Dest port: 48691


Repeat this step for each of the 4 IP addresses.


So end you should see 8 rules, 2 for each IP address.



If everything set correctly, make incoming call, check you can hear audio & then make outgoing calls, do same.
Jas63
Just Passing Thru
 
Posts: 11
Joined: 11/23/2021
SIP Device Name: Grandstream HT802
Firmware Version: 1.0.11.6
ISP Name: TELUS
Computer OS: Windows 7
Router: pfSense

Re: [Resolved] Calls from certain numbers go to VM.

Postby Liptonbrisk » 01/23/2022

Please don't trust the ** they give you, just allowing SIP servers using port forwarding is not enough.


I don't need to create any port forwarding rules at all, but I'm not using pfsense.

When the request hits their server, that trigger, secondary IPs that makes RTP connections.


That's always been the case. I didn't mention RTP IPs because I thought your issue was fixed, but I did here for this other pfSense user:

viewtopic.php?f=8&t=20294#p79409
Liptonbrisk wrote:
10. If that doesn't work, also allow incoming from 208.85.218.149 and 208.85.218.150 (FPL's RTP IPs for the media/audio stream)




208.85.218.150 (unknown IP belongs to FIBERNETICS CORPORATION, SHADY STUFF)


Fibernetics having other IPs/servers isn't "shady".
Please do not send me emails; I do not work for nor represent Freephoneline or Fongo. Post questions on the forums so that others may learn from responses or assist you. Thank you. If you have an issue with your account or have a billing issue, submit a ticket here: https://support.fongo.com/hc/en-us/requests/new. Visit http://status.fongo.com/ to check FPL/Fongo service status. Freephoneline setup guides can be found at viewforum.php?f=15.
User avatar
Liptonbrisk
Technical Support
 
Posts: 2019
Joined: 04/26/2010
SIP Device Name: OBi202
Firmware Version: 3.2.2 (Build:8680EX)
ISP Name: Cable
Computer OS: Windows 10 x64 Pro
Router: Asuswrt-Merlin


Return to Community Support

Who is online

Users browsing this forum: No registered users and 4 guests